質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

87.34%

[python3.8] ライブラリ matplotlib のインストールでエラーの原因が分かりません

解決済

回答 2

投稿

  • 評価
  • クリップ 0
  • VIEW 4,432

score 6

前提・実現したいこと

matplotlibでグラフを描写しようと思ったのですが,
コマンドプロンプトで pip install matplotlib を入力実行するとものすごいエラーを吐かれてしまったのですが,何が原因か,どうしたら良いのか分かりません・・・助けて下さい

補足情報

エラー画面
イメージ説明
イメージ説明
イメージ説明

茶色の長方形で塗りつぶしてある箇所にはユーザ名が入っています
3枚目の最後にpipバージョンを新しくしろとあったので新しくして再度matplotlib入れてみましたが変わりませんでした

補足情報

matplotlibを入れる前,以下のライブラリを入れました.
pip
pyserial
setuptools
six
(これらは正常に入りました)

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 2

checkベストアンサー

0

python3.8はまだ新しいバージョンのため、主要ライブラリでも対応が終わっていないものがあります。当分の間はpython3.7以前のものを使うことをおすすめします。一度python3.8をアンインストールし、改めて3.7以前のバージョンのpythonで環境を構築してください。

Matplotlib - python matplotlib インストールエラー|teratail
Python - matplotlibをインストールできない|teratail

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2019/11/23 23:31

    3.7にダウングレードする前に最後にもう1回だけ3.8で試したところ,すんなり入りました.
    時間を返してほしいです.
    ありがとうございました.

    キャンセル

  • 2019/11/24 02:33

    なるほど、ちょうど22日にアップデートされて3.8対応のwheelが配布されるようになったのですね。お知らせいただきありがとうございます。
    https://pypi.org/project/matplotlib/

    キャンセル

  • 2019/11/25 12:31

    追記です.
    3.8にて(質問時と同じ環境で)pip install matplotlibしたところすんなり入り,pip listにもmatplotlibが表示されていたのですが,
    いざPycharmでプログラムしようとするとPycharmではmatplotlibが反映されず,Pycharmからmatplotlibを入れ直そうとしてみましたがエラーが出ました....

    結局以前に使用していた環境の3.6にダウングレードすることにしました.(3.6では全て問題なく動作しています.時間を返してほしい)

    キャンセル

0

こちらと同じ事象と思われるので,Python 3.7にしてみてください.

https://teratail.com/questions/222261

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2019/11/22 15:34

    今日3.7にダウングレードする前に最後にもう1回だけ3.8で試したところ,すんなり入りました.
    時間を返してほしいです.
    ありがとうございました.

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 87.34%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る