質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

88.34%

Xcode 11.2.1 でcocapodsのAlamofireのmodule map fileが見つからずbuildできない

解決済

回答 1

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 1,962

Shichi7

score 22

Xcode11.2.1にアップデートしました。

おそらく、Podfileが影響してXcode 11.2ではbuildできていたものが通らなくなりました。
以下のエラーが出ています。

追記:
新しくプロジェクトを作成してみて、Alamofireの4.8.2(バグが出ているプロジェクトと同じバージョン)をインストールしてbuildしてみましたが、問題なくできました。
Alamofireのバージョンが原因ではないのかもしれません。

unknown>:0: error: module map file '/Users/xxx/Library/Developer/Xcode/DerivedData/Build/Products/Debug-iphonesimulator/Alamofire/Alamofire.modulemap' not found
<unknown>:0: error: module map file '/Users/xxx/Library/Developer/Xcode/DerivedData/Build/Products/Debug-iphonesimulator/Alamofire/Alamofire.modulemap' not found
2 errors generated.
<unknown>:0: error: failed to emit precompiled header '/Users/xxx/Library/Developer/Xcode/DerivedData/Build/Intermediates/PrecompiledHeaders/ObjectiveC_Bridging_Header-swift_G3WBCCN69QCA-clang_1ZMCMFHEN997W.pch' for bridging header '/Users/xxx/iOSApp/projectapp/projectapp/ObjectiveC_Bridging_Header.h'

Podfile

# Uncomment the next line to define a global platform for your project
# platform :ios, '11.0'

target 'projectapp' do
  # Comment the next line if you're not using Swift and don't want to use dynamic frameworks
  use_frameworks!

  # Pods for projectapp
  pod 'Alamofire'
  pod 'AlamofireImage', '~> 3.5'
  pod 'Crossroad'
  pod 'FacebookCore'
  pod 'FacebookLogin'
  pod 'FacebookShare'

  target 'projectappTests' do
    inherit! :search_paths
    # Pods for testing
  end

  target 'projectappUITests' do
    inherit! :search_paths
    # Pods for testing
  end

end

post_install do |installer|
  installer.pods_project.targets.each do |target|
    target.build_configurations.each do |config|
      config.build_settings['SWIFT_VERSION'] = '4.2'
    end
  end
end

ちなみに、Alamofireには新しいバージョンが出ているようです。
もしかすると、以下のバージョンでXcode11.2.1に対応しているのかもしれません。

pod 'Alamofire', '~> 5.0.0-rc.3'

しかし、AlamofireImageの最新版がAlamofireの4.8に対応しているようで、Alamofireの最新版は入れられないようです。

$ pod install --repo-update
[!] CocoaPods could not find compatible versions for pod "Alamofire":
  In Podfile:
    Alamofire (~> 5.0.0-rc.3)

    AlamofireImage (~> 3.5) was resolved to 3.5.2, which depends on
      Alamofire (~> 4.8)


Cocoapods側の問題なのか、Xcode側の設定だけで解決できると良いのですが。。。
何が原因でしょうか?よろしくお願いします。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

check解決した方法

0

問題がないかわかりませんが、こちらの方法で解決しました。

https://teratail.com/questions/224440

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 88.34%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る