質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

88.06%

eclipseでRUNしようとすると

解決済

回答 1

投稿

  • 評価
  • クリップ 0
  • VIEW 2,537

score 45

Java HotSpot(TM) 64-Bit Server VM warning: ignoring option MaxPermSize=256m; support was removed in 8.0 !SESSION 2015-12-12 13:03:50.734 ----------------------------------------------- eclipse.buildId=4.5.1.M20150904-0015 java.version=1.8.0_65 java.vendor=Oracle Corporation BootLoader constants: OS=macosx, ARCH=x86_64, WS=cocoa, NL=ja_JP Framework arguments:  -product org.eclipse.platform.ide Command-line arguments:  -product org.eclipse.platform.ide -data /Users/daisuke/Documents/workspace/lol -dev file:/Users/daisuke/Documents/workspace/.metadata/.plugins/org.eclipse.pde.core/New_configuration/dev.properties -os macosx -ws cocoa -arch x86_64 -consoleLog

!ENTRY org.eclipse.jface 2 0 2015-12-12 13:03:58.267 !MESSAGE Keybinding conflicts occurred.  They may interfere with normal accelerator operation. !SUBENTRY 1 org.eclipse.jface 2 0 2015-12-12 13:03:58.267 !MESSAGE A conflict occurred for COMMAND+SHIFT+-: Binding(COMMAND+SHIFT+-,     ParameterizedCommand(Command(org.eclipse.ui.window.splitEditor,Toggle Split Editor,         Split or join the currently active editor.,         Category(org.eclipse.ui.category.window,Window,null,true),         org.eclipse.ui.internal.WorkbenchHandlerServiceHandler@c4ca86a,         [Parameter(Splitter.isHorizontal,Orientation,null,false)],,true),[org.eclipse.core.commands.Parameterization@6102fa90]),     org.eclipse.ui.defaultAcceleratorConfiguration,     org.eclipse.ui.contexts.window,ja,,system) Binding(COMMAND+SHIFT+-,     ParameterizedCommand(Command(org.eclipse.ui.window.splitEditor,Toggle Split Editor,         Split or join the currently active editor.,         Category(org.eclipse.ui.category.window,Window,null,true),         org.eclipse.ui.internal.WorkbenchHandlerServiceHandler@c4ca86a,         [Parameter(Splitter.isHorizontal,Orientation,null,false)],,true),[org.eclipse.core.commands.Parameterization@6102fa90]),     org.eclipse.ui.defaultAcceleratorConfiguration,     org.eclipse.ui.contexts.window,,cocoa,system)

!ENTRY org.eclipse.core.net 1 0 2015-12-12 13:03:58.899 !MESSAGE System property http.nonProxyHosts has been set to local|*.local|169.254/16|*.169.254/16 by an external source. This value will be overwritten using the values from the preferences *WARNING: Display must be created on main thread due to Cocoa restrictions. *WARNING: Display must be created on main thread due to Cocoa restrictions.

というようなエラーが出ます。初心者ですのでよくわからないのですが、前まで使っていたプロジェクトでは普通にRUNできていたのですが、それを消して新しいプロジェクトでRUNしようとするとこのエラーが出ます。 回答の方よろしくお願いします。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

checkベストアンサー

0

ここに書かれているメッセージは、(修正すべき項目がある、という旨の警告ではあるものの)RUNできなくなった原因となるようなエラーは含まれていないように見えます。

仮に以前はこのような警告すら出なかったのであれば、最近導入したプラグインに問題がある可能性が高いです。ので、可能であれば一度アンインストールしてみてください。


新しいプロジェクトでRUNしようとするとこのエラーが出ます。

というのは、新規のJava Projectを作成して、下のような空のクラスを作成、実行しても同じメッセージが出ますか?他に何か別のメッセージが出ているなどといったこともないでしょうか。

public class Main {

    public static void main(String[] args) {
        System.out.println("Hello, world!");
    }
}

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2015/12/12 14:19

    一度eclipseを強制終了して、もう一度RUNしたら、「現在ワークスペースは他のアプリケーションが使用中なので開始できません」というような警告が出ました。どうすればいいでしょうか。

    キャンセル

  • 2015/12/12 14:30

    正式にはこの警告文が出ます。

    Workspace Cannot Be Locked
    Could not launch the application because the associated workspace is currently in use by another Eclipse application.

    キャンセル

  • 2015/12/12 14:42

    何度もすみません。
    調べてみると、java.exeというのを終了させて、.lockを削除すればいいということなのですが、java.exeというのはどこにあって、どうやって終了させるのか教えて下さい。macです。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 88.06%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る