質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.12%

phpを実行しようとすると、nginx上でAccess deniedになる

解決済

回答 2

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 7,674

tixure55

score 354

phpを実行しようとすると、nginx上でAccess deniedになります。いろいろ検索すると、default.confの設定を見直しなさいというのがたくさん出てきたのですが、どれを試してもアクセス拒否になってしまいます。 どのあたりを改善すべきでしょうか?

/etc/nginx/conf.d/default.conf↓

server {
  listen 8001 default_server;
  root /usr/share/nginx/html;
  index index.html index.htm;
  server_name localhost;

  location / { 
# First attempt to serve request as file, then
# as directory, then fall back to displaying a 404.
    try_files $uri $uri/ /index.html;
# Uncomment to enable naxsi on this location
# include /etc/nginx/naxsi.rules
  }

  location /doc/ {
    alias /usr/share/doc/;
    autoindex on; 
    allow 127.0.0.1;
    allow ::1;
    deny all;
  }

  error_page 500 502 503 504 /50x.html;
  location = /50x.html {
    root /usr/share/nginx/html;
  }

  location ~ \.php$ {
    try_files $uri =404;
    fastcgi_split_path_info ^(.+\.php)(/.+)$;
# NOTE: You should have "cgi.fix_pathinfo = 0;" in php.ini

# With php5-cgi alone:
#fastcgi_pass 127.0.0.1:9000;
# With php5-fpm:
fastcgi_pass unix:/var/run/php5-fpm.sock;
    fastcgi_index index.php;
    include fastcgi_params;
    fastcgi_param   PATH_INFO         $fastcgi_path_info;
    fastcgi_param   PATH_TRANSLATED   $document_root$fastcgi_path_info;
    fastcgi_param   SCRIPT_FILENAME   $document_root$fastcgi_script_name;
  }
  location ~ /\.ht {
    deny all;
  }
}

なお、ディストリビューションはUbuntu14.04で、php5-fpmは起動しており、実行しようとしているphpファイルの実行権限は755です。/usr/share/nginx/html上のhmtlファイルはブラウザ上で実行できております。

/etc/php5/fpm/php.ini↓

gi.fix_pathinfo=0

/var/log/nginx/error.log↓

FastCGI sent in stderr: "Access to the script '/usr/share/nginx/html' has been denied (se    e security.limit_extensions)" while reading response header from upstream, client: 127.0.0.1, server: localhost, request: "GET /h    ello.php HTTP/1.1", upstream: "fastcgi://unix:/var/run/php5-fpm.sock:", host: "localhost:8001"

追記:/etc/php5/fpm/pool.d/www.conf

user = www-data↲
group = www-data↲
listen = /var/run/php5-fpm.sock↲
pm = dynamic↲
pm.max_children = 5↲
pm.start_servers = 2↲
pm.min_spare_servers = 1↲
pm.max_spare_servers = 3
  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正、ベストアンサー選択の依頼

  • TaichiYanagiya

    2015/12/12 15:10

    「fastcgi_split_path_info ^(.+\.php)(/.+)$;」の設定がありますが、URL のパスは「/foo.php/bar」のような形式になるのでしょうか?
    具体的な URL を教えてください。

    キャンセル

  • tixure55

    2015/12/12 21:37

    回答ありがとうございます、具体的には、localhost:8001/foo.phpのような形になります。

    キャンセル

回答 2

checkベストアンサー

+1

/etc/php5/fpm/pool.d/www.conf の設定を教えてください。

例えば、

;listen = /var/run/php5-fpm.sock
listen = 127.0.0.1:9000

※unix socketではく、ネットワークバインドしています。

あと、/etc/nginx/sites-enabled/defaultの php を呼び出す部分を教えてください。

例えば、

server {
  listen   8001;
  server_name default_server;
  root /usr/share/nginx/html;
  index  index.php index.html index.htm;
  location ~ \.php$ {
    fastcgi_pass    127.0.0.1:9000;
    fastcgi_index   index.php;
    fastcgi_param   SCRIPT_FILENAME /usr/share/nginx/html$fastcgi_script_name;
    include         fastcgi_params;
  }
}

※ index の index.phpは忘れがち。

投稿

編集

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2015/12/12 21:34

    /etc/nginx/sites-enabled/defaultを上記のように設置してみましたが、変わらないようです。www.confを追記しましたので、ご助言いただけますでしょうか?

    キャンセル

  • 2015/12/13 11:36

    /etc/php5/fpm/php-fpm.conf で、
    ---
    include=/etc/php5/fpm/pool.d/*.conf
    ---
    という指定がある事と、

    /etc/php5/fpm/pool.d/www.conf で、
    ---
    ;security.limit_extensions = .php .php3 .php4 .php5
    security.limit_extensions = .php .html
    ---
    以下のようになっている事をご確認くださいませ。
    あと、設定を変更された場合は、デーモンの再起動をしてください。

    キャンセル

  • 2015/12/15 07:14

    回答遅くなって申し訳ありません。おっしゃる点を確認しましたが、両方ともそうなっていますが、access deniedになってしまいます。他に心当たりございますでしょうか?

    キャンセル

  • 2015/12/15 07:21

    security.limit_extensions = .php .htmlの行の次の行に半角文字が入っていてそれが原因だったようです。無事動きました。ありがとうございました。

    キャンセル

0

Ken.sakanakana さんの回答のとおり、 security.limit_extensions に ".php" が含まれていないためだと思います。 security.limit_extensions が未定義の場合はデフォルトで ".php" となるはずですが、php-fpm のバージョンによって違うのかもしれません。

アクセスする URL の情報ありがとうございます。 「fastcgi_split_path_info ^(.+\.php)(/.+)$;」の設定があるので、".php" 以外で php-fpm に渡っているのではないかと推測していました。 ".php" でアクセスするのであれば、fastcgi_split_path_info の設定は必要ないと思います。 

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.12%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

同じタグがついた質問を見る