質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

88.05%

Rails Herokuへのデプロイについて

受付中

回答 1

投稿

  • 評価
  • クリップ 1
  • VIEW 450

score 9

RailsアプリをHerokuへデプロイしようとしているのですが、下記のようにコンパイルに失敗しましたというエラーメッセージが出てきてしまいます。試したこととしては、Gemfile Lockを一度削除しbundle install --without productionを実行しもう一度デプロイを試みる、Procfileの中身を確認するなどを行いましたが、解決することが出来ませんでした。下記がエラーメッセージの詳細です。何卒よろしくお願いします。

remote:        Bundle completed (49.03s)
remote:        Cleaning up the bundler cache.
remote: -----> Installing node-v10.15.3-linux-x64
remote: -----> Detecting rake tasks
remote: 
remote:  !
remote:  !     Could not detect rake tasks
remote:  !     ensure you can run `$ bundle exec rake -P` against your app
remote:  !     and using the production group of your Gemfile.
remote:  !     rake aborted!
remote:  !     FrozenError: can't modify frozen String: "railties_load_path="
remote:  !     /tmp/build_fb43dfd74c55084ea64bb31b686a0843/vendor/bundle/ruby/2.7.0/gems/activesupport-5.2.3/lib/active_support/ordered_options.rb:43:in `chomp!'
remote:  !     /tmp/build_fb43dfd74c55084ea64bb31b686a0843/vendor/bundle/ruby/2.7.0/gems/activesupport-5.2.3/lib/active_support/ordered_options.rb:43:in `method_missing'
remote:  !     /tmp/build_fb43dfd74c55084ea64bb31b686a0843/vendor/bundle/ruby/2.7.0/gems/activesupport-5.2.3/lib/active_support/i18n_railtie.rb:12:in `<class:Railtie>'
remote:  !     /tmp/build_fb43dfd74c55084ea64bb31b686a0843/vendor/bundle/ruby/2.7.0/gems/activesupport-5.2.3/lib/active_support/i18n_railtie.rb:10:in `<module:I18n>'
remote:  !     /tmp/build_fb43dfd74c55084ea64bb31b686a0843/vendor/bundle/ruby/2.7.0/gems/activesupport-5.2.3/lib/active_support/i18n_railtie.rb:9:in `<main>'
remote:  !     /tmp/build_fb43dfd74c55084ea64bb31b686a0843/vendor/bundle/ruby/2.7.0/gems/bootsnap-1.4.5/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:22:in `require'
remote:  !     /tmp/build_fb43dfd74c55084ea64bb31b686a0843/vendor/bundle/ruby/2.7.0/gems/bootsnap-1.4.5/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:22:in `block in require_with_bootsnap_lfi'
remote:  !     /tmp/build_fb43dfd74c55084ea64bb31b686a0843/vendor/bundle/ruby/2.7.0/gems/bootsnap-1.4.5/lib/bootsnap/load_path_cache/loaded_features_index.rb:92:in `register'
remote:  !     /tmp/build_fb43dfd74c55084ea64bb31b686a0843/vendor/bundle/ruby/2.7.0/gems/bootsnap-1.4.5/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:21:in `require_with_bootsnap_lfi'
remote:  !     /tmp/build_fb43dfd74c55084ea64bb31b686a0843/vendor/bundle/ruby/2.7.0/gems/bootsnap-1.4.5/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:30:in `require'
remote:  !     /tmp/build_fb43dfd74c55084ea64bb31b686a0843/vendor/bundle/ruby/2.7.0/gems/activesupport-5.2.3/lib/active_support/dependencies.rb:291:in `block in require'
remote:  !     /tmp/build_fb43dfd74c55084ea64bb31b686a0843/vendor/bundle/ruby/2.7.0/gems/activesupport-5.2.3/lib/active_support/dependencies.rb:257:in `load_dependency'
remote:  !     /tmp/build_fb43dfd74c55084ea64bb31b686a0843/vendor/bundle/ruby/2.7.0/gems/activesupport-5.2.3/lib/active_support/dependencies.rb:291:in `require'
remote:  !     /tmp/build_fb43dfd74c55084ea64bb31b686a0843/vendor/bundle/ruby/2.7.0/gems/activesupport-5.2.3/lib/active_support/railtie.rb:4:in `<main>'
remote:  !     /tmp/build_fb43dfd74c55084ea64bb31b686a0843/vendor/bundle/ruby/2.7.0/gems/bootsnap-1.4.5/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:22:in `require'
remote:  !     /tmp/build_fb43dfd74c55084ea64bb31b686a0843/vendor/bundle/ruby/2.7.0/gems/bootsnap-1.4.5/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:22:in `block in require_with_bootsnap_lfi'
remote:  !     /tmp/build_fb43dfd74c55084ea64bb31b686a0843/vendor/bundle/ruby/2.7.0/gems/bootsnap-1.4.5/lib/bootsnap/load_path_cache/loaded_features_index.rb:92:in `register'
remote:  !     /tmp/build_fb43dfd74c55084ea64bb31b686a0843/vendor/bundle/ruby/2.7.0/gems/bootsnap-1.4.5/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:21:in `require_with_bootsnap_lfi'
remote:  !     /tmp/build_fb43dfd74c55084ea64bb31b686a0843/vendor/bundle/ruby/2.7.0/gems/bootsnap-1.4.5/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:30:in `require'
remote:  !     /tmp/build_fb43dfd74c55084ea64bb31b686a0843/vendor/bundle/ruby/2.7.0/gems/activesupport-5.2.3/lib/active_support/dependencies.rb:291:in `block in require'
remote:  !     /tmp/build_fb43dfd74c55084ea64bb31b686a0843/vendor/bundle/ruby/2.7.0/gems/activesupport-5.2.3/lib/active_support/dependencies.rb:257:in `load_dependency'
remote:  !     /tmp/build_fb43dfd74c55084ea64bb31b686a0843/vendor/bundle/ruby/2.7.0/gems/activesupport-5.2.3/lib/active_support/dependencies.rb:291:in `require'
remote:  !     /tmp/build_fb43dfd74c55084ea64bb31b686a0843/vendor/bundle/ruby/2.7.0/gems/railties-5.2.3/lib/rails.rb:17:in `<main>'
remote:  !     /tmp/build_fb43dfd74c55084ea64bb31b686a0843/vendor/bundle/ruby/2.7.0/gems/bootsnap-1.4.5/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:22:in `require'
remote:  !     /tmp/build_fb43dfd74c55084ea64bb31b686a0843/vendor/bundle/ruby/2.7.0/gems/bootsnap-1.4.5/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:22:in `block in require_with_bootsnap_lfi'
remote:  !     /tmp/build_fb43dfd74c55084ea64bb31b686a0843/vendor/bundle/ruby/2.7.0/gems/bootsnap-1.4.5/lib/bootsnap/load_path_cache/loaded_features_index.rb:92:in `register'
remote:  !     /tmp/build_fb43dfd74c55084ea64bb31b686a0843/vendor/bundle/ruby/2.7.0/gems/bootsnap-1.4.5/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:21:in `require_with_bootsnap_lfi'
remote:  !     /tmp/build_fb43dfd74c55084ea64bb31b686a0843/vendor/bundle/ruby/2.7.0/gems/bootsnap-1.4.5/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:30:in `require'
remote:  !     /tmp/build_fb43dfd74c55084ea64bb31b686a0843/vendor/bundle/ruby/2.7.0/gems/activesupport-5.2.3/lib/active_support/dependencies.rb:291:in `block in require'
remote:  !     /tmp/build_fb43dfd74c55084ea64bb31b686a0843/vendor/bundle/ruby/2.7.0/gems/activesupport-5.2.3/lib/active_support/dependencies.rb:257:in `load_dependency'
remote:  !     /tmp/build_fb43dfd74c55084ea64bb31b686a0843/vendor/bundle/ruby/2.7.0/gems/activesupport-5.2.3/lib/active_support/dependencies.rb:291:in `require'
remote:  !     /tmp/build_fb43dfd74c55084ea64bb31b686a0843/vendor/bundle/ruby/2.7.0/gems/railties-5.2.3/lib/rails/all.rb:3:in `<main>'
remote:  !     /tmp/build_fb43dfd74c55084ea64bb31b686a0843/vendor/bundle/ruby/2.7.0/gems/bootsnap-1.4.5/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:22:in `require'
remote:  !     /tmp/build_fb43dfd74c55084ea64bb31b686a0843/vendor/bundle/ruby/2.7.0/gems/bootsnap-1.4.5/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:22:in `block in require_with_bootsnap_lfi'
remote:  !     /tmp/build_fb43dfd74c55084ea64bb31b686a0843/vendor/bundle/ruby/2.7.0/gems/bootsnap-1.4.5/lib/bootsnap/load_path_cache/loaded_features_index.rb:92:in `register'
remote:  !     /tmp/build_fb43dfd74c55084ea64bb31b686a0843/vendor/bundle/ruby/2.7.0/gems/bootsnap-1.4.5/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:21:in `require_with_bootsnap_lfi'
remote:  !     /tmp/build_fb43dfd74c55084ea64bb31b686a0843/vendor/bundle/ruby/2.7.0/gems/bootsnap-1.4.5/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:30:in `require'
remote:  !     /tmp/build_fb43dfd74c55084ea64bb31b686a0843/vendor/bundle/ruby/2.7.0/gems/activesupport-5.2.3/lib/active_support/dependencies.rb:291:in `block in require'
remote:  !     /tmp/build_fb43dfd74c55084ea64bb31b686a0843/vendor/bundle/ruby/2.7.0/gems/activesupport-5.2.3/lib/active_support/dependencies.rb:257:in `load_dependency'
remote:  !     /tmp/build_fb43dfd74c55084ea64bb31b686a0843/vendor/bundle/ruby/2.7.0/gems/activesupport-5.2.3/lib/active_support/dependencies.rb:291:in `require'
remote:  !     /tmp/build_fb43dfd74c55084ea64bb31b686a0843/config/application.rb:3:in `<top (required)>'
remote:  !     /tmp/build_fb43dfd74c55084ea64bb31b686a0843/Rakefile:4:in `require_relative'
remote:  !     /tmp/build_fb43dfd74c55084ea64bb31b686a0843/Rakefile:4:in `<top (required)>'
remote:  !     /tmp/build_fb43dfd74c55084ea64bb31b686a0843/vendor/bundle/ruby/2.7.0/gems/rake-13.0.0/lib/rake/rake_module.rb:29:in `load'
remote:  !     /tmp/build_fb43dfd74c55084ea64bb31b686a0843/vendor/bundle/ruby/2.7.0/gems/rake-13.0.0/lib/rake/rake_module.rb:29:in `load_rakefile'
remote:  !     /tmp/build_fb43dfd74c55084ea64bb31b686a0843/vendor/bundle/ruby/2.7.0/gems/rake-13.0.0/lib/rake/application.rb:703:in `raw_load_rakefile'
remote:  !     /tmp/build_fb43dfd74c55084ea64bb31b686a0843/vendor/bundle/ruby/2.7.0/gems/rake-13.0.0/lib/rake/application.rb:104:in `block in load_rakefile'
remote:  !     /tmp/build_fb43dfd74c55084ea64bb31b686a0843/vendor/bundle/ruby/2.7.0/gems/rake-13.0.0/lib/rake/application.rb:186:in `standard_exception_handling'
remote:  !     /tmp/build_fb43dfd74c55084ea64bb31b686a0843/vendor/bundle/ruby/2.7.0/gems/rake-13.0.0/lib/rake/application.rb:103:in `load_rakefile'
remote:  !     /tmp/build_fb43dfd74c55084ea64bb31b686a0843/vendor/bundle/ruby/2.7.0/gems/rake-13.0.0/lib/rake/application.rb:82:in `block in run'
remote:  !     /tmp/build_fb43dfd74c55084ea64bb31b686a0843/vendor/bundle/ruby/2.7.0/gems/rake-13.0.0/lib/rake/application.rb:186:in `standard_exception_handling'
remote:  !     /tmp/build_fb43dfd74c55084ea64bb31b686a0843/vendor/bundle/ruby/2.7.0/gems/rake-13.0.0/lib/rake/application.rb:80:in `run'
remote:  !     /tmp/build_fb43dfd74c55084ea64bb31b686a0843/vendor/bundle/ruby/2.7.0/gems/rake-13.0.0/exe/rake:27:in `<top (required)>'
remote:  !     vendor/bundle/bin/rake:29:in `load'
remote:  !     vendor/bundle/bin/rake:29:in `<main>'
remote:  !
  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

+1

issueがあがっているようですね。
安定版である ruby 2.6.5 を使ってください。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 88.05%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る