質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

88.78%

AWS SDK for Javaのセットアップについて

受付中

回答 0

投稿 編集

  • 評価
  • クリップ 1
  • VIEW 463

mucho7

score 8

現行のjavaアプリ(ver.1.6)が参照しているファイルデータをAWS互換のS3ストレージに移行する対応をしているのですが、「AWS SDK for Java」のセットアップに手間取っております。

https://docs.aws.amazon.com/ja_jp/sdk-for-java/v1/developer-guide/setup-install.html

上記の、プロジェクトにSDKを含めるのところで
Apache Ant またはその他の方法でセットアップ・・・を試みているのですが上手くいきません。

javaのバージョンが1.6なので、「以前のバージョンのSDKのインストール」の手順を行っています。

4.開発システムのディレクトリ・・・・
↑ これが指しているのは対象アプリのディレクトリ直下(C:\pleiades\workspace\【アプリ名】/aws-sdk-java-1.6.10)でよいのでしょうか。

> mvn clean install
[INFO] Scanning for projects...
[WARNING]
[WARNING] Some problems were encountered while building the effective model for com.amazonaws:aws-java-sdk:jar:1.6.10
[WARNING] 'build.plugins.plugin.version' for org.apache.maven.plugins:maven-gpg-plugin is missing. @ line 170, column 17
[WARNING]
[WARNING] It is highly recommended to fix these problems because they threaten the stability of your build.
[WARNING]
[WARNING] For this reason, future Maven versions might no longer support building such malformed projects.
[WARNING]
[INFO]
[INFO] ---------------------< com.amazonaws:aws-java-sdk >---------------------
[INFO] Building AWS SDK for Java 1.6.10
[INFO] --------------------------------[ jar ]---------------------------------
[INFO]
[INFO] --- maven-clean-plugin:2.5:clean (default-clean) @ aws-java-sdk ---
[INFO] Deleting C:\pleiades\workspace\【アプリ名】\aws-sdk-java-1.6.10\target
[INFO]
[INFO] --- maven-resources-plugin:2.6:resources (default-resources) @ aws-java-sdk ---
[WARNING] Using platform encoding (MS932 actually) to copy filtered resources, i.e. build is platform dependent!
[INFO] Copying 13 resources
[INFO]
[INFO] --- maven-compiler-plugin:3.1:compile (default-compile) @ aws-java-sdk ---
[INFO] Changes detected - recompiling the module!
[INFO] Compiling 6377 source files to C:\pleiades\workspace\【アプリ名】\aws-sdk-java-1.6.10\target\classes
[INFO] -------------------------------------------------------------
[ERROR] COMPILATION ERROR :
[INFO] -------------------------------------------------------------
[ERROR] No compiler is provided in this environment. Perhaps you are running on a JRE rather than a JDK?
[INFO] 1 error
[INFO] -------------------------------------------------------------
[INFO] ------------------------------------------------------------------------
[INFO] BUILD FAILURE
[INFO] ------------------------------------------------------------------------
[INFO] Total time:  3.527 s
[INFO] Finished at: 2019-11-05T14:57:18+09:00
[INFO] ------------------------------------------------------------------------
[ERROR] Failed to execute goal org.apache.maven.plugins:maven-compiler-plugin:3.1:compile (default-compile) on project aws-java-sdk: Compilation failure
[ERROR] No compiler is provided in this environment. Perhaps you are running on a JRE rather than a JDK?
[ERROR]
[ERROR] -> [Help 1]
[ERROR]
[ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR]
[ERROR] For more information about the errors and possible solutions, please read the following articles:
[ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/MojoFailureException

このERRORを解消したらセットアップ完了でしょうか。
詳しい方いらっしゃいましたら、ご教示頂けますと幸いです。

※20191203追記

aws-sdk-java v.1.11

上記のライブラリをダウンロードして実装を試みました。

アプリのプロジェクトのFWはSeasar2を利用しており、
WEB-INF/lib直下に必要なjarを配置して「Javaのビルドパス」→ jarの追加でクラスパスを通したのですがEclipseのマーカーに「Archive for required library: 'C:/pleiades/workspace/【アプリ名】/src/main/webapp/WEB-INF/lib/aws-java-sdk-1.11.683.jar' in project '【アプリ名】' cannot be read or is not a valid ZIP file」と出ます。

古いaws-sdk-java を利用したほうがよいでしょうか?
その場合、AWS公式ドキュメントによるとmavenで構築することになるのでしょうか。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正の依頼

  • asahina1979

    2019/11/05 23:07

    指定されたJDKはJREではありませんか?
    エラーメッセージをよく読もう

    キャンセル

まだ回答がついていません

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 88.78%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る