質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

89.65%

ラズパイ functools_lru_cacheについて

解決済

回答 1

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 250

raspypy

score 63

やろうとしていること

ラズパイで作成したcsvファイルを、matplotlibを使用してグラフ化させたいと考えています。
(プログラムコードを最後に掲載します。)

困っていること

プログラムを実行すると、次のエラーが発生します。

Traceback (most recent call last):
  File "./test.py", line 9, in <module>
    import matplotlib
  File "/home/pi/.local/lib/python2.7/site-packages/matplotlib/__init__.py", line 130, in <module>
    from matplotlib.rcsetup import defaultParams, validate_backend, cycler
  File "/home/pi/.local/lib/python2.7/site-packages/matplotlib/rcsetup.py", line 29, in <module>
    from matplotlib.fontconfig_pattern import parse_fontconfig_pattern
  File "/home/pi/.local/lib/python2.7/site-packages/matplotlib/fontconfig_pattern.py", line 28, in <module>
    from backports.functools_lru_cache import lru_cache
ImportError: No module named functools_lru_cache

教えてほしいこと

エラーの最後に
"No module named functools_lru_cache"とあるのですが、

次のコマンドを実行し、
pi@raspberrypi:~ $ pip install backports.functools_lru_cache

次の結果が得られています。

Looking in indexes: https://pypi.org/simple, https://www.piwheels.org/simple
Requirement already satisfied: backports.functools_lru_cache in /home/pi/.local/lib/python2.7/site-packages (1.5)

functools_lru_cacheはインストールできているのに、なぜ↑のエラーが発生するのかが分かりません。

バージョン情報

matplotlibのバージョンは、2.2.4です。

プログラムコード

#!/usr/bin/python
# -*- coding: utf-8 -*-

#Save the temperature, humidity, and atmospheric pressure obtained from bme280 in csv
#csv format:
#year,month,date,hour,min,val


import matplotlib.pyplot as plt
import csv


MAX_RANGE=50
URL_PATH="/home/pi/dev/data/"

temp=[0 for i in range(MAX_RANGE)]
date=[0 for i in range(MAX_RANGE)]
span=[]

for i in range(MAX_RANGE):
    span.append(1000/MAX_RANGE*i)

fp=open(URL_PATH+"temp.csv","rb")
reader=csv.reader(fp)
for row in reader:
    temp.pop(0)
    temp.append(float(row[5]))
    date.pop(0)
    #month/date_hour:minute
    date.append("%02d"%int(row[1])+"/"+"%02d"%int(row[2])+"_"+"%02d"%int(row[3])+":"+"%02d"%int(row[4]))
fp.close()

fig=plt.figure(figsize=(16,9))
ax=fig.add_subplot(1,1,1)
plt.title("Temperature")
plt.gca().get_yaxis().get_major_formatter().set_useOffset(False)
plt.xlabel("month/date_hour:minute")
plt.ylabel("degree Celsius")
plt.plot(temp,color="m")
plt.xticks(range(MAX_RANGE),date)
grid(True)
labels=ax.set_xticklabels(date,rotation=90,fontsize="small")

plt.show()
plt.savefig(URL_PATH+"temp.png",bbox_inches="tight")
  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

check解決した方法

0

matplotlibライブラリについて。
pipでインストールしていましたが、
apt-get installで改めてインストールしたところ、問題なくなりました。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 89.65%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる