質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

89.53%

Ubuntu18.07LTSにrubyをインストールしたいけれど、Cコンパイラがインストールできません

受付中

回答 1

投稿

  • 評価
  • クリップ 1
  • VIEW 293

SkipEveryLunch

score 10

前提・実現したいこと

Ubuntu18.07LTSでRuby on Railsの開発環境を構築するため、
Cコンパイラをインストールしたい

発生している問題・エラーメッセージ

こんにちは。Ruby初心者です。
ほぼフロントサイドの勉強しかしてこなかったため、
Linuxの知識は基本的なコマンド程度しかありません。

Windows10でUbuntu18.07LTSを開き、
$ rbenv install -v 2.6.5した所、BUILD FAILEDします。

Inspect or clean up the working tree at /tmp/ruby-build.20191014145854.1843
Results logged to /tmp/ruby-build.20191014145854.1843.log

Last 10 log lines:
checking for ruby... false
checking build system type... x86_64-pc-linux-gnu
checking host system type... x86_64-pc-linux-gnu
checking target system type... x86_64-pc-linux-gnu
checking for gcc... no
checking for cc... no
checking for cl.exe... no
configure: error: in `/tmp/ruby-build.20191014145854.1843/ruby-2.6.5':
configure: error: no acceptable C compiler found in $PATH
See `config.log' for more details

試したこと

no acceptable C compiler found in $PATH とのことですので、
Cコンパイラをubuntuに入れる方法はないかググってみたところ、
$ sudo apt-get install build-essential するといいと言う情報があったのですが、
上手く行きませんでした。

Package build-essential is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'build-essential' has no installation candidate


apt-getの代わりにaptを入れようとしても同じエラーが出ます。

次に、$ sudo apt-get install gcc を試してみると、
また違うエラーが出てきました。

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 gcc : Depends: cpp (>= 4:7.4.0-1ubuntu2.3) but it is not going to be installed
       Depends: gcc-7 (>= 7.4.0-1~) but it is not going to be installed
       Recommends: libc6-dev but it is not installable or
                   libc-dev but it is not installable
E: Unable to correct problems, you have held broken packages.

yumを使ってgccをインストールすればいいとの情報もあったのですが、
そもそもyumのインストールの時点でエラーが出ます。
$ sudo apt-get install yum すると、

Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package yum

という感じになります。

何か解決の心当たりがある方がいらっしゃれば、
教えていただければ幸いです。
もっと言えば、目的はLinuxターミナルでRuby on Railsの開発環境を構築することですので、
Ubuntu18.04以外にスマートな方法があるぞい! という情報でも大変助かります。
よろしくお願いします。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

0

Ubuntuなら最初からgccはいってるんじゃないでしょうか。
gcc -v
したらなにがでてくるでしょうか

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2019/10/14 20:34 編集

    ご回答ありがとうございます!
    gcc -v してみても

    Command 'gcc' not found, but can be installed with:
    sudo apt install gcc

    としか出てこないんですよね……。
    ちなみに、$ sudo apt install gcc すると以下のエラーが出ます。

    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:

    The following packages have unmet dependencies:
    gcc : Depends: cpp (>= 4:7.4.0-1ubuntu2.3) but it is not going to be installed
    Depends: gcc-7 (>= 7.4.0-1~) but it is not going to be installed
    Recommends: libc6-dev but it is not installable or
    libc-dev but it is not installable
    E: Unable to correct problems, you have held broken packages.

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 89.53%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

同じタグがついた質問を見る