質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

87.92%

Jupyter NotebookでRを動かしたい。

受付中

回答 2

投稿

  • 評価
  • クリップ 0
  • VIEW 1,219

前提・実現したいこと

anacondaでpythonを触っていたが、Rも同様なことができると知ったので、ネットで探してやってみようと思ったが、最初の必要なパッケージをインストーるするところでつまずいてしまってわからなくなってしまった。

発生している問題・エラーメッセージ

エラーメッセージ
  • installing *source* package ‘ps’ ...
      パッケージ ‘ps’ の解凍および MD5 サムの検証に成功しました  ** libs x86_64-apple-darwin13.4.0-clang -march=core2 -mtune=haswell -mssse3 -ftree-vectorize -fPIC -fPIE -fstack-protector-strong -O2 -pipe -I/anaconda3/include -fdebug-prefix-map==/usr/local/src/conda/- -fdebug-prefix-map==/usr/local/src/conda-prefix  -Wall px.c -o px ld: warning: ignoring file /Library/Developer/CommandLineTools/SDKs/MacOSX.sdk/usr/lib/libSystem.tbd, file was built for unsupported file format ( 0x2D 0x2D 0x2D 0x20 0x21 0x74 0x61 0x70 0x69 0x2D 0x74 0x62 0x64 0x2D 0x76 0x33 ) which is not the architecture being linked (x86_64): /Library/Developer/CommandLineTools/SDKs/MacOSX.sdk/usr/lib/libSystem.tbd Undefined symbols for architecture x86_64: "_error", referenced from: _echo_from_fd in px-29b3f4.o "_stack_chk_fail", referenced from: _cat2 in px-29b3f4.o _cat in px-29b3f4.o _echo_from_fd in px-29b3f4.o _main in px-29b3f4.o "_stack_chk_guard", referenced from: _cat2 in px-29b3f4.o _cat in px-29b3f4.o _echo_from_fd in px-29b3f4.o _main in px-29b3f4.o "_stderrp", referenced from: _usage in px-29b3f4.o _cat2 in px-29b3f4.o _cat in px-29b3f4.o _write_to_fd in px-29b3f4.o _echo_from_fd in px-29b3f4.o _main in px-29b3f4.o "___stdoutp", referenced from: _echo_from_fd in px-29b3f4.o _main in px-29b3f4.o "_close", referenced from: _cat in px-29b3f4.o "_exit", referenced from: _cat2 in px-29b3f4.o _cat in px-29b3f4.o "_fflush", referenced from: _echo_from_fd in px-29b3f4.o _main in px-29b3f4.o "_fprintf", referenced from: _cat2 in px-29b3f4.o _cat in px-29b3f4.o _write_to_fd in px-29b3f4.o _echo_from_fd in px-29b3f4.o _main in px-29b3f4.o "_fputs", referenced from: _main in px-29b3f4.o "_fwrite", referenced from: _usage in px-29b3f4.o _main in px-29b3f4.o "_getenv", referenced from: _main in px-29b3f4.o "_open", referenced from: _cat in px-29b3f4.o "_printf", referenced from: _main in px-29b3f4.o "_puts", referenced from: _main in px-29b3f4.o "_read", referenced from: _cat2 in px-29b3f4.o _cat in px-29b3f4.o _echo_from_fd in px-29b3f4.o "_sleep", referenced from: _main in px-29b3f4.o "_sscanf", referenced from: _main in px-29b3f4.o "_strcmp", referenced from: _main in px-29b3f4.o "_strerror", referenced from: _echo_from_fd in px-29b3f4.o "_strlen", referenced from: _write_to_fd in px-29b3f4.o _echo_from_fd in px-29b3f4.o _main in px-29b3f4.o "_usleep", referenced from: _main in px-29b3f4.o "_write", referenced from: _cat2 in px-29b3f4.o _cat in px-29b3f4.o _write_to_fd in px-29b3f4.o _echo_from_fd in px-29b3f4.o _main in px-29b3f4.o (maybe you meant: _write_to_fd) ld: symbol(s) not found for architecture x86_64 clang-4.0: error: linker command failed with exit code 1 (use -v to see invocation) make: * [Makevars:11: px] Error 1
    ERROR: compilation failed for package ‘ps’

  • removing ‘/anaconda3/lib/R/library/ps’

  • installing *source* package ‘fs’ ...
    **  パッケージ ‘fs’ の解凍および MD5 サムの検証に成功しました 
    中略
    ERROR: compilation failed for package ‘fs’

  • removing ‘/anaconda3/lib/R/library/fs’

  • installing *source* package ‘git2r’ ...
    **  パッケージ ‘git2r’ の解凍および MD5 サムの検証に成功しました 
    checking build system type... x86_64-apple-darwin18.7.0
    checking host system type... x86_64-apple-darwin18.7.0
    checking for gcc... x86_64-apple-darwin13.4.0-clang
    checking whether the C compiler works... no
    configure: error: in /private/var/folders/1j/ykvjgzl54qd3mffmxmk191c40000gn/T/Rtmpuqstls/R.INSTALLb9a7ee0f365/git2r': configure: error: C compiler cannot create executables See config.log' for more details
    ERROR: configuration failed for package ‘git2r’

  • removing ‘/anaconda3/lib/R/library/git2r’

  • installing *source* package ‘pbdZMQ’ ...
    **  パッケージ ‘pbdZMQ’ の解凍および MD5 サムの検証に成功しました 
    checking for pkg-config... no

************** Results of pbdZMQ package configure *************

GET_PKG_CONFIG = no
GET_SYSTEM_ZMQ = no
PKG_CONFIG = 
SYSTEM_ZMQ_INCLUDEDIR = 
SYSTEM_ZMQ_LIBDIR = 
ENABLE_INTERNAL_ZMQ = no
INTERNAL_ZMQ_INCLUDEDIR = ./zmqsrc/include
INTERNAL_ZMQ_LIBDIR = ./
EXTERNAL_ZMQ_INCLUDE = 
EXTERNAL_ZMQ_LDFLAGS = 
ZMQ_INCLUDE = -I./zmqsrc/include
ZMQ_LDFLAGS = -L./ -lzmq
EXT_LIBS = $(R_ZMQ)
ZMQ_POLLER = select


configure: creating ./config.status
config.status: creating src/Makevars
configure: creating ./config.status
config.status: creating src/Makevars
config.status: creating src/build_zmq
configure: creating ./config.status
config.status: creating src/Makevars
config.status: creating src/build_zmq
config.status: creating R/zzz.r
 libs ( sh ./chmod_zmq.inc; cd zmqsrc; sh ../build_zmq ) checking for a BSD-compatible install... /usr/bin/install -c checking whether build environment is sane... yes checking for a thread-safe mkdir -p... config/install-sh -c -d checking for gawk... no checking for mawk... no checking for nawk... no checking for awk... awk checking whether make sets $(MAKE)... yes checking whether make supports nested variables... yes checking whether UID '501' is supported by ustar format... yes checking whether GID '20' is supported by ustar format... yes checking how to create a ustar tar archive... gnutar checking whether make supports nested variables... (cached) yes checking for gcc... x86_64-apple-darwin13.4.0-clang checking whether the C compiler works... no configure: error: in /private/var/folders/1j/ykvjgzl54qd3mffmxmk191c40000gn/T/Rtmp0l1kTW/R.INSTALLba9a4f57d766/pbdZMQ/src/zmqsrc': configure: error: C compiler cannot create executables See config.log' for more details make[1]: Entering directory '/private/var/folders/1j/ykvjgzl54qd3mffmxmk191c40000gn/T/Rtmp0l1kTW/R.INSTALLba9a4f57d766/pbdZMQ/src/zmqsrc' make[1]: * No targets specified and no makefile found.  Stop.
make[1]: Leaving directory '/private/var/folders/1j/ykvjgzl54qd3mffmxmk191c40000gn/T/Rtmp0l1kTW/R.INSTALLba9a4f57d766/pbdZMQ/src/zmqsrc'
make[1]: Entering directory '/private/var/folders/1j/ykvjgzl54qd3mffmxmk191c40000gn/T/Rtmp0l1kTW/R.INSTALLba9a4f57d766/pbdZMQ/src/zmqsrc'
make[1]: * No rule to make target 'install'.  Stop. make[1]: Leaving directory '/private/var/folders/1j/ykvjgzl54qd3mffmxmk191c40000gn/T/Rtmp0l1kTW/R.INSTALLba9a4f57d766/pbdZMQ/src/zmqsrc' make: * [Makevars:52: libzmq] Error 2
ERROR: compilation failed for package ‘pbdZMQ’

  • removing ‘/anaconda3/lib/R/library/pbdZMQ’
  • restoring previous ‘/anaconda3/lib/R/library/pbdZMQ’
  • installing *source* package ‘uuid’ ...
    **  パッケージ ‘uuid’ の解凍および MD5 サムの検証に成功しました 
    checking for gcc... x86_64-apple-darwin13.4.0-clang
    checking whether the C compiler works... no
    configure: error: in /private/var/folders/1j/ykvjgzl54qd3mffmxmk191c40000gn/T/Rtmp1tfrQl/R.INSTALLbe02479f30fa/uuid': configure: error: C compiler cannot create executables See config.log' for more details
    ERROR: configuration failed for package ‘uuid’
  • removing ‘/anaconda3/lib/R/library/uuid’

ERROR: dependency ‘ps’ is not available for package ‘processx’

  • removing ‘/anaconda3/lib/R/library/processx’
    ERROR: dependencies ‘fs’, ‘git2r’ are not available for package ‘usethis’
  • removing ‘/anaconda3/lib/R/library/usethis’
  • installing *source* package ‘IRdisplay’ ...
      パッケージ ‘IRdisplay’ の解凍および MD5 サムの検証に成功しました  ** R ** byte-compile and prepare package for lazy loading ** help * installing help indices
    ** building package indices
    ** testing if installed package can be loaded
  • DONE (IRdisplay)
    ERROR: dependency ‘processx’ is not available for package ‘xopen’
  • removing ‘/anaconda3/lib/R/library/xopen’
    ERROR: dependency ‘processx’ is not available for package ‘callr’
  • removing ‘/anaconda3/lib/R/library/callr’
    ERROR: dependency ‘callr’ is not available for package ‘pkgbuild’
  • removing ‘/anaconda3/lib/R/library/pkgbuild’
    ERROR: dependency ‘pkgbuild’ is not available for package ‘pkgload’
  • removing ‘/anaconda3/lib/R/library/pkgload’
    ERROR: dependencies ‘callr’, ‘pkgbuild’, ‘xopen’ are not available for package ‘rcmdcheck’
  • removing ‘/anaconda3/lib/R/library/rcmdcheck’
    ERROR: dependency ‘pkgload’ is not available for package ‘roxygen2’
  • removing ‘/anaconda3/lib/R/library/roxygen2’
    ERROR: dependencies ‘usethis’, ‘callr’, ‘git2r’, ‘pkgbuild’, ‘pkgload’, ‘rcmdcheck’, ‘roxygen2’ are not available for package ‘devtools’
  • removing ‘/anaconda3/lib/R/library/devtools’

ダウンロードされたパッケージは、以下にあります 
‘/private/var/folders/1j/ykvjgzl54qd3mffmxmk191c40000gn/T/RtmplYekNy/downloaded_packages’ 
'.Library' 中のパッケージの HTML 索引を更新します 
Making 'packages.html' ...  完了 
14 件の警告がありました (警告を見るには warnings() を使って下さい) 

該当のソースコード

install.packages(c('repr', 'IRdisplay', 'evaluate', 'crayon', 'pbdZMQ', 'devtools', 'uuid', 'digest'))

試したこと

ここに問題に対して試したことを記載してください。

補足情報(FW/ツールのバージョンなど)

Mac OSX Mojave 10.14.6
anaconda、Rは最新にバージョンアップ済み
ここにより詳細な情報を記載してください。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 2

0

私はMacは持ってないので直接的な検証はできませんが、

checking for gcc... x86_64-apple-darwin13.4.0-clang
checking whether the C compiler works... no

まずはここに問題がありそうです。とりあえずCコンパイラ環境を整える必要があるでしょう。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2019/10/14 14:49

    お返事ありがとうございます。Cコンパイラ環境を全く触ったことがないのですが、具体的にどのようなことを調べて実行すればよいのでしょうか?

    キャンセル

  • 2019/10/14 17:39

    >具体的にどのようなことを調べて

    macos gcc インストール
    まずググる。

    キャンセル

  • 2019/10/18 12:32

    ターミナルからgccがインストールされているかを確認したのですが、
    $ gcc -v
    Configured with: --prefix=/Applications/Xcode.app/Contents/Developer/usr --with-gxx-include-dir=/Library/Developer/CommandLineTools/SDKs/MacOSX.sdk/usr/include/c++/4.2.1
    Apple clang version 11.0.0 (clang-1100.0.33.8)
    Target: x86_64-apple-darwin18.7.0
    Thread model: posix
    InstalledDir: /Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin

    gccが存在はしそうなのですが、Target: x86_64-apple-darwin18.7.0がchecking for gcc... x86_64-apple-darwin13.4.0-clangとは違うからエラーが出るのでしょうか?

    キャンセル

0

以下が該当しませんでしょうか?

Qiita:install.packages("pander")にてx86_64-apple-darwin13.4.0-clang++: command not found出力時の対応方法

$ conda install clangxx_osx-64

因みに「apple-darwin13.4.0-clang」でググっただけです。

投稿

編集

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2019/10/26 23:14

    それに関しては以前やってみたのですが、結果としては、うまくいかなかったです。
    $ conda install clangxx_osx-64
    Collecting package metadata (repodata.json): done
    Solving environment: done

    ## Package Plan ##

    environment location: /anaconda3

    added / updated specs:
    - clangxx_osx-64


    The following packages will be downloaded:

    package | build
    ---------------------------|-----------------
    certifi-2019.9.11 | py37_0 154 KB
    conda-4.7.12 | py37_0 3.0 MB
    ------------------------------------------------------------
    Total: 3.1 MB

    The following packages will be SUPERSEDED by a higher-priority channel:

    certifi anaconda --> pkgs/main
    conda anaconda --> pkgs/main
    openssl anaconda::openssl-1.1.1-h1de35cc_0 --> pkgs/main::openssl-1.1.1d-h1de35cc_3


    Proceed ([y]/n)? y


    Downloading and Extracting Packages
    certifi-2019.9.11 | 154 KB | ################################################################ | 100%
    conda-4.7.12 | 3.0 MB | ################################################################ | 100%
    Preparing transaction: done
    Verifying transaction: done
    Executing transaction: done


    > install.packages(c('repr', 'IRdisplay', 'evaluate', 'crayon', 'pbdZMQ', 'devtools', 'uuid', 'digest'))

    ld: warning: -pie being ignored. It is only used when linking a main executable
    ld: warning: ignoring file /Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX.sdk/System/Library/Frameworks//CoreFoundation.framework/CoreFoundation.tbd, file was built for unsupported file format ( 0x2D 0x2D 0x2D 0x20 0x21 0x74 0x61 0x70 0x69 0x2D 0x74 0x62 0x64 0x2D 0x76 0x33 ) which is not the architecture being linked (x86_64): /Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX.sdk/System/Library/Frameworks//CoreFoundation.framework/CoreFoundation.tbd
    ld: warning: ignoring file /Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX.sdk/usr/lib/libSystem.tbd, file was built for unsupported file format ( 0x2D 0x2D 0x2D 0x20 0x21 0x74 0x61 0x70 0x69 0x2D 0x74 0x62 0x64 0x2D 0x76 0x33 ) which is not the architecture being linked (x86_64): /Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX.sdk/usr/lib/libSystem.tbd
    installing via 'install.libs.R' to /anaconda3/lib/R/library/00LOCK-pbdZMQ/00new/pbdZMQ

    * installing *source* package ‘uuid’ ...
    ** パッケージ ‘uuid’ の解凍および MD5 サムの検証に成功しました
    ** using staged installation
    checking for gcc... x86_64-apple-darwin13.4.0-clang
    checking whether the C compiler works... no
    configure: error: in `/private/var/folders/1j/ykvjgzl54qd3mffmxmk191c40000gn/T/RtmpVLl1WB/R.INSTALLac0e38e90178/uuid':
    configure: error: C compiler cannot create executables
    See `config.log' for more details
    ERROR: configuration failed for package ‘uuid’

    ld: warning: ignoring file /Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX.sdk/usr/lib/libSystem.tbd, file was built for unsupported file format ( 0x2D 0x2D 0x2D 0x20 0x21 0x74 0x61 0x70 0x69 0x2D 0x74 0x62 0x64 0x2D 0x76 0x33 ) which is not the architecture being linked (x86_64): /Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX.sdk/usr/lib/libSystem.tbd

    KojiDoiさんにご指摘頂いたエラーもまだ出ていますので、どこかに問題がある様に感じますが、何をどうすれば良いのが検討がつきません。

    キャンセル

  • 2019/10/27 02:08

    やはりgccを再インストールすべきじゃないでしょうか。gcc本体は存在していても環境が完全にはできていないように見えますが。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 87.92%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る