質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

88.35%

ruby on railsチュートリアル1.13時に発生した、bundle install失敗の回避策

受付中

回答 1

投稿 編集

  • 評価
  • クリップ 1
  • VIEW 554

chimakida

score 4

前提・実現したいこと

プログラミング初心者です。勉強を進めようと、まず以下チュートリアルを終わらせようとしています。
https://railstutorial.jp/chapters/beginning?version=5.1#code-gemfile_pg_gem

開発環境はAWS Cloud9、手順はスキップせず順ををってこなしている状況です。
チュートリアル外でしたことは、bundle updateを実行したのみです。

状況として1.13にて記載しろと言われているGemfileの内容を追記し、1.14のコマンドを実行したところエラーが出ます。
メッセージ的にはpgのバージョンを変更すればいい?のでしょうが、変に変更して
進めた後で問題が発生するのかもと思い、考え方や回避策についてアドバイス頂きたいです。

発生している問題・エラーメッセージ

ec2-user:~/environment/hello_app (master) $ bundle install --without production
Fetching gem metadata from https://rubygems.org/............
Fetching gem metadata from https://rubygems.org/.
Resolving dependencies...
Bundler could not find compatible versions for gem "ruby":
In Gemfile:
ruby

pg (= 0.20.0) was resolved to 0.20.0, which depends on
ruby (< 2.5) x64-mingw32

pg (= 0.20.0) was resolved to 0.20.0, which depends on
ruby (< 2.5) x86-mingw32

pg (= 0.20.0) was resolved to 0.20.0, which depends on
ruby (>= 2.0.0)
ec2-user:~/environment/hello_app (master) $ 

該当のソースコード

source 'https://rubygems.org'

gem 'rails',        '5.1.6'
gem 'puma',         '3.9.1'
gem 'sass-rails',   '5.0.6'
gem 'uglifier',     '3.2.0'
gem 'coffee-rails', '4.2.2'
gem 'jquery-rails', '4.3.1'
gem 'turbolinks',   '5.0.1'
gem 'jbuilder',     '2.6.4'

group :development, :test do
  gem 'sqlite3',      '1.3.13'
  gem 'byebug', '9.0.6', platform: :mri
end

group :development do
  gem 'web-console',           '3.5.1'
  gem 'listen',                '3.1.5'
  gem 'spring',                '2.0.2'
  gem 'spring-watcher-listen', '2.0.1'
end

group :production do
  gem 'pg', '0.20.0'
end

# Windows環境ではtzinfo-dataというgemを含める必要があります
gem 'tzinfo-data', platforms: [:mingw, :mswin, :x64_mingw, :jruby]

試したこと

0.20.0 のバージョンをいくつか変更してみましたが、pgのバージョンが何があるのか
わかりませんでした、yumの様にバージョン一覧が分かれば全部試せると思います。
ただ、チュートリアルの指定と変わるので不安はあります。

補足情報(FW/ツールのバージョンなど)

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

0

ちなみにrubyはインストールされていますか?

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2019/10/08 11:40

    rubyのバージョンが違うか、rubyがインストールされていないかのどちらかだと思います。
    ターミナルで「ruby -v」を叩いてみてください。

    キャンセル

  • 2019/10/08 12:02

    インストールはされているようです。
    ec2-user:~/environment/hello_app (master) $ ruby -v
    ruby 2.6.3p62 (2019-04-16 revision 67580) [x86_64-linux]

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 88.35%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る