質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

87.78%

Eclipse に DB viewer をダウンロードできない

解決済

回答 1

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 3,143

score 30

QuantumDBをeclipseと連携できず、上司もわからないというので諦めました。

DBviewer というプラグインがあるらしいので、それを導入できないかと考えています。

導入参考サイト

をみてやろうとしたのですが、新規ソフトウェアのインストール、という選択肢自体が出ないです。

また、質問するにあたって、eclipseのバージョンの調べ方についても調べました。

バージョン確認方法

を見ました。

しかし、eclipse について、という選択肢もやはり出なかったです。
そのためeclipseのバージョンはわかりません。

なぜ選択肢が出ないのか、選択肢を出すためにはどうすればよいのか、を伺いたいです。

どうぞよろしくお願いいたします。

Microsoft Windows [Version 10.0.17763.737]
java version "1.8.0_221"
Mysql8.0
Widnows10 Pro version 1809

起動画面
eclipse画面キャプチャ

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正、ベストアンサー選択の依頼

  • m.ts10806

    2019/09/27 16:07

    ただ、Jazz自体はオープンソースプロジェクトではないみたいで、独自の問題であればアドバイスは得られにくいかもしれません。

    キャンセル

  • masaking

    2019/09/27 16:55

    新しいeclipseをダウンロードして、javaもダウンロードしなおしたところ、簡単にマーケットプレイスに接続できました。

    DBviewerを見つけられなかったので、DBeaverをダウンロードして設定したところ、mysqlに接続することができました。

    eclipseのバージョンがおっしゃるようにネックだったみたいです。
    これから、導入の手順書を作って、上司に掛け合います。
    ありがとうございます。
    ご報告までに。

    キャンセル

  • m.ts10806

    2019/09/27 17:09

    それはJazzとして入れたものですか?Jazz利用の経緯や背景をきちんと確認しておかないとそれこそ「システム上の不整合」が起きて開発が進まなくなる懸念はあります。

    キャンセル

回答 1

checkベストアンサー

-1

バージョンにもよるので一概には言えませんが、マーケットプレイスから入手する方法以外にも「プラグインを単体で入手してEclipseのpluginフォルダにそのまま突っ込む」という手もあります。

eclipseにDBViewerPluginを追加する方法

ただ、やはりバージョン次第ですし、DBViewerが導入されているEclipseのバージョンに対応している必要があります。

提示いただいたiniからかなり古いものと推察されるので、対応しているかどうかは要確認です。
自身で任意のEclipseを導入できない環境なのであれば「そもそも導入無理」となる可能性もあるのでご留意ください。

質問冒頭に書かれているQuantumDBもEclipseのプラグインのようですがそもそもメンテナンスされてなさそうに見えます。最新のリリースが8年前ですね。

私であればEclipse含めて一通り環境を一新するように上に掛け合います。
とてもWin10で1.8でMySQL8で作ろうとしている環境には思えません。

投稿

編集

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2019/09/27 15:13

    ご連絡ありがとうございます。
    C:\jazz\client\eclipse\plugins

    zigen.plugin.db_1.2.3.v20101023.jar
    を突っ込んでみたところ、DBviewerをパースペクティブから開くことができました。

    その後、DBviewer pluginに

    データベース定義名: mysql
    を設定しました。

    JDBC Driverに
    C:\Program Files (x86)\MySQL\Connector J 8.0\mysql-connector-java-8.0.17\com\mysql-connector-java-8.0.17.jar
    をadd external jarしたものの、
    終了ボタンが明るくならずに困っています。

    導入不可能な可能性があること承知しました。
    アップデート自体は、自分で勝手にやるならどうぞ、というようなのでやってみようと思います。

    アップデータすると、社内のシステムと不整合?起こすかもしれないのでアップデートしていない、と聞きました。

    上と掛け合う点については、かけあい方がわからず、まず自分でやってみてから意見して、という上司のスタンスですので、やはり自分のeclipseをアップデートするところから始めようと思います。

    キャンセル

  • 2019/09/27 15:16

    パースペクティブに出たということは対応済みということで良いとは思いますが、互換性が100%保証されたわけではないと思います。使い方の問題がないわけではなさそうですが…。

    Eclipse自体は単体アップデートというより指定のEclipseをダウンロードしてくるのが一番早いのでそちらで。既存プロジェクトはエクスポート→インポートでいけるとは思います。

    キャンセル

  • 2019/09/27 15:18

    それにEclipseはあくまで開発ツールなのでシステム(要はプログラムコードですよね)が不整合起こすというのは考えがたいです。なんのことを言っているかは詳細確認必要そうに思います。
    ただ、自身で検証する許可を得られたのでしたらチャンスと思います。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 87.78%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る