質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

89.63%

.debファイルをインストールするためのlsbパッケージを探してます

解決済

回答 1

投稿

  • 評価
  • クリップ 0
  • VIEW 468

NCC1701

score 1496

前提・実現したいこと

Debian (on Docker)にてエプソンプリンタのドライバーをインストールしようとしてます。
apt install ./epson-inkjet-printer-escpr-1.7.3-1lsb3.2_amd64.deb
このようにコマンドを叩いたのですが、lsbが必要と言われました。が、apt-get install lsbではライブラリをインストールできませんでした。
lsb ソースパッケージは確かにあるようなのですが、どのようにすれば良いでしょうか?

発生している問題・エラーメッセージ

> の行が入力したコマンドです

> apt install ./epson-inkjet-printer-escpr-1.7.3-1lsb3.2_amd64.deb
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Note, selecting 'epson-inkjet-printer-escpr' instead of './epson-inkjet-printer-escpr-1.7.3-1lsb3.2_amd64.deb'
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 epson-inkjet-printer-escpr : Depends: lsb (>= 3.2) but it is not installable
E: Unable to correct problems, you have held broken packages.

> apt-get install lsb
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package lsb is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'lsb' has no installation candidate

試したこと

apt-getで見つからないパッケージを追加する方法(debian, ubuntu両方対応)を参考に次のことをしています。

> apt-get install apt-file
> apt-file update
> apt-file search apt-add-repository
> apt-get install -y software-properties-common
> apt-add-repository buster
Error: 'buster' invalid
> cat /etc/apt/sources.list
# deb http://snapshot.debian.org/archive/debian/20190708T033000Z buster main
deb http://deb.debian.org/debian buster main
# deb http://snapshot.debian.org/archive/debian-security/20190708T033000Z buster/updates main
deb http://security.debian.org/debian-security buster/updates main
# deb http://snapshot.debian.org/archive/debian/20190708T033000Z buster-updates main
deb http://deb.debian.org/debian buster-updates main

補足情報(FW/ツールのバージョンなど)

debian_version:10.1
PRETTY_NAME="Debian GNU/Linux 10 (buster)"
NAME="Debian GNU/Linux"
VERSION_ID="10"
VERSION="10 (buster)"
VERSION_CODENAME=buster
ID=debian
HOME_URL="https://www.debian.org/"
SUPPORT_URL="https://www.debian.org/support"
BUG_REPORT_URL="https://bugs.debian.org/"

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正、ベストアンサー選択の依頼

  • TaichiYanagiya

    2019/09/17 00:09

    パッケージ名は lsb ではなく、lsb-release ではないでしょうか?

    キャンセル

  • NCC1701

    2019/09/17 10:18

    lsb-base、lsb-release 両方インストールされてました。
    # apt list|grep lsb-
    lsb-base/stable,now 10.2019051400 all [installed,automatic]
    lsb-release/stable,now 10.2019051400 all [installed]

    キャンセル

回答 1

check解決した方法

0

Ubuntu にしてうまくいったので、Debian では諦めました。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2019/09/17 14:11

    LSB 関連の仕様が変わったのかもしれませんね。
    debian 10 で提供されている printer-driver-escpr をインストールして、別途、機種に合った PPD ファイルをインポートする手順になったのかもしれません。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 89.63%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

同じタグがついた質問を見る