質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

89.97%

Dockerfileで

解決済

回答 1

投稿

  • 評価
  • クリップ 2
  • VIEW 142

Nero1129

score 17

興味レベルでDockerの実験で、出来上がったイメージではなく、自分でイメージを作成してLAMP環境を整えたいと思っています。

リポジトリ追加でエラーになる。

とりあえず、Dockerでcentosのイメージを普通に引っ張ってきて、そのままRUNしてコンテナを立ち上げて、apacheとphp7.2、composer、laravelを入れることまでは成功したので、下記のようにDockerfileを書きました。

# イメージの指定
FROM centos:latest

#署名追加
RUN rpm --import /etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-7

# インストールコマンド
RUN yum install -y httpd

#ライブラリの追加
RUN yum install -y epel-release
RUN rpm -Uvh https://dl.fedoraproject.org/pub/epel/epel-release-latest-7.noarch.rpm
RUN rpm -Uvh http://rpms.famillecollet.com/enterprise/remi-release-7.rpm

# ここから下のコマンドには進まないので省略


最初は、epelのリポジトリさえも入りませんでした。
コンテナを起動して、普通にリポジトリを追加する分には署名などは関係なのですが、なんかDockerfileでリポジトリを追加する際には署名が必要だという記事がどこかに転がっていたので、書き込んだらepelのリポジトリは入ったのですが他のリポジトリは入らず、そのまま終わってしまい、buildされませんでした。

dockerの公式イメージのDockerfileを参考にしようとしたのですが、公式はCentosではなくDebianベースだったので参考にならず。

Complete!
Removing intermediate container c08a988e7eb3
 ---> 121cd6955a45
Step 5/14 : RUN rpm -Uvh https://dl.fedoraproject.org/pub/epel/epel-release-latest-7.noarch.rpm
 ---> Running in f57bb378cd1a
warning: /var/tmp/rpm-tmp.O0k8vF: Header V3 RSA/SHA256 Signature, key ID 352c64e5: NOKEY
Retrieving https://dl.fedoraproject.org/pub/epel/epel-release-latest-7.noarch.rpm
Preparing...                          ########################################
        package epel-release-7-11.noarch is already installed
The command '/bin/sh -c rpm -Uvh https://dl.fedoraproject.org/pub/epel/epel-release-latest-7.noarch.rpm' returned a non-zero code: 1

buildが勝手に終了するあたりのログです。
何が何だか、正直よくわかりません。
どうすれば、リポジトリを追加し、PHP7をインストールできるのでしょうか?
解説よろしくお願いいたします。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

checkベストアンサー

0

RUN yum install -y epel-release
RUN rpm -Uvh https://dl.fedoraproject.org/pub/epel/epel-release-latest-7.noarch.rpm

yum install -y epel-release で extras リポジトリから epel-release がインストールされるので、次の行で is already installed とエラーになり、build がストップしています。
やろうとしていることは同じなので、どちらか 1 行でいいです。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2019/09/16 16:07

    回答ありがとうございます。
    今さっき、コンテナを立てて、epel-releaseをインストールし、PHPをインストールしたのですが、PHPのバージョンが5.4.16が入ってしまい意味がありませんでした。
    勉強不足で申し訳ないですが、epel-releaseからPHP7以上をインストールするには、リポジトリを有効にするなどの中間手順が必要なのでしょうか?

    キャンセル

  • 2019/09/16 16:11

    "remi" "enablerepo" で調べてみてください。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 89.97%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる