質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

89.52%

LinuxサーバーにGoogle Chromeを入れたい

解決済

回答 3

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 742

Masalu_Kudou

score 30

お世話になっております。

現在私が使用しているSVPサーバー(さくらのVPS)にChromeを入れたいと思っております。

OSは、CentOS6の 6.10になります。
下記の記事を参考に手順を進めようとしているのですが、

yum install google-chrome-stable

を実行したときにエラーが出てしまいます。

参考記事> https://qiita.com/camopy/items/c7eda82f41c903bec298

読み込んだプラグイン:auto-update-debuginfo, fastestmirror, security
インストール処理の設定をしています
エラー: File contains parsing errors: file:///etc/yum.repos.d/google-chrome.repo
[line  7]: EOS

解消法がお分かりになられる方、是非よろしくお願いいたします。

→ scsiさん
申し訳ありません、昨日更新したつもりでしたができていませんでした。
repoファイルは下記の通りです。

[google-chrome]
name=google-chrome
baseurl=http://dl.google.com/linux/chrome/rpm/stable/$basearch
enabled=0
gpgcheck=1
gpgkey=https://dl-ssl.google.com/linux/linux_signing_key.pub

→ fu7mu4さん
set nuで番号振ってみたのですが、EOSらしいものがわからないです。。

 1 [google-chrome]
 2 name=google-chrome
 3 baseurl=http://dl.google.com/linux/chrome/rpm/stable/$basearch
 4 enabled=0
 5 gpgcheck=1
 6 gpgkey=https://dl-ssl.google.com/linux/linux_signing_key.pub

→ Orlofskyさん
知りませんでした。。教えてくださり、ありがとうございます。
修正いたしました。


追記
すみません、EOSの問題は解消されたのですが、別のエラーが出ております。

[root@tk2-258-38511 ~]# yum install google-chrome-stable
読み込んだプラグイン:auto-update-debuginfo, fastestmirror, security
インストール処理の設定をしています
Loading mirror speeds from cached hostfile
 * base: ty1.mirror.newmediaexpress.com
 * epel: nrt.edge.kernel.org
 * epel-debuginfo: nrt.edge.kernel.org
 * extras: ty1.mirror.newmediaexpress.com
 * updates: ty1.mirror.newmediaexpress.com
google-chrome                                            | 1.3 kB     00:00
依存性の解決をしています
--> トランザクションの確認を実行しています。
---> Package google-chrome-stable.x86_64 0:76.0.3809.132-1 will be インストール
--> 依存性の処理をしています: /usr/bin/lsb_release のパッケージ: google-chrome-stable-76.0.3809.132-1.x86_64
--> 依存性の処理をしています: libc.so.6(GLIBC_2.16)(64bit) のパッケージ: google-chrome-stable-76.0.3809.132-1.x86_64
--> 依存性の処理をしています: liberation-fonts のパッケージ: google-chrome-stable-76.0.3809.132-1.x86_64
--> 依存性の処理をしています: libgdk-3.so.0()(64bit) のパッケージ: google-chrome-stable-76.0.3809.132-1.x86_64
--> 依存性の処理をしています: libatspi.so.0()(64bit) のパッケージ: google-chrome-stable-76.0.3809.132-1.x86_64
--> 依存性の処理をしています: libXss.so.1()(64bit) のパッケージ: google-chrome-stable-76.0.3809.132-1.x86_64
--> 依存性の処理をしています: libappindicator3.so.1()(64bit) のパッケージ: google-chrome-stable-76.0.3809.132-1.x86_64
--> 依存性の処理をしています: libgtk-3.so.0()(64bit) のパッケージ: google-chrome-stable-76.0.3809.132-1.x86_64
--> 依存性の処理をしています: libatk-bridge-2.0.so.0()(64bit) のパッケージ: google-chrome-stable-76.0.3809.132-1.x86_64
--> トランザクションの確認を実行しています。
---> Package google-chrome-stable.x86_64 0:76.0.3809.132-1 will be インストール
--> 依存性の処理をしています: libc.so.6(GLIBC_2.16)(64bit) のパッケージ: google-chrome-stable-76.0.3809.132-1.x86_64
--> 依存性の処理をしています: liberation-fonts のパッケージ: google-chrome-stable-76.0.3809.132-1.x86_64
--> 依存性の処理をしています: libgdk-3.so.0()(64bit) のパッケージ: google-chrome-stable-76.0.3809.132-1.x86_64
--> 依存性の処理をしています: libatspi.so.0()(64bit) のパッケージ: google-chrome-stable-76.0.3809.132-1.x86_64
--> 依存性の処理をしています: libappindicator3.so.1()(64bit) のパッケージ: google-chrome-stable-76.0.3809.132-1.x86_64
--> 依存性の処理をしています: libgtk-3.so.0()(64bit) のパッケージ: google-chrome-stable-76.0.3809.132-1.x86_64
--> 依存性の処理をしています: libatk-bridge-2.0.so.0()(64bit) のパッケージ: google-chrome-stable-76.0.3809.132-1.x86_64
---> Package libXScrnSaver.x86_64 0:1.2.2-2.el6 will be インストール
---> Package redhat-lsb-core.x86_64 0:4.0-7.el6.centos will be インストール
--> 依存性の処理をしています: perl-Test-Simple のパッケージ: redhat-lsb-core-4.0-7.el6.centos.x86_64
--> 依存性の処理をしています: perl-Test-Harness のパッケージ: redhat-lsb-core-4.0-7.el6.centos.x86_64
--> 依存性の処理をしています: perl-ExtUtils-MakeMaker のパッケージ: redhat-lsb-core-4.0-7.el6.centos.x86_64
--> 依存性の処理をしています: perl-CGI のパッケージ: redhat-lsb-core-4.0-7.el6.centos.x86_64
--> 依存性の処理をしています: /usr/bin/pax のパッケージ: redhat-lsb-core-4.0-7.el6.centos.x86_64
--> トランザクションの確認を実行しています。
---> Package google-chrome-stable.x86_64 0:76.0.3809.132-1 will be インストール
--> 依存性の処理をしています: libc.so.6(GLIBC_2.16)(64bit) のパッケージ: google-chrome-stable-76.0.3809.132-1.x86_64
--> 依存性の処理をしています: liberation-fonts のパッケージ: google-chrome-stable-76.0.3809.132-1.x86_64
--> 依存性の処理をしています: libgdk-3.so.0()(64bit) のパッケージ: google-chrome-stable-76.0.3809.132-1.x86_64
--> 依存性の処理をしています: libatspi.so.0()(64bit) のパッケージ: google-chrome-stable-76.0.3809.132-1.x86_64
--> 依存性の処理をしています: libappindicator3.so.1()(64bit) のパッケージ: google-chrome-stable-76.0.3809.132-1.x86_64
--> 依存性の処理をしています: libgtk-3.so.0()(64bit) のパッケージ: google-chrome-stable-76.0.3809.132-1.x86_64
--> 依存性の処理をしています: libatk-bridge-2.0.so.0()(64bit) のパッケージ: google-chrome-stable-76.0.3809.132-1.x86_64
---> Package pax.x86_64 0:3.4-10.1.el6 will be インストール
---> Package perl-CGI.x86_64 0:3.51-144.el6 will be インストール
---> Package perl-ExtUtils-MakeMaker.x86_64 0:6.55-144.el6 will be インストール
--> 依存性の処理をしています: perl-devel のパッケージ: perl-ExtUtils-MakeMaker-6.55-144.el6.x86_64
---> Package perl-Test-Harness.x86_64 0:3.17-144.el6 will be インストール
---> Package perl-Test-Simple.x86_64 0:0.92-144.el6 will be インストール
--> トランザクションの確認を実行しています。
---> Package google-chrome-stable.x86_64 0:76.0.3809.132-1 will be インストール
--> 依存性の処理をしています: libc.so.6(GLIBC_2.16)(64bit) のパッケージ: google-chrome-stable-76.0.3809.132-1.x86_64
--> 依存性の処理をしています: liberation-fonts のパッケージ: google-chrome-stable-76.0.3809.132-1.x86_64
--> 依存性の処理をしています: libgdk-3.so.0()(64bit) のパッケージ: google-chrome-stable-76.0.3809.132-1.x86_64
--> 依存性の処理をしています: libatspi.so.0()(64bit) のパッケージ: google-chrome-stable-76.0.3809.132-1.x86_64
--> 依存性の処理をしています: libappindicator3.so.1()(64bit) のパッケージ: google-chrome-stable-76.0.3809.132-1.x86_64
--> 依存性の処理をしています: libgtk-3.so.0()(64bit) のパッケージ: google-chrome-stable-76.0.3809.132-1.x86_64
--> 依存性の処理をしています: libatk-bridge-2.0.so.0()(64bit) のパッケージ: google-chrome-stable-76.0.3809.132-1.x86_64
---> Package perl-devel.x86_64 4:5.10.1-144.el6 will be インストール
--> 依存性の処理をしています: perl(ExtUtils::ParseXS) のパッケージ: 4:perl-devel-5.10.1-144.el6.x86_64
--> 依存性の処理をしています: gdbm-devel のパッケージ: 4:perl-devel-5.10.1-144.el6.x86_64
--> 依存性の処理をしています: db4-devel のパッケージ: 4:perl-devel-5.10.1-144.el6.x86_64
--> トランザクションの確認を実行しています。
---> Package db4-devel.x86_64 0:4.7.25-22.el6 will be インストール
--> 依存性の処理をしています: db4-cxx = 4.7.25-22.el6 のパッケージ: db4-devel-4.7.25-22.el6.x86_64
--> 依存性の処理をしています: libdb_cxx-4.7.so()(64bit) のパッケージ: db4-devel-4.7.25-22.el6.x86_64
---> Package gdbm-devel.x86_64 0:1.8.0-39.el6 will be インストール
---> Package google-chrome-stable.x86_64 0:76.0.3809.132-1 will be インストール
--> 依存性の処理をしています: libc.so.6(GLIBC_2.16)(64bit) のパッケージ: google-chrome-stable-76.0.3809.132-1.x86_64
--> 依存性の処理をしています: liberation-fonts のパッケージ: google-chrome-stable-76.0.3809.132-1.x86_64
--> 依存性の処理をしています: libgdk-3.so.0()(64bit) のパッケージ: google-chrome-stable-76.0.3809.132-1.x86_64
--> 依存性の処理をしています: libatspi.so.0()(64bit) のパッケージ: google-chrome-stable-76.0.3809.132-1.x86_64
--> 依存性の処理をしています: libappindicator3.so.1()(64bit) のパッケージ: google-chrome-stable-76.0.3809.132-1.x86_64
--> 依存性の処理をしています: libgtk-3.so.0()(64bit) のパッケージ: google-chrome-stable-76.0.3809.132-1.x86_64
--> 依存性の処理をしています: libatk-bridge-2.0.so.0()(64bit) のパッケージ: google-chrome-stable-76.0.3809.132-1.x86_64
---> Package perl-ExtUtils-ParseXS.x86_64 1:2.2003.0-144.el6 will be インストー ル
--> トランザクションの確認を実行しています。
---> Package db4-cxx.x86_64 0:4.7.25-22.el6 will be インストール
---> Package google-chrome-stable.x86_64 0:76.0.3809.132-1 will be インストール
--> 依存性の処理をしています: libc.so.6(GLIBC_2.16)(64bit) のパッケージ: google-chrome-stable-76.0.3809.132-1.x86_64
--> 依存性の処理をしています: liberation-fonts のパッケージ: google-chrome-stable-76.0.3809.132-1.x86_64
--> 依存性の処理をしています: libgdk-3.so.0()(64bit) のパッケージ: google-chrome-stable-76.0.3809.132-1.x86_64
--> 依存性の処理をしています: libatspi.so.0()(64bit) のパッケージ: google-chrome-stable-76.0.3809.132-1.x86_64
--> 依存性の処理をしています: libappindicator3.so.1()(64bit) のパッケージ: google-chrome-stable-76.0.3809.132-1.x86_64
--> 依存性の処理をしています: libgtk-3.so.0()(64bit) のパッケージ: google-chrome-stable-76.0.3809.132-1.x86_64
--> 依存性の処理をしています: libatk-bridge-2.0.so.0()(64bit) のパッケージ: google-chrome-stable-76.0.3809.132-1.x86_64
--> 依存性解決を終了しました。
エラー: パッケージ: google-chrome-stable-76.0.3809.132-1.x86_64 (google-chrome)
             要求: libgdk-3.so.0()(64bit)
エラー: パッケージ: google-chrome-stable-76.0.3809.132-1.x86_64 (google-chrome)
             要求: libatspi.so.0()(64bit)
エラー: パッケージ: google-chrome-stable-76.0.3809.132-1.x86_64 (google-chrome)
             要求: liberation-fonts
エラー: パッケージ: google-chrome-stable-76.0.3809.132-1.x86_64 (google-chrome)
             要求: libatk-bridge-2.0.so.0()(64bit)
エラー: パッケージ: google-chrome-stable-76.0.3809.132-1.x86_64 (google-chrome)
             要求: libgtk-3.so.0()(64bit)
エラー: パッケージ: google-chrome-stable-76.0.3809.132-1.x86_64 (google-chrome)
             要求: libc.so.6(GLIBC_2.16)(64bit)
エラー: パッケージ: google-chrome-stable-76.0.3809.132-1.x86_64 (google-chrome)
             要求: libappindicator3.so.1()(64bit)
 問題を回避するために --skip-broken を用いることができません
 これらを試行できます: rpm -Va --nofiles --nodigest

試しにrpm -Va --nofiles --nodigestを実行したのですが、何の解決にもならなかったです。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正、ベストアンサー選択の依頼

  • scsi

    2019/08/28 22:22

    repoファイルの中身を質問に記述してください

    キャンセル

  • fu7mu4

    2019/08/29 00:13

    [line 7]: EOS あるので7行目にEOSの文字がはいってしまっているんじゃないでしょうか?

    キャンセル

  • Orlofsky

    2019/08/29 00:20

    URLは https://teratail.com/help/question-tips#questionTips3-7 の [リンク] に修正してください。

    キャンセル

回答 3

+1

enabled=1 にして試してもらえますか。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2019/08/29 22:41

    ご回答ありがとうございます。enabled=1にしても同じエラーが出てしまいました。。。

    キャンセル

checkベストアンサー

0

エラー: パッケージ: google-chrome-stable-76.0.3809.132-1.x86_64 (google-chrome)
             要求: libgdk-3.so.0()(64bit)
エラー: パッケージ: google-chrome-stable-76.0.3809.132-1.x86_64 (google-chrome)
             要求: libatspi.so.0()(64bit)
エラー: パッケージ: google-chrome-stable-76.0.3809.132-1.x86_64 (google-chrome)
             要求: liberation-fonts
エラー: パッケージ: google-chrome-stable-76.0.3809.132-1.x86_64 (google-chrome)
             要求: libatk-bridge-2.0.so.0()(64bit)
エラー: パッケージ: google-chrome-stable-76.0.3809.132-1.x86_64 (google-chrome)
             要求: libgtk-3.so.0()(64bit)
エラー: パッケージ: google-chrome-stable-76.0.3809.132-1.x86_64 (google-chrome)
             要求: libc.so.6(GLIBC_2.16)(64bit)
エラー: パッケージ: google-chrome-stable-76.0.3809.132-1.x86_64 (google-chrome)
             要求: libappindicator3.so.1()(64bit)

必要なパッケージがCentos6ではサポートされてないのでインストールできないのではと思います。
Centos7 環境に移行してください。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2019/09/16 22:12

    ご回答ありがとうございます。そしてご連絡遅くなり申し訳ありません。
    本日CentOS7への環境に移行しました。再度実施してみます。

    キャンセル

0

原因はやはりファイル内にEOSが入っていたようです。
しかし、私はViでずっと確認していて、ViではEOSの確認ができませんでした。
なんとなくVimで開いたところ、ファイルの一番下にEOSがあることが判明しました。

→ と思ったら、上記のエラーは解消したのですが、別のエラーでダウンロードができずにいます。

投稿

編集

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 89.52%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

同じタグがついた質問を見る