質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

87.79%

githubのWe found potential security vulnerabilities in your dependencies.というメッセージがついて

受付中

回答 1

投稿

  • 評価
  • クリップ 0
  • VIEW 541

score 29

githubに
イメージ説明
というメッセージが来ていて開いてみると
![イメージ説明
actionviewをクリックすると
イメージ説明
このように表示されています。
bundle updateをしてみましたが変わりませんでした。
どのようにすればこのメッセージは消えますか?

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正、ベストアンサー選択の依頼

  • querykuma

    2019/08/26 21:02

    エラーメッセージで検索したら記事がいくつも出てきます。
    記事はbundle updateで解決すると書いてあるのでbundle updateで解決しないのはおかしいですね。

    実物をコピーして試さないとわからないと思います。
    githubのURLを貼ってください。

    キャンセル

  • ikt_erk122

    2019/08/26 21:50

    https://github.com/ryusei1124/kintai-system
    いくつかリポジトリがあるのですが全てにメッセージが表示されています。
    よろしくお願いします

    キャンセル

  • querykuma

    2019/08/26 23:41 編集

    タグにRubyGemsとRubyを追加してください。
    手動でGemfile.lockのactionviewを>= 5.1.6.2あるいは6.0.0に書き換えればGitHubのエラーメッセージが消えますが、本当に解決した訳ではありません。
    何かの`bundle`コマンドで自動的にGemfile.lockが書き換わるはずだからです。
    RubyやRubygems(bundle)に詳しい方に尋ねるのがいいと思います。

    キャンセル

回答 1

0

$ gem list

...
actionview (6.0.0)
...

でactionviewのバージョンが調べられます。
一覧になかったのでgem install actionviewでインストールしました。

GitHubのメッセージはバージョン5.1.6.1以下のactionviewに脆弱性が見つかったのでactionviewを5.1.6.2以上に上げなさいということです。

GitHubはGemfile.lockを見てバージョンを調べているようです。
actionviewをインストールして更新するだけではなくGemfile.lockのファイルの中身も更新しなければなりません。

bundle updateでGemfile.lockが更新されるはずですが更新されませんでした。

私の環境下におけるエラーは次のとおりです。
あなたの環境下におけるエラーは違うかもしれません。
私の環境下におけるエラーが修正されても、あなたの環境下におけるエラーが修正されなかったら意味がありませんが、載せておきます。

$ bundle update actionview
Fetching gem metadata from https://rubygems.org/.........
Fetching gem metadata from https://rubygems.org/.
Resolving dependencies.....
Bundler could not find compatible versions for gem "ruby NUL":
  In Gemfile:
    ruby NUL

    listen (= 3.1.5) was resolved to 3.1.5, which depends on
      rb-inotify (>= 0.9.7, ~> 0.9) was resolved to 0.10.0, which depends on
        ffi (~> 1.0) was resolved to 1.11.1, which depends on
          ruby NUL (>= 2.2) x64-mingw32

    pg (= 0.20.0) was resolved to 0.20.0, which depends on
      ruby NUL (< 2.5) x64-mingw32

    bootstrap-sass (= 3.4.1) was resolved to 3.4.1, which depends on
      sassc (>= 2.0.0) was resolved to 2.1.0, which depends on
        ruby NUL (>= 2.0.0) x64-mingw32

    sqlite3 (= 1.3.13) was resolved to 1.3.13, which depends on
      ruby NUL (>= 1.8.7) x64-mingw32

Could not find gem 'ruby NUL (< 2.5)', which is required by gem 'pg (= 0.20.0)', in
any of the relevant sources:
  the local ruby installation

ここから先はわかりませんでしたのでRubyやRubygems(bundle)に詳しい方に聞くのがいいと思います。
最初にGemfile.lockのファイルを作った方が手動でactionviewのバージョンを書いたという可能性もあります。

Gemfile.lockにBUNDLED WITH 1.17.2と書いてあるので
$ gem install bundler -v 1.17.2
でインストールしました。

投稿

編集

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 87.79%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る