wordpress 更新ができない

解決済

回答 2

投稿

  • 評価
  • クリップ 0
  • VIEW 1,821
退会済みユーザー

退会済みユーザー

wordpressについて助けてください!

現在@niftyでwordpressのインストールを行いましたが、
バージョンが3.3.1の為、4.3.1にしようと思っているのですが (PHP5,MySQL5)、
ダッシュボードから自動アップデートを行おうとすると、

================================================

http://downloads.wordpress.org/release/ja/wordpress-4.3.1.zip から更新をダウンロードしています…
ダウンロードに失敗しました。: error setting certificate verify locations: CAfile: /etc/pki/tls/certs/ca-bundle.crt CApath: none
インストール失敗

================================================

と表示され何もできません。
PHPやMySQLのバージョンが対応していないのか、
何がなんだかよく分からない状態です。
ちなみ最初から入っているAkismetについても更新をしようとすると、

================================================

プラグインの更新: Akismet (1/1)
http://downloads.wordpress.org/plugin/akismet.2.5.10.zip から更新をダウンロードしています…
Akismet の更新中にエラーが起こりました: ダウンロードに失敗しました。 error setting certificate verify locations: CAfile: /etc/pki/tls/certs/ca-bundle.crt CApath: none

メンテナンスモードを無効にします…

すべての更新が完了しました。

================================================

となります。

どなたかご教授いただけると幸いです。
宜しくお願い致します。






  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 2

checkベストアンサー

+1

「error setting certificate verify locations」とありますし、wordpressのファイルを保持しているサーバーの証明書の正当性を確認するためのCAファイルがインストールされてないとかでしょうか。
PHPやMySQLのバージョンが云々というものではないと思います。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2015/11/20 10:24

    ご回答ありがとうございます。

    CAファイルは私が個人でどうにかできるのなのでしょうか?
    それともホスティング会社でやっていただくものになるのでしょうか?

    キャンセル

  • 2015/11/20 12:23

    どのようなサーバーを扱っているかにもよりますが、wordpressがインストールしてあるサーバーに対して行うものです。
    現状そのサーバーがwordpressアップデートファイル発行サーバーの認証ファイルを認知していないため、怪しいサーバーだと弾いている状態だと思います。

    私の場合はVPSなので自身でCAファイルのインストールを行っております。
    レンタルサーバーの場合、どの程度の権限が許容されているか分からないので、自身で出来るかどうかはハッキリとは言えませんが。

    キャンセル

  • 2015/11/20 15:57

    ありがとうございます!
    @niftyのホスティングサービスで恐らくVPSほど自由がないと(root権限もなさそう)思うので、レンタルサーバー自体を変えることにしました。
    ありがとうございました!

    キャンセル

0

http://club.jidaikobo.com/knowledge/102.html
上記のページで、同じエラー内容に対して対応しているようです。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2015/11/20 10:00

    連投で失礼します。
    調べてみると、rontecさんの言うとおり、サーバー証明書に関するCAファイルのエラーのようです。

    キャンセル

  • 2015/11/20 10:22

    ご回答ありがとうございます。
    教えていただいたサイトでの手順は関連していそうなファイルも含めて、
    探してみましたが、該当箇所がなく何もできませんでした。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.21%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる