質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

89.05%

unityでカメラロールから写真を選び自身のアプリに使いたいのですが、実機にダウンロード中にエラーになります。

受付中

回答 4

投稿 編集

  • 評価
  • クリップ 1
  • VIEW 856

tamachan2020

score 31

前提・実現したいこと

unityでカメラロールから写真を選び自身のアプリに使いたいのですが
ネットに参考になるurlがあったのですが、
https://github.com/thedoritos/unimgpickerJoin GitHub today
実機でテストしようとすると、実機にダウンロードしている最中にエラーが表示されます。
UnityEditor.BuildPlayerWindow+BuildMethodException:2 errors
何を調べれば良いか教えて頂けませんか。

発生している問題・エラーメッセージconsoleのエラー表示

![Error-1](c781971ee90ed6e45e6305f798f40fcd.png)
Error-2

VisualStudio 初期画面
ずっと出ていて邪魔くさい!!
消えてくれません。
インストール催促画面

UnityEditor.BuildPlayerWindow+BuildMethodException:2 errors

ビルド時表示内容
Build failure
com.android.build.api.transform.TransformException:
java.lang.RuntimeException:
java.lang.RuntimeException:Unable to pre-dex'/Users/*****/Desktop/unimagepicker-master/Temp/gradleOut/Unimagpicker/libs/unimagepicker.jar' to '/Users/******/Desktop/unimagepicker-master/Temp/gradleOut/build/intermediates/transform/preDex/release/2.jar' See the Console for details.

 

補足情報(FW/ツールのバージョンなど)

Unity 2018.2.5f1 Personal 64bit
ここにより詳細な情報を記載してください。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正、ベストアンサー選択の依頼

  • tamachan2020

    2019/08/18 16:02

    因みにtonkoさんのpcではhttps://github.com/thedoritos/unimgpicker "Join GitHub today" のgithubで動きますか?

    キャンセル

  • 退会済みユーザー

    退会済みユーザー

    2019/08/21 07:56

    動きますよ(^^)

    キャンセル

  • tamachan2020

    2019/08/21 19:45

    unity 2018.2.5f1 Personal(64bit)
    SDK: /Users/taeda-seiji/Library/Android/sdk
    JDK:/Library/Java/JavaVirtualMachines/jdk1.8.0_131.jdk/Contents/Home/
    NDK: /Applications/Unity/android-ndk-r13b
    MiniumApiLevel: Android 4.1 'jelly Bean" (API levvel 16)
    Target API Level : Automatic (highest installed)
    なのですが他に違いがあるのでしょうか?

    キャンセル

回答 4

0

Consoleウィンドウに他にエラーが出ているはずなので、それを調べてください。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

0

上の方が言われているようにしてみては?もしくは、そのコンソールのスクショを貼ってもいいですよ。(^^)

あと、URLはJoin GitHub todayという風にしてください。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2019/08/10 13:54

    では、NDKをインストールして、そのパスをその欄に入力してください。

    キャンセル

  • 2019/08/12 08:06

    NDKをセットしても同じでした。
    エラー内容が少し変わりました。他のアプリはBuildできるのでこのアプリの設定だと思うのですが?

    キャンセル

  • 2019/08/12 08:25

    MSAA support is disabled on High Sierra for this GPUのメッセージが表示されているのですが、SierraがバージョンアップされてMojava 10.14.5 になっています

    キャンセル

0

URLを貼りたいのでこちらから失礼します。
この方の質問をみてください。→Unityがビルドできない

それでもまだできない場合はお知らせください。

投稿

編集

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2019/08/14 10:49

    あぁ!これですか。私も実は同じのが出ています。私は毎回無視していますがね。
    この変なやつを毎回出ないようにしたいのですか?

    キャンセル

  • 2019/08/14 10:52

    Docにでも退避できれば良いのですが。

    キャンセル

  • 2019/09/14 14:00

    返信遅れすぎてすみません。
    どうしてもインストールしたいですか?
    どっちでもよければ無視することがオススメですね・・・(すみません。こんな回答で・・・)

    キャンセル

0

Unityは触ってないけどググってみた

  1. CommandInvokationFailure~
    【Unity2018対応】Androidビルドでエラーが出る場合の対処法の「Gradle build failedが出る」

  2. Build completed with a result of 'Failed'
    Unity Android向けにビルドしたときにエラーが起きてしまう
    【Unity】Androidへの書き出しでエラーが出る時 Build completed with a result of 'Failed'

質問に書いてあるのはエラーが二つあったよって程度のものなので肝心なのはその上に赤いビックリマークだと思うので、そっちを調べてみた

一つ目の方はいったん置いておくとして、二つ目の方はSDKのバージョンが違うという情報が出てきます
teratailの質問のベストアンサーを試してみてはいかがでしょうか?

原因はPleyer SettingsのTarget API Level が Minimum API Level と同じだったからみたいです。Target  API Level を Automatic に直したらビルドが通るようになりました。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2019/08/14 09:09

    SDK-Toolsのバージョンは29.0.1でSDKもインストールし直しました。Target API LeveはAutomaticにしています。

    キャンセル

  • 2019/08/14 09:52

    とりあえず、一つ目と二つ目の赤ビックリマークの内容もコピペして質問文に追加してください
    解決すべき内容はそちらなのですが、回答者には情報が途切れてしまって正直エラー内容が正確に把握できません

    キャンセル

  • 2019/08/14 10:11

    JdkとMinium Api Levelの問題でしょうか?

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 89.05%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る

  • トップ
  • Unityに関する質問
  • unityでカメラロールから写真を選び自身のアプリに使いたいのですが、実機にダウンロード中にエラーになります。