質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

88.06%

rails bundleインストールできない

受付中

回答 1

投稿

  • 評価
  • クリップ 0
  • VIEW 1,106

score 13

前提・実現したいこと

rails の bundleをインストールしたい

発生している問題・エラーメッセージ

下記のエラーがでインストールができない。
gemfile.lockのファイルが生成されない

該当のソースコード

An error occurred while installing nokogiri (1.10.3), and Bundler cannot
continue.
Make sure that gem install nokogiri -v '1.10.3' --source 'https://rubygems.org/' succeeds before bundling.

In Gemfile:
rails was resolved to 5.2.3, which depends on
actioncable was resolved to 5.2.3, which depends on
actionpack was resolved to 5.2.3, which depends on
actionview was resolved to 5.2.3, which depends on
rails-dom-testing was resolved to 2.0.3, which depends on
nokogiri

試したこと

gemfile に gem "nokogiri" を追記したが
現象は変わらない

補足情報(FW/ツールのバージョンなど)source 'https://rubygems.org'

下記がgemfile です

git_source(:github) { |repo| "https://github.com/#{repo}.git" }

ruby '2.6.3'

Bundle edge Rails instead: gem 'rails', github: 'rails/rails'

gem 'rails', '~> 5.2.3'

Use sqlite3 as the database for Active Record

gem 'sqlite3'

Use Puma as the app server

gem 'puma', '~> 3.11'

Use SCSS for stylesheets

gem 'sass-rails', '~> 5.0'

Use Uglifier as compressor for JavaScript assets

gem 'uglifier', '>= 1.3.0'

See https://github.com/rails/execjs#readme for more supported runtimes

gem 'duktape'

Use CoffeeScript for .coffee assets and views

gem 'coffee-rails', '~> 4.2'

Turbolinks makes navigating your web application faster. Read more: https://github.com/turbolinks/turbolinks

gem 'turbolinks', '~> 5'

Build JSON APIs with ease. Read more: https://github.com/rails/jbuilder

gem 'jbuilder', '~> 2.5'

Use Redis adapter to run Action Cable in production

gem 'redis', '~> 4.0'

Use ActiveModel has_secure_password

gem 'bcrypt', '~> 3.1.7'

Use ActiveStorage variant

gem 'mini_magick', '~> 4.8'

Use Capistrano for deployment

gem 'capistrano-rails', group: :development

Reduces boot times through caching; required in config/boot.rb

gem 'bootsnap', '>= 1.1.0', require: false

group :development, :test do

Call 'byebug' anywhere in the code to stop execution and get a debugger console

gem 'byebug', platforms: [:mri, :mingw, :x64_mingw]
end

group :development do

Access an interactive console on exception pages or by calling 'console' anywhere in the code.

gem 'web-console', '>= 3.3.0'
end

group :test do

Adds support for Capybara system testing and selenium driver

gem 'capybara', '>= 2.15'
gem 'selenium-webdriver'

Easy installation and use of chromedriver to run system tests with Chrome

gem 'chromedriver-helper'
end

Windows does not include zoneinfo files, so bundle the tzinfo-data gem

gem 'tzinfo-data'#, platforms: [:mingw, :mswin, :x64_mingw, :jruby]
gem "nokogiri" , "1.10.3"

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正、ベストアンサー選択の依頼

  • 8zca

    2019/08/06 21:34

    こんばんは。
    出力された結果の全文を貼ってもらえるとエラーの原因がつかみやすくなります。
    また、gemファイルは「コードの挿入」機能を使ってもらえると読みやすくなるのでうれしいです。

    キャンセル

  • sumio

    2019/08/06 22:17

    ご回答ありがとうございます。
    ネットで色々調べて、かいますが一向に糸口が見えず、かれこれ2週間ほどハマっています。何卒よろしくお願いします。
    下記が全文です。

    c:\test-app>bundle install
    Fetching gem metadata from https://rubygems.org/.............
    Fetching gem metadata from https://rubygems.org/.
    Resolving dependencies....
    Using rake 12.3.3
    Using concurrent-ruby 1.1.5
    Using i18n 1.6.0
    Using minitest 5.11.3
    Using thread_safe 0.3.6
    Using tzinfo 1.2.5
    Using activesupport 5.2.3
    Using builder 3.2.3
    Using erubi 1.8.0
    Using mini_portile2 2.4.0
    Fetching nokogiri 1.10.3
    Installing nokogiri 1.10.3 with native extensions
    Gem::Ext::BuildError: ERROR: Failed to build gem native extension.

    current directory:
    c:/test-app/vendor/bundle/ruby/2.6.0/gems/nokogiri-1.10.3/ext/nokogiri
    C:/Ruby26-x64/bin/ruby.exe -I C:/Ruby26-x64/lib/ruby/site_ruby/2.6.0 -r
    ./siteconf20190806-6524-18g9dye.rb extconf.rb --use-system-libraries
    checking if the C compiler accepts ... yes
    Building nokogiri using system libraries.
    pkg-config could not be used to find libxml-2.0
    Please install either `pkg-config` or the pkg-config gem per

    gem install pkg-config -v "~> 1.1"

    pkg-config could not be used to find libxslt
    Please install either `pkg-config` or the pkg-config gem per

    gem install pkg-config -v "~> 1.1"

    pkg-config could not be used to find libexslt
    Please install either `pkg-config` or the pkg-config gem per

    gem install pkg-config -v "~> 1.1"

    ERROR: cannot discover where libxml2 is located on your system. please make sure
    `pkg-config` is installed.
    *** extconf.rb failed ***
    Could not create Makefile due to some reason, probably lack of necessary
    libraries and/or headers. Check the mkmf.log file for more details. You may
    need configuration options.

    Provided configuration options:
    --with-opt-dir
    --without-opt-dir
    --with-opt-include
    --without-opt-include=${opt-dir}/include
    --with-opt-lib
    --without-opt-lib=${opt-dir}/lib
    --with-make-prog
    --without-make-prog
    --srcdir=.
    --curdir
    --ruby=C:/Ruby26-x64/bin/$(RUBY_BASE_NAME)
    --help
    --clean
    --use-system-libraries
    --with-zlib-dir
    --without-zlib-dir
    --with-zlib-include
    --without-zlib-include=${zlib-dir}/include
    --with-zlib-lib
    --without-zlib-lib=${zlib-dir}/lib
    --with-xml2-dir
    --without-xml2-dir
    --with-xml2-include
    --without-xml2-include=${xml2-dir}/include
    --with-xml2-lib
    --without-xml2-lib=${xml2-dir}/lib
    --with-libxml-2.0-config
    --without-libxml-2.0-config
    --with-pkg-config
    --without-pkg-config
    --with-xslt-dir
    --without-xslt-dir
    --with-xslt-include
    --without-xslt-include=${xslt-dir}/include
    --with-xslt-lib
    --without-xslt-lib=${xslt-dir}/lib
    --with-libxslt-config
    --without-libxslt-config
    --with-exslt-dir
    --without-exslt-dir
    --with-exslt-include
    --without-exslt-include=${exslt-dir}/include
    --with-exslt-lib
    --without-exslt-lib=${exslt-dir}/lib
    --with-libexslt-config
    --without-libexslt-config

    To see why this extension failed to compile, please check the mkmf.log which can
    be found here:

    c:/test-app/vendor/bundle/ruby/2.6.0/extensions/x64-mingw32/2.6.0/nokogiri-1.10.3/mkmf.log

    extconf failed, exit code 1

    Gem files will remain installed in
    c:/test-app/vendor/bundle/ruby/2.6.0/gems/nokogiri-1.10.3 for inspection.
    Results logged to
    c:/test-app/vendor/bundle/ruby/2.6.0/extensions/x64-mingw32/2.6.0/nokogiri-1.10.3/gem_make.out

    An error occurred while installing nokogiri (1.10.3), and Bundler cannot
    continue.
    Make sure that `gem install nokogiri -v '1.10.3' --source
    'https://rubygems.org/'` succeeds before bundling.

    In Gemfile:
    rails was resolved to 5.2.3, which depends on
    actioncable was resolved to 5.2.3, which depends on
    actionpack was resolved to 5.2.3, which depends on
    actionview was resolved to 5.2.3, which depends on
    rails-dom-testing was resolved to 2.0.3, which depends on
    nokogiri

    キャンセル

回答 1

0

こんばんは。
この手のエラーは、ちゃんとエラーを読むと解決の糸口がつかめます。
貼っていただいているエラーメッセージに

ERROR: cannot discover where libxml2 is located on your system


と出ていますので、libxml2を入れてあげればbundle installできると思います。

OSのバージョンによって手順は変わるかもしれませんが、Windowsで同様の手順を踏まれた方のQiita記事があったので参考までに貼っておきますね。
https://qiita.com/tanakahisateru/items/76d7049b806dfa2e59f9

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2019/08/07 22:02

    ご回答ありがとうございます。
    お教えいただいたサイトの手順通りに進めているのですが、またつまずいています。msys.batを開いてコマンド入力してもエラーが出てしまいます。
    対処方法をお教え願います

    ーーーーーーー下記がーーーーーーーーーー
    smio@LAPTOP-JTI84MF7 ~
    $ cd libxml2
    sh: cd: libxml2: No such file or directory

    sumio@LAPTOP-JTI84MF7 ~
    $
    ーーーーーーーーーーーーーーーー


    ーーーーーー下記が手順ーーーーーーーーー
    DevKitの msys.bat を叩いてもうひとつシェルを開きます。

    $ cd libxml2

    $ cd libxml2-2.9.1
    $ ./configure
    $ make
    $ make install
    $ cd ..



    $ cd libxslt-1.1.28
    $ ./configure

    キャンセル

  • 2019/08/08 01:17

    cd: libxml2: No such file or directory
    は libxml2 のフォルダが無いという意味です。

    1つ上の手順で mkdir libxml2 を実行することで libxml2フォルダを作っていると思いますが、
    そこに移動するということを指しています。

    キャンセル

  • 2019/08/09 00:12

    度々すみません
    DevKitの msys.bat を叩いてもうひとつシェルを開いて実行したのですが
    今度は  $ ./configure  のところでエラーがでてしまいました。
    どうすればよいでしょうか?

    ーーーーコマンドーーーーーーーー
    sumio@LAPTOP-JTI84MF7 ~
    $ cd libxml2

    sumio@LAPTOP-JTI84MF7 ~/libxml2
    $ cd libxml2-2.9.1

    sumio@LAPTOP-JTI84MF7 ~/libxml2/libxml2-2.9.1
    $ ./configure
    sh: ./configure: No such file or directory

    sumio@LAPTOP-JTI84MF7 ~/libxml2/libxml2-2.9.1
    $

    キャンセル

  • 2019/08/09 00:48

    /libxml2/libxml2-2.9.1
    にいる状態で
    ls -la
    を打った結果を教えてください。

    ちなみに以下のコマンドは実行済ですよね?
    これをやることで libxml2-2.9.1 フォルダが作られ、その中に configure ファイルが存在しているはずです。
    --- コマンド --
    $ curl -O ftp://xmlsoft.org/libxml2/libxml2-2.9.1.tar.gz
    $ tar xzf libxml2-2.9.1.tar.gz

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 88.06%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る