質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

88.32%

Laravelのバージョンアップでエラー

解決済

回答 1

投稿

  • 評価
  • クリップ 0
  • VIEW 882

nyaron.

score 13

LaravelとMAMP使っています。 
Laravel5.2から5.8にバージョンアップのためcomposer.jsonを以下のように書き換えて

composer.json

{
    "name": "laravel/laravel",
    "description": "The Laravel Framework.",
    "keywords": ["framework", "laravel"],
    "license": "MIT",
    "type": "project",
    "require": {
        "php": ">=7.3.7",
        "laravel/framework": "5.8.*"
    },
    "require-dev": {
        "fzaninotto/faker": "~1.4",
        "mockery/mockery": "0.9.*",
        "phpunit/phpunit": "~7.0",
        "symfony/css-selector": "2.8.*|3.0.*",
        "symfony/dom-crawler": "2.8.*|3.0.*"
    },
    "autoload": {
        "classmap": [
                     "database"
                     ],
        "psr-4": {
            "App\\": "app/"
        }
    },
    "autoload-dev": {
        "classmap": [
                     "tests/TestCase.php"
                     ]
    },
    "scripts": {
        "post-root-package-install": [
                                      "php -r \"copy('.env.example', '.env');\""
                                      ],
        "post-create-project-cmd": [
                                    "php artisan key:generate"
                                    ],
        "post-install-cmd": [
                             "Illuminate\\Foundation\\ComposerScripts::postInstall",
                             "php artisan optimize"
                             ],
        "post-update-cmd": [
                            "Illuminate\\Foundation\\ComposerScripts::postUpdate",
                            "php artisan optimize"
                            ]
    },
    "config": {
        "preferred-install": "dist",
        "sort-packages": true,
        "optimize-autoloader": true,
        "platform": {
            "php": "7.3.7"
        }
    }
}

「composer update」を実行したところエラーが発生しました。(Laravelのバージョンアップは成功したみたいです)
Parse error: parse error, expecting '&'' or "variable (T_VARIABLE)"' in /Applications/MAMP/htdocs/mojiart/vendor/symfony/var-dumper/Resources/functions/dump.php on line 18

「php -v」 でPHPのバージョンを調べると
PHP 5.5.34 (cli) (built: Apr 22 2016 19:16:58) 
Copyright (c) 1997-2015 The PHP Group
Zend Engine v2.5.0, Copyright (c) 1998-2015 Zend Technologies
と返ってきました。(ちなみにMAMPのPHPバージョンは7.3.7でした。)

MAMPのPHPとバージョンが違うようです。
解決策を教えてもらえないでしょうか?

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

checkベストアンサー

+1

cliのphpのバージョンを上げるか
cliのphpのパスをmampのphpに書き換えてください

おそらくcliのphqはmamp付属のものではなくmamp付属のものです。
homebrewでバージョンをあげるのが簡単だと思います

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2019/08/11 21:21

    OSがEl Capitanだったので対応するhomebrewのバージョンもPHP5が限界だったのですが、
    その後、OSをHigh Sierraにアップデートしたと同時にhomebrewのバージョンも上がったのでPHPを7にアップデート出来ました。
    ありがとうございました。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 88.32%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る