質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

88.80%

【macOS】Your Ruby version is 2.3.7, but your Gemfile specified 2.3.0

解決済

回答 1

投稿 編集

  • 評価
  • クリップ 1
  • VIEW 697

ayachika

score 36

初めてmacを購入し、環境構築をするために該当プロジェクトに記載の通り、必要なソフトウェアのインストールをしました。

homebrewのインストール後、brewを使用し、以下の通り必要な物をインストールしました。

$ brew install mysql
$ brew install git
$ brew install rbenv
$ brew install ruby-build
$ brew install graphviz(これも一応)

さらに今回使用したいバージョンのRubyをインストールしました。

$ rbenv install 2.3.0

エラー内容

はじめ、参照するrubyのPATHが違っていて、macにデフォルトで入っているruby2.3.7を参照していたので、それに対する対処をし、以下のようにrubyのPATHの設定も完了しました。

$ which ruby
/Users/user/.rbenv/shims/ruby

usernoMacBook-Air:project user$ ruby -v
ruby 2.3.0p0 (2015-12-25 revision 53290) [x86_64-darwin18]

しかし、bunsle installをしようとすると、いまだにこのエラーが出ます。

$ bundle install --path vendor/bundle
Your Ruby version is 2.3.7, but your Gemfile specified 2.3.0

おそらくbundleのPATH設定がおかしいのかなと思うのですが、対処の方法がわかりません。
bundleは以下のようになっています。

$ which bundle
/usr/local/bin/bundle

PATHを確認してみると

$ echo $PATH
/Users/user/.rbenv/shims:/Users/user/.rbenv/bin:/Users/user/.rbenv/shims:/usr/local/bin:/usr/bin:/bin:/usr/sbin:/sbin:/Users/user/.rbenv/shims:/Users/user/.rbenv/bin

さらに以下の通りみてみると、まだruby2.3.0ではなくデフォルトのシステムの方のrubyを参照していることがわかります。

$ bundle env
## Environment

Bundler 2.0.2
Platforms ruby, universal-darwin-18
Ruby 2.3.7p456 (2018-03-28 revision 63024) [universal.x86_64-darwin18]

これはなぜなのでしょうか。
対策をとったはずなのですが、参照するPATHが違うようで、原因がわかりません。

ちなみに参考にしたサイトは以下3つです。

rbenvでバージョンがうまく切り替わらなかった時にやったこと
【2018年版】macにrbenvを入れてrubyを管理できるようにしちゃう
rbenv+ruby-buildを使ってMacにRubyの環境を構築する

解決策をご存知の方がいらっしゃれば、ご教示下さいますようよろしくお願いします。

追記

asm様に解決方法を示していただき、解決することができました。
追記ですが、$ gem install bundler後、$rbenv rehashを実行する必要がありました。
bundlerをインストールしたら毎回このコマンドを実行しなければいけません。
なぜなら、このコマンドにより、gem,rake,rails,rubyなどのコマンドをrbenvに渡してくれるshimsという軽量実行ファイルをインストールしているからだそうです。(ここでは深く記述しません)

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

checkベストアンサー

0

ruby 2.3だとbundlerはデフォルトでインストールされるgemではないので、自分でインストールが必要です。

gemコマンドが/Users/user/.rbenv/shims/rubyになってることを確認した後に
$ gem install bundler
を実行

rbenvでsystemに切り替えた後に$ gem uninstall bundlerしておいた方が今後のためかもしれません。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2019/08/02 21:27 編集

    asm様
    ご回答ありがとうございます。遅くなりましたが、一つ質問があります。
    $ gem environment を行うと、下の通り表示されたのですが、これでは/Users/user/.rbenv/shims/rubyではないですよね・・調べてみたのですが、正確なパスではないと思いまして・・その場合、パスを正確なものに設定する必要がありますか?
    連続した質問で申し訳ありませんが、可能であれば教えていただけると幸いです。
    - GEM PATHS:
    - /Users/user/.rbenv/versions/2.3.0/lib/ruby/gems/2.3.0
    - /Users/user/.gem/ruby/2.3.0

    キャンセル

  • 2019/08/03 04:49

    おそらく大丈夫ですよ
    「which gemの結果が~/.rbenv/shimsになってるか、確認してね」
    くらいの意味だったので

    キャンセル

  • 2019/08/03 08:37

    asm 様 which gem の結果、パスはあっていました!まだ最後まで作業をしておりませんが、取り急ぎお礼申し上げます。ありがとうございます。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 88.80%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る