質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

89.98%

[Android Studio]gradleプロジェクトの同期に失敗しましたというエラーメッセージが発生しました

解決済

回答 3

投稿

  • 評価
  • クリップ 0
  • VIEW 521

moke995

score 6

前提・実現したいこと

AndroidStudioをでプロジェクトを作成した際に、
gradleプロジェクトの同期に失敗しましたというエラーメッセージが発生しました。
イメージ説明
イメージ説明
イメージ説明

発生している問題・エラーメッセージ

gradleプロジェクトの同期に失敗しました。基本的な機能(編集、デバックなど)は正しく機能しません。と表示されます。
その影響かxmlではビルドが成功するまでプレビューは使用できませんと表示されます。
ビルドにはエラーが表示されていますが、ログキャットには何も表示されていません。

試したこと

再インストールしました。
また、gradleプロジェクトの同期に失敗しましたのワードで解決策を検索しましたがエラーの箇所が違うらしく参考になりませんでした。

補足情報(FW/ツールのバージョンなど)

Android Studioのバージョンは3.11です。
インストールと初期設定は以下サイトを参考にしました。
変にいじったりはしていません。
https://keiji.github.io/the-androidstudio-book/
日本語化はEclipseのサイトのやつを使用しました。(7732b67c4a33e20bfaa03677f924719d.png)
解決の手がかりがありましたらご教示頂けると幸いです。よろしくお願いします。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 3

checkベストアンサー

+1

あと現時点(2019/7/31)で、Android Studio の最新バージョンは 3.4.2 ですね。最新バージョンで試された方がよいかもしれません。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2019/08/01 13:11

    ネットワークを繋いでも治らなかったので最新バージョンをインストールしたらエラーが出なくなりましたありがとうございます!

    キャンセル

+1

com.android.support以下のパッケージ(旧サポートライブラリ)は28.0.0までしかリリースされていません。APIレベル29以上を対象とするなら、AndroidXに移行する必要があります。
https://developer.android.com/topic/libraries/support-library/revisions#september-21,-2018

最新のAndroid Studioを使えばプロジェクトの作成時にAndroidXを使うかどうかを選択するオプションがあるので、まずは最新の環境でプロジェクトを作り直してみてください。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2019/08/01 13:10

    最新バージョンのAndroid Studioに変えたらエラーが出なくなりましたありがとうございます!

    キャンセル

0

ネットワークに接続できる状態ですかね?(ライブラリ類がネットワークから取得できない、というエラー内容のように見受けられます。)

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 89.98%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる