質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.12%

Mac環境からmysqlを使用したい。。。Authentication plugin 'caching_sha2_password' cannot be loaded:

解決済

回答 1

投稿

  • 評価
  • クリップ 0
  • VIEW 384

kozuketec

score 136

やりたいこと

Mac環境からmysqlを使用したい。

先の目的はpythonのsqlalchemyでmysqlのdbを操作したい。
その前段でmysqlをinstall使用している際に発生。

起きているエラー

MySQL8系に変わったタイミングで認証方式が変わったらしいが、brew install mysql@5.6で8系はinstallしていない。
MySQL公式Doc

ERROR 2059 (HY000): Authentication plugin 'caching_sha2_password' cannot be loaded: dlopen(/usr/local/Cellar/mysql@5.6/5.6.43/lib/plugin/caching_sha2_password.so, 2): image not found

試したこと

このエラーが発生する前にはMySQL8系で接続できていた。
ますbrew instal mysqlで8系のmysqlをinstall。
それからbrew install mysql-connector-cをした時に、以下のエラーが発生。

Error: Cannot install mysql-connector-c because conflicting formulae are installed.
  mysql: because both install MySQL client libraries

Please `brew unlink mysql` before continuing.


brew info mysqlをしてみると。

mysql: stable 8.0.16 (bottled)
Open source relational database management system
https://dev.mysql.com/doc/refman/8.0/en/
Conflicts with:
  mariadb (because mysql, mariadb, and percona install the same binaries.)
  mariadb-connector-c (because both install plugins)
  mysql-cluster (because mysql, mariadb, and percona install the same binaries.)
  mysql-connector-c (because both install MySQL client libraries)


確かにコンフリクトしているような記載がある。

公式サイトから直接connectorをインストールしてみたが特に状況は変わらず。
※なんとなくこのインストールが悪さしている気はする。

それから、ググって出てきたブログ記事より、MysqlバージョンをDowngradeしてみるとエラーがなくなるような記事を発見。

brew uninstall mysqlを実行。
/usr/local/var/mysql配下のファイルも全てremove

brew install mysql@5.6で5.6バージョンをインストール。
すると、コネクターも無事インストール完了。

それから、mysqlのパスを通して、echo 'export PATH="/usr/local/opt/mysql@5.6/bin:$PATH"' >> ~/.bash_profile
mysqlコマンドを実行すると、上記のエラーになる。

路頭に迷いました。。。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

check解決した方法

0

再起動したら問題なくmysql起動できました。
よくあるやつです。。。。。。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.12%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる