質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

新規登録して質問してみよう
ただいま回答率
87.20%

解決済

AtomへのTerm2のインストールについて

oyd0312
oyd0312

総合スコア0

1回答

0評価

0クリップ

3655閲覧

投稿2015/11/15 15:39

AtomへTerm2をインストールしようとすると以下のエラーが出ます。

質問できるテキストの長さの問題上一部を抜粋して掲載します。

10

make: \*\*\* \[Release/obj\.target/pty/src/unix/pty\.o\] Error 1 gyp ERR! build error gyp ERR! stack Error: `make` failed with exit code: 2 gyp ERR! stack at ChildProcess\.onExit \(/Applications/Atom\.app/Contents/Resources/app/apm/node_modules/npm/node_modules/node-gyp/lib/build\.js:269:23\) gyp ERR! stack at ChildProcess\.emit \(events\.js:98:17\) gyp ERR! stack at Process\.ChildProcess\._handle\.onexit \(child_process\.js:820:12\) gyp ERR! System Darwin 15\.0\.0 gyp ERR! command "node" "/Applications/Atom\.app/Contents/Resources/app/apm/node_modules/npm/node_modules/node-gyp/bin/node-gyp\.js" "rebuild" gyp ERR! cwd /private/var/folders/lc/c4fwxb2x0ms2l0g51bs6crb80000gn/T/apm-install-dir-1151016-3511-1lihwll/node_modules/term2/node_modules/pty\.js gyp ERR! node -v v0\.10\.40 gyp ERR! node-gyp -v v2\.0\.2 gyp ERR! not ok npm ERR! Darwin 15\.0\.0 npm ERR! argv "/Applications/Atom\.app/Contents/Resources/app/apm/bin/node" "/Applications/Atom\.app/Contents/Resources/app/apm/node_modules/npm/bin/npm-cli\.js" "--globalconfig" "/Users/oyamadakeisuke/\.atom/\.apm/\.apmrc" "--userconfig" "/Users/oyamadakeisuke/\.atom/\.apmrc" "install" "/private/var/folders/lc/c4fwxb2x0ms2l0g51bs6crb80000gn/T/d-1151016-3511-fnaa3c/package\.tgz" "--target=0\.34\.0" "--arch=x64" npm ERR! node v0\.10\.40 npm ERR! npm v2\.13\.3 npm ERR! code ELIFECYCLE npm ERR! pty\.js@0\.2\.13 install: `node-gyp rebuild` npm ERR! Exit status 1 npm ERR! npm ERR! Failed at the pty\.js@0\.2\.13 install script 'node-gyp rebuild'\. npm ERR! This is most likely a problem with the pty\.js package, npm ERR! not with npm itself\. npm ERR! Tell the author that this fails on your system: npm ERR! node-gyp rebuild npm ERR! You can get their info via: npm ERR! npm owner ls pty\.js npm ERR! There is likely additional logging output above\. npm ERR! Please include the following file with any support request: npm ERR! /private/var/folders/lc/c4fwxb2x0ms2l0g51bs6crb80000gn/T/apm-install-dir-1151016-3511-1lihwll/npm-debug\.log コード

このようにエラーが出ます。
npm v3.3.6
node v5.0.0
xcode v7.1.1
comannd line tools For Xcode v7.1
環境は、OS X El Capitan 10.11.1です。
いろいろと調べたのですが、解決につながる方法が見つからなかったので、質問させていただきます。
よろしくお願いします。

良い質問の評価を上げる

以下のような質問は評価を上げましょう

  • 質問内容が明確
  • 自分も答えを知りたい
  • 質問者以外のユーザにも役立つ

評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

気になる質問をクリップする

クリップした質問は、後からいつでもマイページで確認できます。

またクリップした質問に回答があった際、通知やメールを受け取ることができます。

teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

  • プログラミングに関係のない質問
  • やってほしいことだけを記載した丸投げの質問
  • 問題・課題が含まれていない質問
  • 意図的に内容が抹消された質問
  • 過去に投稿した質問と同じ内容の質問
  • 広告と受け取られるような投稿

評価を下げると、トップページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

まだ回答がついていません

会員登録して回答してみよう

15分調べてもわからないことは
teratailで質問しよう!

ただいまの回答率
87.20%

質問をまとめることで
思考を整理して素早く解決

テンプレート機能で
簡単に質問をまとめる

質問する

関連した質問

同じタグがついた質問を見る