質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

88.62%

Ruby on Railsでbundle installがエラーになってしまう

解決済

回答 1

投稿

  • 評価
  • クリップ 1
  • VIEW 2,854
退会済みユーザー

退会済みユーザー

前提・実現したいこと

Ruby on Rails5のチュートリアルを使って勉強をしています。

現在第3章まで進み、新しいアプリケーションの作成にあたってGemのカスタマイズを行なっているのですが、bundle installやbundle updateを実行してもエラーが発生してしまいます。

まだRubyの学習を初めて二週間程度なので野暮な質問かもしれませんが、チュートリアルを進めることができず困っているのでどうかよろしくお願いします。

発生している問題・エラーメッセージ

#bundle installを実行した場合
You have requested:
  listen = 3.0.8

The bundle currently has listen locked at 3.1.5.
Try running `bundle update listen`

If you are updating multiple gems in your Gemfile at once,
try passing them all to `bundle update`

#bundle update listenを実行した場合
You have requested:
  spring = 2.0.2

The bundle currently has spring locked at 2.1.0.
Try running `bundle update spring`

If you are updating multiple gems in your Gemfile at once,
try passing them all to `bundle update`

#bundle updateを実行した場合
Bundler could not find compatible versions for gem "bundler":
  In Gemfile:
    rails (= 5.0.3) was resolved to 5.0.3, which depends on
      bundler (< 2.0, >= 1.3.0)

  Current Bundler version:
    bundler (2.0.2)
This Gemfile requires a different version of Bundler.
Perhaps you need to update Bundler by running `gem install bundler`?

Could not find gem 'bundler (< 2.0, >= 1.3.0)', which is required by gem 'rails
(= 5.0.3)', in any of the sources.

Bundler could not find compatible versions for gem "listen":
  In Gemfile:
    listen (= 3.0.8)

    guard (= 2.13.0) was resolved to 2.13.0, which depends on
      listen (<= 4.0, >= 2.7)

    spring-watcher-listen (= 2.0.1) was resolved to 2.0.1, which depends on
      listen (< 4.0, >= 2.7)

Bundler could not find compatible versions for gem "spring":
  In Gemfile:
    spring (= 2.0.2)

    spring-watcher-listen (= 2.0.1) was resolved to 2.0.1, which depends on
      spring (< 3.0, >= 1.2)

該当のソースコード

source 'https://rubygems.org'

gem 'rails',        '5.0.3'
gem 'puma',         '3.9.1'
gem 'sass-rails',   '5.0.6'
gem 'uglifier',     '3.2.0'
gem 'coffee-rails', '4.2.2'
gem 'jquery-rails', '4.3.1'
gem 'turbolinks',   '5.0.1'
gem 'jbuilder',     '2.7.0'

group :development, :test do
  gem 'sqlite3', '1.3.13'
  gem 'byebug',  '9.0.6', platform: :mri
end

group :development do
  gem 'web-console',           '3.5.1'
  gem 'listen',                '3.0.8'
  gem 'spring',                '2.0.2'
  gem 'spring-watcher-listen', '2.0.1'
end

group :test do
  gem 'rails-controller-testing', '1.0.2'
  gem 'minitest-reporters',       '1.1.14'
  gem 'guard',                    '2.13.0'
  gem 'guard-minitest',           '2.4.4'
end

group :production do
  gem 'pg', '0.18.4'
end

試したこと

・エラーメッセージに表示された通りにListenやSpringのアップデートを試みたのですが、どうやら何度同じコマンドを入力しても、どちらもアップデートされないようです。

・Bundlerのバージョンを変更するためbundler uninstall -vを実行して、現在は2.0.2, 1.7.8がインストールされています。Gemlfile.lockのBUNDLE WITHにはバージョン2.0.2と記載されているのでそれに合わせているのですが、メッセージには私が理解する限りバージョンが2以上では高すぎると書かれているので困惑しています。

・元々のGemfileに記載されていた

<コメント>Windows環境ではtzinfo-dataというgemを含める必要があります
gem 'tzinfo-data', platforms: [:mingw, :mswin, :x64_mingw, :jruby]

という記述は削除しました。

補足情報(FW/ツールのバージョンなど)

ruby 2.5.3p105 (2018-10-18 revision 65156) [x86_64-darwin18]

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

checkベストアンサー

+1

メッセージには私が理解する限りバージョンが2以上では高すぎると書かれているので困惑しています。

残念ながらそのとおりで、Rails 5.0.3はBundler 1系列と組み合わせないと動きません。

Rails 5.0系列でも5.0.5以上であればBundler 2系列をサポートしているので、少しバージョンを上げてみるといいでしょう。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2019/07/09 10:31

    素早い回答ありがとうございます!

    かなり調べてもどのバージョンのRailsがどのバージョンのBundlerに対応しているかという情報は出てこなかったので大変参考になりました。

    Gemfileを書き換えながら、手動でGemを一つずつアップデートしていったところエラー無くBundle installを行うことができたので、チュートリアルを進めていこうと思います。本当にありがとうございました!

    キャンセル

  • 2019/07/09 10:34

    RubyGemsから見れば依存関係を確認することもできます。

    https://rubygems.org/gems/rails/versions/5.0.3

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 88.62%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る