質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

新規登録して質問してみよう
ただいま回答率
86.12%
CentOS

CentOSは、主にRed Hat Enterprise Linux(RHEL)をベースにした、フリーのソフトウェアオペレーティングシステムです。

解決済

CentOS6.5 Pacemaker+Corosync環境のクラスタ作成

isamua
isamua

総合スコア20

CentOS

CentOSは、主にRed Hat Enterprise Linux(RHEL)をベースにした、フリーのソフトウェアオペレーティングシステムです。

3回答

0グッド

0クリップ

2898閲覧

投稿2015/11/11 07:05

サーバ情報:CentOS6.5 64bit
インストールパッケージ:
ccs-0.16.2-81.el6.x86_64.rpm
clusterlib-3.0.12.1-73.el6.1.x86_64.rpm
compat-readline5-5.2-17.1.el6.x86_64.rpm
corosync-1.4.7-2.el6.x86_64.rpm
corosynclib-1.4.7-2.el6.x86_64.rpm
glib2-2.28.8-4.el6.x86_64.rpm
libibverbs-1.1.8-4.el6.x86_64.rpm
libqb-0.17.1-1.el6.x86_64.rpm
librdmacm-1.0.19.1-1.el6.x86_64.rpm
pacemaker-1.1.12-8.el6.x86_64.rpm
pacemaker-cli-1.1.12-8.el6.x86_64.rpm
pacemaker-cluster-libs-1.1.12-8.el6.x86_64.rpm
pacemaker-libs-1.1.12-8.el6.x86_64.rpm
pcs-0.9.139-9.el6_7.1.x86_64.rpm
perl-TimeDate-1.16-13.el6.noarch.rpm
python-clufter-0.11.2-1.el6.x86_64.rpm
rdma-6.7_3.15-5.el6.noarch.rpm
resource-agents-3.9.5-24.el6.x86_64.rpm
ruby-1.8.7.374-4.el6_6.x86_64.rpm
ruby-irb-1.8.7.374-4.el6_6.x86_64.rpm
ruby-libs-1.8.7.374-4.el6_6.x86_64.rpm
ruby-rdoc-1.8.7.374-4.el6_6.x86_64.rpm
rubygems-1.3.7-5.el6.noarch.rpm
構成:
ーーーーーーーーーーインターネットーーーーーーーーー
192.168.0.1 | 192.168.0.2
eth1 | eth1
APサーバ#1 | APサーバ#2
eth2 | eth3 | eth2 | eth3
192.168.1.1 | 192.168.2.1 | 192.168.1.2 | 192.168.2.2
|---------------ハートビート1-----------| |
|----------ハートビート2---------|

という構成なんですけど
ハートビートが動かなくて

crm_monを実行しても以下のような結果になるんです。
Last updated: Wed Nov 11 15:53:43 2015
Last change: Wed Nov 11 15:32:28 2015
Current DC: NONE
0 Nodes configured
0 Resources configured

設定の間違えと直し方を教えてほしいです。
あとちょっと特殊な環境でインストールするときはインターネットからとってくるのじゃなくてrpmを準備して入れなければならないんで追加のインストールがあるならそのイメージ名も教えてほしいです。

cat corosync.conf

Please read the corosync.conf.5 manual page

compatibility: whitetank

service {
name: pacemaker
ver: 0
use_mgmtd: yes
}
totem {
version: 2
secauth: off
threads: 0
interface {
broadcast: yes
ringnumber: 0
bindnetaddr: 192.168.1.0
mcastport: 5405
ttl: 1
}
transport: udpu
}
nodelist {
node {
ring0_addr: 192.168.1.1
nodeid: 1
}

node { ring0_addr: 192.168.1.2 nodeid: 2 }

}
logging {
fileline: off
to_stderr: no
to_logfile: yes
logfile: /var/log/cluster/corosync.log
to_syslog: yes
debug: off
timestamp: on
logger_subsys {
subsys: AMF
debug: off
}
}
amf {
mode: disabled
}

よろしくお願いします。

以下のような質問にはグッドを送りましょう

  • 質問内容が明確
  • 自分も答えを知りたい
  • 質問者以外のユーザにも役立つ

グッドが多くついた質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

気になる質問をクリップする

クリップした質問は、後からいつでもマイページで確認できます。

またクリップした質問に回答があった際、通知やメールを受け取ることができます。

下記のような質問は推奨されていません。

  • 間違っている
  • 質問になっていない投稿
  • スパムや攻撃的な表現を用いた投稿

適切な質問に修正を依頼しましょう。

回答3

0

あとpacemakerの起動でも失敗するんですが

投稿2015/11/12 02:18

isamua

総合スコア20

良いと思った回答にはグッドを送りましょう。
グッドが多くついた回答ほどページの上位に表示されるので、他の人が素晴らしい回答を見つけやすくなります。

下記のような回答は推奨されていません。

  • 間違っている回答
  • 質問の回答になっていない投稿
  • スパムや攻撃的な表現を用いた投稿

このような回答には修正を依頼しましょう。

0

ベストアンサー

broadcast: yestransport: udpu (ユニキャスト) が矛盾します。
broadcast: yes にするのであれば transport は設定しない。
transport: udpu にするのであれば broadcast を設定せず、member {} を設定追加する必要があります。

(設定例) totem { interface { member { memberaddr: 192.168.1.1 } member { memberaddr: 192.168.1.2 } ringnumber: 0 bindnetaddr: 192.168.1.0 mcastport: 5405 ttl: 1 transport: udpu } }

また、この pacemaker のバージョンだと service {} 箇所で ver: 1 にして、
corosync とは別に pacemaker を起動(service pacemaker start)するのではないでしょうか。

(設定例) service { name: pacemaker ver: 1 #use_mgmtd: yes }

crm_mon も pacemaker 起動後に見れるようになると思います。

ログ(/var/log/messages, /var/log/cluster/corosync.log)を見ると何かわかるかもしれません。

投稿2015/11/11 08:21

TaichiYanagiya

総合スコア11946

良いと思った回答にはグッドを送りましょう。
グッドが多くついた回答ほどページの上位に表示されるので、他の人が素晴らしい回答を見つけやすくなります。

下記のような回答は推奨されていません。

  • 間違っている回答
  • 質問の回答になっていない投稿
  • スパムや攻撃的な表現を用いた投稿

このような回答には修正を依頼しましょう。

回答へのコメント

isamua

2015/11/12 02:12

返信が遅くなり申し訳ありません。 ご指摘の箇所をtransport: udpuバージョンで直して、サービスの再起動をさせたのですが、起動に失敗してしまいます。
isamua

2015/11/12 07:12 編集

削除しました。
isamua

2015/11/12 02:21

transportに#をつけたら、ノードを認識しました。 ご指導ありがとうございます。

0

設定はさらっと見た感じ問題ないように見えますが、以下の指定

mcastport: 5405

上記のポートがiptables等で閉じられているということはないですか?
UDP/5405 が開放されているか確認してみては如何でしょう。

あと、SELinuxが邪魔しているということも考えられます。
無効にして切り分けしてみては如何でしょう。

投稿2015/11/11 07:18

over

総合スコア4302

良いと思った回答にはグッドを送りましょう。
グッドが多くついた回答ほどページの上位に表示されるので、他の人が素晴らしい回答を見つけやすくなります。

下記のような回答は推奨されていません。

  • 間違っている回答
  • 質問の回答になっていない投稿
  • スパムや攻撃的な表現を用いた投稿

このような回答には修正を依頼しましょう。

回答へのコメント

isamua

2015/11/11 07:42 編集

回答ありがとうございます。 iptablesは 3 180 ACCEPT all -- eth2 * 0.0.0.0/0 0.0.0.0/0 state NEW 0 0 ACCEPT all -- eth3 * 0.0.0.0/0 0.0.0.0/0 state NEW のようにnic単位であけています。 SELinuxはdisabledにしていて、原因がつかまないんです。 よろしくお願いします。
TaichiYanagiya

2015/11/11 08:23

"state NEW" は TCP ですか? UDP は許可されていますでしょうか。
isamua

2015/11/11 08:42

cat /etc/sysconfig/iptables # Generated by iptables-save v1.4.7 on Mon Nov 9 14:30:04 2015 *filter :INPUT ACCEPT [0:0] :FORWARD ACCEPT [0:0] :OUTPUT ACCEPT [14:3152] -A INPUT -m state --state RELATED,ESTABLISHED -j ACCEPT -A INPUT -p icmp -j ACCEPT -A INPUT -i lo -j ACCEPT -A INPUT -p tcp -m state --state NEW -m tcp --dport 20 -j ACCEPT -A INPUT -p tcp -m state --state NEW -m tcp --dport 21 -j ACCEPT -A INPUT -p tcp -m state --state NEW -m tcp --dport 22 -j ACCEPT -A INPUT -m state --state NEW -i eth2 -j ACCEPT -A OUTPUT -m state --state NEW -o eth2 -j ACCEPT -A INPUT -m state --state NEW -i eth3 -j ACCEPT -A OUTPUT -m state --state NEW -o eth3 -j ACCEPT -A INPUT -j REJECT --reject-with icmp-host-prohibited -A FORWARD -j REJECT --reject-with icmp-host-prohibited COMMIT # Completed on Mon Nov 9 14:30:04 2015 ですのでUDPの許可をしていると思っていますが、よろしいでしょうか?

15分調べてもわからないことは
teratailで質問しよう!

ただいまの回答率
86.12%

質問をまとめることで
思考を整理して素早く解決

テンプレート機能で
簡単に質問をまとめる

質問する

関連した質問

同じタグがついた質問を見る

CentOS

CentOSは、主にRed Hat Enterprise Linux(RHEL)をベースにした、フリーのソフトウェアオペレーティングシステムです。