質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

88.06%

Node.jsの環境構築、-bash: yum: command not foundでつまづいています

解決済

回答 2

投稿

  • 評価
  • クリップ 0
  • VIEW 1,747
退会済みユーザー

退会済みユーザー

いつもお世話になっています。初心者で話が通じなかったり、何言ってんだこいつと思うことがあるかもしれませんが、ご承知下さい。

急遽会社の方からNode.jsの環境構築をしてきてと言われたのですが、http://liginc.co.jp/web/programming/node-js/85318を見てやってきてと言われ早速つまずいています。

一番初めのnvmがインストールできず、
※Linuxなどを利用していてgitコマンドがインストールされてない(command not foundなどと表示される)場合は以下を実行してgitコマンドを利用できるようにしましょう。
$ yum -y install git

とやると、-bash: yum: command not foundと出てしまい次に進めません。
検索してみたのですが、検索力が足りず解決することができませんでした。

どうすればいいのか教えて欲しいです。また、最低これぐらい知ってろと思うことがあれば言ってください。

よろしくお願い致します。
  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 2

checkベストアンサー

0

公式 creationix/nvm の「Install script」にある

wget -qO- https://raw.githubusercontent.com/creationix/nvm/v0.29.0/install.sh | bash
source ~/.nvm/nvm.sh

nvm ls-remote
nvm install 4.2.2
nvm use 4.2.2

node -v
# v4.2.2
npm -v
# 2.14.7

で動作しませんか?OSXであれば、wgetではなくcurlが利用できます。

また、~/.bash_profileに下記のような設定が必要になるはずです。

source ~/.nvm/nvm.sh
nvm use 4.2.2

上記の動作を確認した環境はCentOS6.5です。

投稿

編集

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2015/11/08 13:10

    回答ありがとうございます。試してみます!

    キャンセル

  • 2015/11/08 13:39

    node.js無事インストールできました。ありがとうございます。

    キャンセル

0

まずOSとOSのバージョンを確認してください。

使っている環境が記事の前提と違っています。
yumはRedhat系のLinuxにはデフォルトで入っていますが、Debian系には入っていません。
もちろんMacとWindowsにも入っていません。
アプリケーションをインストールする場合、使っている環境に合った方法を探す必要があります。



追記です
MacであればHomebrewを使うといいかと思います。
Homebrewがインストールされていなければ
ruby -e "$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/master/install)"
Homebrewがインストールされていれば以下の手順でgitとnodeは使えるようになります。
brew install git
brew install nodebrew
nodebrew install-binary v4.2.2
nodebrew use v4.2.2

投稿

編集

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2015/11/08 11:18

    回答ありがとうございます。OS X Yosemiteでバージョンは10.10.1です。
    この記事以前の問題ということですね、、、

    キャンセル

  • 2015/11/08 13:10

    やってみます!ありがとうございます。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 88.06%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る