WordPressにて、このブロックでエラーが表示されたためプレビューできませんと表示される

解決済

回答 2

投稿

  • 評価
  • クリップ 0
  • VIEW 200

nakayama1820

score 18

失礼いたします

私、ワードプレスでブログを書いています

新しいエディタのGutenbergで書いていたですが、昨日、バージョン5.2.2–jaに更新したところ、新規投稿記事を書こうとすると、このブロックでエラーが表示されたためプレビューできません、と出るようになってしまいました

特に他に設定はいじっておらず、アップデートがきっかけかと思います

このような場合、どのようにして通常通りの投稿ができるようにこのエラーを消すことができますでしょうか

素人質問で恐縮です
なにか書き足りていないことなどあればご指摘いただければ書き加えます

ご教授いただけると嬉しいです

イメージ説明

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正、ベストアンサー選択の依頼

  • CHERRY

    2019/06/20 08:37

    Web サーバーのログに なにかメッセージは記録されていないでしょうか?

    キャンセル

回答 2

checkベストアンサー

0

ああ、これは、プラグインがブロックの使用を変えたのに
deprecatedの定義が十分じゃなかったってパターンじゃないかな

ブラウザのコンソール見たら
「saveではこんな出力を期待したのに、実際保存されてるコードはこんなのだったよ」
みたいなエラー出てないですか

多分コード編集モードは使えるはずです

コンソールのエラーメッセージでコードの差分を見て
直せそうならコード編集モードで直してみてください

直せなさそうならコード編集モードで
テキストデータとかだけとって作り直すぐらいですかね

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2019/06/24 18:33

    ご厚意ある回答ありがとうございます。

    確認して問題解決しました

    回答頂き、本当に感謝です

    ワードプレスの知識があまりないため、本当に助かりました

    ありかとうございつす

    キャンセル

0

WordPress 5.0.3-ja から 5.2.2-ja にアップデートした環境( TwentyNineteen テーマ + JetPack ) で新規投稿を作成して、いろいろなブロックを追加してみたり、順番を入れ替えてみたりして試してみましたが、質問に記載されている様な「エラーメッセージ」は再現しないようです。

お使いの環境やお使いのテーマ・プラグインが、影響している可能性がありそうです。


1.まず、お使いのプラグインをすべて無効にして試す。

⇒ エラーがなくなれば、無効にしたプラグインのどれかが影響している。
⇒ プラグインを1つずつ有効に戻しながら、エラーが出ないことを確認する。

エラーが発生したら、追加したプラグインに原因が有る可能性が高いので、プラグインの作者に問い合わせする。


2.プラグインをすべて無効にしてもエラーが出る場合は、プラグインを無効にしたままで、お使いのテーマを WordPress 標準テーマの Twenty Nineteen に変更してみる。

⇒ エラーがなくなれば、お使いのテーマが影響している。

⇒ お使いのテーマをカスタマイズして変更いるのであれば、カスタマイズの内容をバックアップした上で、テーマをダウンロードした(カスタマイズ前の)状態に戻してみる。

テーマの初期状態で、エラーが出ない場合は、カスタマイズ内容が影響しているので、カスタマイズ内容を1つずつ設定しながら動作確認をして、エラーが出ないか確認する。
⇒ カスタマイズ後にエラーが出た場合は、直前に変更した部分が原因の可能性が高いので、記載方法の間違い等を確認する。

カスタマイズ前の状態でもエラーが出る場合は、テーマの作成者に問い合わせることになると思います。


3.標準テーマでも エラーが出る場合は、アップデート後に発生したということですので、可能性は低いですが、アップデート中にファイルのコピーやアップデートに失敗した可能性が考えられます。

WordPress のアップグレード の「手動更新」を参考にして、sftp や ftp等で、WordPress の圧縮ファイルをダウンロードして展開(解凍)したファイルを WordPress に上書きしてアップデートしてみてください。(wp-config.php や wp-content のディレクトリやファイルを誤って削除しないように注意してください。)

投稿

編集

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2019/06/24 18:34

    丁寧に、細かいご回答ありがとうごさいます

    恐縮ながら他の方をベストアンサーとさせていただきましたが、そちら様のご助言も本当に参考になりました

    一通り、ご助言試させていただきました

    私のような素人には、とても参考になり、勉強にもなる助言でした

    心より御礼いたします

    ありがとうございました

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.22%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる