質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

89.22%

Cloud Functionsのデプロイでエラーが出ます

受付中

回答 2

投稿

  • 評価
  • クリップ 0
  • VIEW 1,406

Khy

score 70

決済にStripeを使おうと思っているのですが、Cloud Functionsをデプロイしようとすると以下のエラーが出ます。

Did you list all required modules in the package.json dependencies?
Detailed stack trace: Error: Cannot find module 'stripe'

index.jsとpackage.jsonは以下のようになっております。
原因がわかる方がおられましたらお教え頂きたいです。
よろしくお願い致します。

const functions = require('firebase-functions');
const admin = require('firebase-admin');
const CORS = require('cors');
const Stripe = require('stripe');

    const charge = (request, response) => {
      const body = JSON.parse(request.body);
      const token = body.token.id;
      const email = body.token.email;
      const amount = body.charge.amount;
      const currency = body.charge.currency;

      const stripe = Stripe(functions.config().stripe.token);
      stripe.charges
        .create({
          amount,
          currency,
          description: "",
          source: token,
          receipt_email: email
        })
        .then(charge => {
          send(response, 200, {
            message: "Success",
            charge
          });
        })
        .catch(error => {
          console.error(error);
          send(response, 500, {
            error: error.message
          });
        });
    };

    function send(response, statusCode, body) {
      response.send({
        statusCode,
        headers: { "Access-Control-Allow-Origin": "*" },
        body: JSON.stringify(body)
      });
    }

    exports.charge = functions.region('asia-northeast1').https.onRequest((request, response) => {
      const CORSRequestHandler = CORS({ origin: true });
      CORSRequestHandler(request, response, () => {
        if (request.method !== "POST") {
          send(response, 405, { error: "Invalid Request" });
        }
        try {
          charge(request, response);
        } catch (e) {
          console.log(e);
          send(response, 500, {
            error: `The server received an unexpected error. Please try again and contact the site admin if the error persists.`
          });
        }
      });
    });    
{
  "name": "APP_NAME",
  "version": "0.1.0",
  "private": true,
  "main": "index.js",
  "scripts": {
    "serve": "vue-cli-service serve",
    "build": "vue-cli-service build",
    "lint": "vue-cli-service lint"
  },
  "dependencies": {
    "@google-cloud/storage": "^2.5.0",
    "axios": "^0.19.0",
    "babel-polyfill": "^6.26.0",
    "cors": "^2.8.5",
    "css-scroll-snap-polyfill": "^0.1.2",
    "date-fns": "^1.30.1",
    "firebase": "^5.9.0",
    "firebase-admin": "^8.0.0",
    "firebase-functions": "^3.0.1",
    "http2": "^3.3.7",
    "ismobilejs": "^0.5.1",
    "jquery": "^3.4.0",
    "register-service-worker": "^1.6.2",
    "rx-js": "0.0.0",
    "stripe": "^7.1.0",
    "vue": "^2.6.6",
    "vue-router": "^3.0.1",
    "vue-rx": "^6.1.0",
    "vue-slick": "^1.1.15",
    "vue-smoothscroll": "^0.2.0",
    "vue-stripe-checkout": "^1.2.6",
    "vuejs-clipper": "^0.2.10",
    "vuetify": "^1.5.5",
    "vuex": "^3.0.1"
  },
  "devDependencies": {
    "@vue/cli-plugin-babel": "^3.5.0",
    "@vue/cli-plugin-eslint": "^3.5.0",
    "@vue/cli-plugin-pwa": "^3.5.0",
    "@vue/cli-service": "^3.7.0",
    "babel-eslint": "^10.0.1",
    "eslint": "^5.16.0",
    "eslint-plugin-vue": "^5.0.0",
    "node-sass": "^4.12.0",
    "sass-loader": "^7.1.0",
    "stylus": "^0.54.5",
    "stylus-loader": "^3.0.1",
    "vue-cli-plugin-vuetify": "^0.5.0",
    "vue-template-compiler": "^2.5.21",
    "vuetify-loader": "^1.0.5"
  }
}
  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 2

0

package.jsonは以下のようになっております。

それはFunctionsではなくVueアプリで使用しているpackage.jsonですよね?

Yesの前提ですが、基本的な手順でFunctionsをセットアップしているならindex.jsがあるディレクトリ(functions)に移動して、そこで当該パッケージをインストール(npm install stripe --save)する必要があります。

上記がもしNoならFunctionsに不要なパッケージ(vue, axios, jquery...)が多すぎるので、最初からセットアップ(firebase init functions)されることをおすすめします。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

0

他の方が仰っているように、Cloud Functions では使用しない Vue.jsのパッケージが package.json に入っているのはおかしいのではないかと思うので必要最低限にしたほうが良いかと思います。

ただ、上記のエラーの原因はインポート方法が間違っているのではないかと思います。
一度 npm の stripe 公式を見てみると良いかと思います。

https://www.npmjs.com/package/stripe

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 89.22%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる