質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

89.51%

CocoapadsでAlamore-SwiftyJSONでインストールができない。

受付中

回答 1

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 2,805

chris

score 11

CocoapodsでAlamore-SwiftJSONをインストールしましたが、バージョンの指定をどうすれば良いか分かりません。他のサイト等で調べましたが、できません。
pod installで以下のように表示されます。
Updating local specs repositories
Analyzing dependencies
Pre-downloading: `Alamofire-SwiftyJSON` from `https://github.com/SwiftyJSON/Alamofire-SwiftyJSON.git`
[!] Unable to satisfy the following requirements:

- `Alamofire` required by `Podfile`
- `Alamofire (= 1.3)` required by `Alamofire-SwiftyJSON (2.0.0-beta.1)`

Specs satisfying the `Alamofire` dependency were found, but they required a higher minimum deployment target.
Podfileは

source 'https://github.com/CocoaPods/Specs.git'
platform :ios, '9.1'
use_frameworks!


target 'サービス名' do


# Alamofire-SwiftyJSON
pod 'Alamofire-SwiftyJSON', :git => "https://github.com/SwiftyJSON/Alamofire-SwiftyJSON.git"

pod 'Alamofire'

pod 'SwiftyJSON'


end

target 'サービス名Tests' do

end

target 'サービス名UITests' do

end
と記述しております。

なぜ出来ないのか。どうすればライブラリーを取得できるのか、教えていただけないでしょうか?
もしくは、Alamorefire-SwiftyJSON以外を用いて、API等でデータベースへ接続する手法を教えてください。

Swift 勉強中で至らない部分があり、申し訳ありません。
  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

0

これはAlamofire-SwiftyJSONがAlamofireの古いバージョンである1.3に依存しているために出ているエラーのようです。

もともとAlamofire-SwiftyJSONは「Alamofireで取得したJSONをSwiftyJSONでSwiftで扱いやすくする」ためのものですが現在のAlamofire(3.0)では単体でJSONが扱いやすくなっている様です。

そのためかわかりませんが、Alamofire-SwiftyJSONの更新も9月で止まっています。
なのでAlamofireだけを使うのが今後はいいと思います。

Alamofireだけをpodで導入し、
pod 'Alamofire'

下記の様な感じで書けばAPIを叩いてJSONを取得することができます。
Alamofire.request(.GET, "http://httpbin.org/get", parameters: ["foo": "bar"])
         .responseJSON { response in
             print(response.request)  // original URL request
             print(response.response) // URL response
             print(response.data)     // server data
             print(response.result)   // result of response serialization

             if let JSON = response.result.value {
                 print("JSON: \(JSON)")
             }
         }

Alamofireの使い方は本家サイトをご覧ください。上記コードもそこからの引用です。
https://github.com/Alamofire/Alamofire

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2015/11/08 19:46

    ありがとうございます。やってみます。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 89.51%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる