質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

88.04%

Laravelでアプリ作成時にバージョンを指定するとエラーが出ます

解決済

回答 2

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 3,023

score 30

VirtualBoxで作った仮想マシンにVagrantで
CentOS 7.6で作った環境にlaravelでアプリを作りたいと思ってます
環境は
$ php -v
PHP 7.3.6

$ mysql --version
mysql  Ver 14.14 Distrib 5.7.26, for Linux (x86_64) using  EditLine wrapper

Apacheは2.4です

拡張モジュールは下記のものは入れてます
ctype
json
mbstring
openssl
PDO
tokenizer
xml

https://getcomposer.org/download/からインストールした
composer.pharを入れたディレクトリで下記のコマンドを使用すると
$ php composer.phar create-project --prefer-dist laravel/laravel blog
Laravel5.8のアプリを作ることはできますが

下記の様にバージョンを指定した場合は以下のエラーがおきます
$ composer create-project --prefer-dist laravel/laravel blog "5.5.*"

Installing laravel/laravel (v5.5.28)

Installing laravel/laravel (v5.5.28): Loading from cache
Created project in blog
@php -r "file_exists('.env') || copy('.env.example', '.env');"
Loading composer repositories with package information
Updating dependencies (including require-dev)
Package operations: 77 installs, 0 updates, 0 removals

Installing kylekatarnls/update-helper (1.1.1): Loading from cache
Plugin installation failed, rolling back
Removing kylekatarnls/update-helper (1.1.1)
[RuntimeException] Could not delete /vagrant/admin_app/blog/vendor/kylekatarnls/update-helper/ src/UpdateHelper:
create-project [-s|--stability STABILITY] [--prefer-source] [--prefer-dist] [--repository REPOSITORY] [--repository-url REPOSITORY-URL] [--dev] [--no-dev] [--no-custom-installers] [--no-scripts] [--no-progress] [--no-secure-http] [--keep-vcs] [--remove-vcs] [--no-install] [--ignore-platform-reqs] [--] [<package>] [<directory>] [<version>]

Laravel 5.5で開発する必要があるので困っています
どんな些細なことでもいいので解決に向けてご助言お願いいたします。

この質問を上げるのは2度目になります
新しいCentOS7で仮想環境を作り直し
$ composer create-project --prefer-dist laravel/laravel blog "5.5.*"
上記のコマンドでを実行したら問題なく実行されたので安心していたのですが
フォルダの構成を間違ったのでフォルダを削除するこにしました。
ついでにMySQLのバージョンを8にあげてから、rm -rf blogコマンドでフォルダ削除してから
$ composer create-project --prefer-dist laravel/laravel blog "5.5.*"
を実行するとまた
[RuntimeException] Could not delete /vagrant/admin_app/blog/vendor/kylekatarnls/update-helper/ src/UpdateHelper:
がでるようになったのです

以前の質問時も皆様にご助言いただきましたが根本的な解決にはいたりませんでした。
下記のurlが以前の質問です
https://teratail.com/questions/194252#reply-288435

これを乗り越えないと何度もエラーがでそうなのでご助言お願いいたします。
関係ないかもしれませんがVirtualBoxは最新版をインストールしています。

前回の質問でkgm様がご助言してくださった
途中でタイムアウトしてプロセスが残っているのでは?
もしそうならば、プロセスをkillしてタイムアウトを延ばせばいけるはずです。
export COMPOSER_PROCESS_TIMEOUT=600

という回答でkillせずにexport COMPOSER_PROCESS_TIMEOUT=600だけ
実行しました。
調べたのですが残っているプロセス探す方法がわかりません
コマンドと確認する項目等をご教示いただけないでしょうか?
$ ps auxというコマンドを実行したのですが沢山表示されますが
どれをkillして良いかわかりません。

追記
新環境を作成した場合、最初は
$ composer create-project --prefer-dist laravel/laravel blog "5.5.*"
に指定してLaravelアプリを開発できますが、一度PuTTyを抜けて
vagrant up等のコマンドで再度立ち上げた場合は
問題のエラーが表示されるようになります。

$ composer create-project --prefer-dist laravel/laravel blog "5.5.*"
を実行できた環境をvagrant boxでバックアップを作って
それをもとに作成した環境でも問題のエラーが表示されます。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正、ベストアンサー選択の依頼

  • m.ts10806

    2019/06/12 18:46

    エラーメッセージもコードと同じくマークダウンのcode機能を利用してご提示ください。

    キャンセル

回答 2

checkベストアンサー

0

Laravelで有名なytakeさんが開発しているCentOS版のLaravel用Vagrant環境のgardeningはどうですか
ytake/gardening HomesteadライクなCentOS
ytake/gardening

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2019/06/12 19:17

    是非導入したいと存じますが
    これはvagrant Boxは何を追加したら良いのでしょうか?

    キャンセル

  • 2019/06/12 19:20

    導入までのコマンドをご教示いただけたら幸いです。

    キャンセル

  • 2019/06/13 11:51 編集

    ytake/gardeningのGitHubのReadmeのInstall Gardening Boxの箇所を読んでみてください。
    コマンドが記載されています。
    自分でvagrantBoxを追加するというよりかは、Gardeningのツールが自動でインストールしてくれる形です。

    キャンセル

0

私も先ほど、全く同じエラーが発生しまして、なんとか解決できました。

私と環境が違うようですので、全く参考にならなかったら申し訳ないのですが、私がやった方法を念のため書かせて頂きます。

私は、Windows10の環境でHomesteadを使っていました。
環境構築は下記の記事を参考に行いました。
https://www.hypertextcandy.com/start-laravel-project-on-windows

ですが、honda_toruさんと全く同じ症状で、Laraveの5.8ですと成功するのですが、5.5のバージョン指定をすると、どうしても同じエラーが出て失敗していました。

そこで、既存の環境を消して構築しなおしまして、その際、git checkoutの部分を下記の公式ドキュメント(の日本語訳)の記述を参考に下記のように変更したところ、5.5でも正常に使えるようになりました。

git checkout v7.1.2
https://readouble.com/laravel/5.5/ja/homestead.html

ちなみに、5.8でも無事に成功しましたが、5.7でやってみると、同じエラーが発生しました。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 88.04%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る