質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.22%

Expoプロジェクトを起動すると /node_modules/expo/AppEntry.bundle がエラーになる

受付中

回答 0

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 323

kotatanaka

score 6

ReactNative + Expo + TypeScript のプロジェクトです。

expo start --ios コマンドで iOS シミュレータの Expo Client を起動させると、
コンソール上にエラーは出ないのですが、
シミュレータの画面上に下記のエラーが出てアプリケーションが起動できません。

Unhandled JS Exception: Unexpected token '{'. import call expects exactly one argument.
 (http://127.0.0.1:19001/node_modules/expo/AppEntry.bundle?platform=ios&dev=true&minify=false&hot=false&assetPlugin={プロジェクトのパス}%2Fnode_modules%2Fexpo%2Ftools%2FhashAssetFiles.js:1808)

JavaScript → TypeScript のコンバート作業の中で遭遇したエラーです(TypeScript のコンパイルは通っている)
キャッシュ削除や node_modules の入れ直しなどを行っても解決しないため、
他に試してみたらいいことなどございますでしょうか?

試したこと

$ npm cache verify
$ watchman watch-del-all
$ rm -rf /tmp/metro-bundler-cache-*
$ rm -rf /tmp/haste-map-react-native-packager-*
$ rm -rf node_modules && npm i
$ expo start -c

関連しそうなIssue

https://github.com/expo/expo/issues/2487
https://github.com/expo/expo-cli/issues/135
https://github.com/expo/expo/issues/872

環境

  • package.json
{
  "main": "node_modules/expo/AppEntry.js",
  "scripts": {
    "start": "expo start",
    "android": "expo start --android",
    "ios": "expo start --ios",
    "eject": "expo eject",
    "test": "node ./node_modules/jest/bin/jest.js --watchAll"
  },
  "jest": {
    "preset": "jest-expo"
  },
  "dependencies": {
    "@expo/samples": "2.1.1",
    "@types/expo": "^32.0.0",
    "@types/react": "^16.8.19",
    "@types/react-native": "^0.57.60",
    "@types/react-native-datepicker": "^1.7.0",
    "@types/react-native-vector-icons": "^6.4.0",
    "@types/react-navigation": "^3.0.7",
    "@types/react-navigation-material-bottom-tabs": "^0.3.1",
    "@types/react-redux": "^7.0.9",
    "axios": "^0.18.0",
    "dotenv": "^8.0.0",
    "expo": "^32.0.0",
    "firebase": "^6.0.3",
    "native-base": "^2.12.1",
    "react": "16.5.0",
    "react-native": "https://github.com/expo/react-native/archive/sdk-32.0.0.tar.gz",
    "react-native-datepicker": "^1.7.2",
    "react-native-elements": "^1.0.0",
    "react-native-material-ui": "^1.30.1",
    "react-native-typescript-transformer": "^1.2.12",
    "react-native-vector-icons": "^6.4.2",
    "react-navigation": "^3.0.9",
    "react-navigation-material-bottom-tabs": "^1.0.0",
    "react-navigation-redux-helpers": "^3.0.2",
    "react-navigation-tabs": "^0.8.4",
    "react-redux": "^5.0.7",
    "redux": "^4.0.0",
    "typescript": "^3.4.5"
  },
  "devDependencies": {
    "@babel/preset-typescript": "^7.3.3",
    "@typescript-eslint/eslint-plugin": "^1.9.0",
    "@typescript-eslint/parser": "^1.9.0",
    "babel-core": "^6.26.3",
    "babel-eslint": "^10.0.1",
    "babel-loader": "^8.0.6",
    "babel-preset-es2015": "^6.24.1",
    "babel-preset-expo": "^5.0.0",
    "babel-preset-react": "^6.24.1",
    "babel-preset-react-native": "^4.0.1",
    "babel-preset-typescript": "^7.0.0-alpha.19",
    "eslint": "^5.16.0",
    "eslint-config-airbnb": "^17.1.0",
    "eslint-config-prettier": "^4.3.0",
    "eslint-plugin-import": "^2.17.2",
    "eslint-plugin-jest": "^22.6.4",
    "eslint-plugin-jsx-a11y": "^6.2.1",
    "eslint-plugin-prettier": "^3.1.0",
    "eslint-plugin-react": "^7.13.0",
    "eslint-plugin-react-hooks": "^1.6.0",
    "husky": "^2.3.0",
    "jest-expo": "^33.0.0",
    "lint-staged": "^8.1.7",
    "prettier": "^1.17.1",
    "prettier-stylelint": "^0.4.2",
    "stylelint": "^10.0.1",
    "stylelint-config-prettier": "^5.2.0",
    "stylelint-config-standard": "^18.3.0",
    "stylelint-order": "^3.0.0",
    "ts-loader": "^6.0.2",
    "webpack": "^4.32.2",
    "webpack-cli": "^3.3.2",
    "webpack-dev-server": "^3.5.0"
  },
  "private": true,
  "name": "app"
}
  • ディレクトリ構成
project
├── App.tsx
├── README.md
├── __tests__
│   └── App-test.js
├── app.json
├── assets
│   ├── ...
├── constants
│   ├── ...
├── node_modules
│   ├── ...
├── package-lock.json
├── package.json
├── src
│   ├── ...
├── tsconfig.json
└── webpack.config.ts
  • npm バージョン:6.9.0
  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

まだ回答がついていません

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.22%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる