質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

88.78%

iphoneアプリをインストールできません

解決済

回答 2

投稿

  • 評価
  • クリップ 0
  • VIEW 719

rabupon

score 19

できないこと

Xcode10で社内用のアプリを作成しています。
サーバーにipaファイルを置き、インストールをするのですが、
一部の端末でインストールすることができません。

【インストールできた端末】
端末:iphone8        OS:ios12.2
端末:iphone5S      OS:iphone12.2
端末:iphone6sPlus   OS:ios12.3.1

【インストールできない端末】
端末:iphone6sPlus    OS:ios12.1.4
端末:iphone7           OS:ios12.1
端末:iphone7           OS:ios10.3

何が原因でしょうか?
iOSが原因ということがあるのでしょうか?
その場合、どのような対応をしたらよろしいのでしょうか?

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 2

checkベストアンサー

0

Xcodeで
Project>Info>Deploument Target の
iOS Deploument Target が 12.2.2になっているのが原因かと思われます。

iOS10.3で動かすには、この「iOS Deploument Target」を10.3以下に設定する必要があります。

別の方法としては、
「インストールできない端末」のiOSをすべて、12.2.2以上にアップデートすると、動くようになると思います。

iOSをアップデートするほうが簡単で安全ですね。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2019/06/03 09:30

    xcode10の「「iOS Deploument Target」が「12.2」でした。
    ここを「11.1」までしか下げられないのでその設定にし、再度ipaファイルを作成しなおしましたが
    iphone6sPlus OS:ios12.1.4で試したところ、
    現象は同じでインストールできませんでした・・・

    キャンセル

  • 2019/06/03 12:06

    すみません、11.1までしかというのは勘違いでした。
    8.0まで選択できました。ですが、エラーが出るのでとりあえず
    「11.0」に設定しました。
    その後、XcodeでTARGET>プロジェクト名>General>の「Deploument Target」も11.0に変更してipaファイルを作成しなおしたところ
    iphone6sPlus OS:ios12.1.4
    ではインストールができました。他の端末はこれから確認してみます。

    キャンセル

0

xcodeの「TARGETS」からプロジェクトを選択し「General」タブを選びます。「Identity」のなかにある「Version」がバージョン番号、「Build」がビルド番号がセットされていませんか?

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2019/06/03 09:33

    現在
    「Version」が1.0.2
    「Build」が1.0.2.1
    になっています。
    ちなみに、plistには
    <key>bundle-version</key>
    <string>1.0.2</string>
    でセットされています。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 88.78%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る