質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

88.04%

gitからダウンロードしたアプリを起動したい

受付中

回答 1

投稿

  • 評価
  • クリップ 2
  • VIEW 653

score 12

前提・実現したいこと

ここに質問の内容を詳しく書いてください。

ruby on rails で gitからダウンロードしたアプリを起動したいのですが、バージョン?が改善できずにいます。

gitからファイルをダウンロードしbundle installコマンド入力後、以下のエラーメッセージが発生しました。

**Could not find bootstrap-sass-3.2.0.2 in any of the sources

というエラーメッセージです。
**### 発生している問題・エラーメッセージ

Could not find bootstrap-sass-3.2.0.2 in any of the sources

### 該当のソースコード
 bundle install

ここに言語名を入力
ruby on rails
ソースコード

試したこと

ec2-user:~/environment $ cd ~/environment/tsubuyaki_22_nov-master/                                                                                                 
ec2-user:~/environment/tsubuyaki_22_nov-master $ rails s                                                                                                           
Could not find proper version of railties (4.1.8) in any of the sources
Run bundle install to install missing gems.
ec2-user:~/environment/tsubuyaki_22_nov-master $ bundle install
Fetching gem metadata from https://rubygems.org/.............
Could not find bootstrap-sass-3.2.0.2 in any of the sources

ec2-user:~/environment/tsubuyaki_22_nov-master $ bundle update
Fetching gem metadata from https://rubygems.org/.............
Fetching gem metadata from https://rubygems.org/.
Resolving dependencies...
Bundler could not find compatible versions for gem "railties":
In Gemfile:
haml-rails was resolved to 2.0.1, which depends on
railties (>= 5.1)

jquery-rails was resolved to 4.3.3, which depends on
railties (>= 4.2.0)

rails (~> 5.2.3) was resolved to 5.2.3, which depends on
railties (= 5.2.3)

sass-rails (~> 4.0.3) was resolved to 4.0.5, which depends on
railties (< 5.0, >= 4.0.0)
ec2-user:~/environment/tsubuyaki_22_nov-master $ bundle update rails bootstrap-sass
Fetching gem metadata from https://rubygems.org/.............
Fetching gem metadata from https://rubygems.org/.
Resolving dependencies...
Bundler could not find compatible versions for gem "railties":
In Gemfile:
haml-rails was resolved to 0.5.3, which depends on
railties (>= 4.0.1)

jquery-rails was resolved to 3.1.2, which depends on
railties (< 5.0, >= 3.0)

rails (~> 5.2.3) was resolved to 5.2.3, which depends on
railties (= 5.2.3)

sass-rails (~> 4.0.3) was resolved to 4.0.4, which depends on
railties (< 5.0, >= 4.0.0)

補足情報(FW/ツールのバージョンなど)

ここにより詳細な情報を記載してください。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正、ベストアンサー選択の依頼

  • gentaro

    2019/05/30 15:23

    gitはソースコードの管理ツールです。
    つまり、そのアプリの管理者がいるはずですので、そちらに質問されるのが筋ではないでしょうか。

    ご質問内容からは、世の中に無数に存在するアプリケーションのうち何について質問されているのかもわかりませんし、そのリポジトリがGitHub(gitとイコールではありません)等の公開リポジトリでなければ、そもそもアクセスすらできません。

    キャンセル

  • CHERRY

    2019/05/30 20:50

    エスパーしてみると https://github.com/daraf-jp/tsubuyaki_22_nov かなぁ?

    キャンセル

回答 1

0

現在使用しているRailsに合わせて作成し直すのが早いかと思います。

Ruby on Rails実践講座 - Twitterの簡易クローンを開発するにて、作り方が記載されているので、こちらのサイトを確認してみるといいかもしれません。

(こちらのサイトで実際に作成したものがそのリポジトリに載せられているものなので。)

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 88.04%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る