質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

88.21%

Debianにcurlがインストールできない

解決済

回答 2

投稿

  • 評価
  • クリップ 1
  • VIEW 3,161

ruei

score 281

Debianにcurlをインストールしたいのですが、エラーが発生しております。

Debianのバージョンは7.11です。

cat /etc/debian_version
7.11

curlをインストールしようとすると、次のようなエラーが発生します。

sudo apt-get install curl
パッケージリストを読み込んでいます... 完了
依存関係ツリーを作成しています
状態情報を読み取っています... 完了
以下のパッケージが新たにインストールされます:
  curl
アップグレード: 0 個、新規インストール: 1 個、削除: 0 個、保留: 0 個。
273 kB のアーカイブを取得する必要があります。
この操作後に追加で 376 kB のディスク容量が消費されます。
警告: 以下のパッケージは認証されていません!
  curl
検証なしにこれらのパッケージをインストールしますか [y/N]? y
エラー http://security.debian.org/ wheezy/updates/main curl amd64 7.26.0-1+wheezy25+deb7u1
  404  Not Found [IP: 151.101.72.204 80]
http://security.debian.org/pool/updates/main/c/curl/curl_7.26.0-1+wheezy25+deb7u1_amd64.deb の取得に失敗しました  404  Not Found [IP: 151.101.72.204 80]
E: いくつかのアーカイブを取得できません。apt-get update を実行するか --fix-missing オプションを付けて試してみてください。


apt-get updateを実行せよとあったので実行しました。以下がその時のログです。

sudo apt-get update
無視 http://http.us.debian.org wheezy-updates Release.gpg
無視 http://http.us.debian.org wheezy-updates Release
無視 http://security.debian.org wheezy/updates Release.gpg
無視 http://security.debian.org wheezy/updates Release
無視 http://security.debian.org wheezy/updates/main amd64 Packages/DiffIndex
無視 http://security.debian.org wheezy/updates/contrib amd64 Packages/DiffIndex
無視 http://security.debian.org wheezy/updates/non-free amd64 Packages/DiffIndex
エラー http://security.debian.org wheezy/updates/main amd64 Packages

エラー http://security.debian.org wheezy/updates/contrib amd64 Packages

エラー http://security.debian.org wheezy/updates/non-free amd64 Packages

エラー http://http.us.debian.org wheezy-updates/main amd64 Packages
  404  Not Found [IP: 64.50.233.100 80]
エラー http://http.us.debian.org wheezy-updates/contrib amd64 Packages
  404  Not Found [IP: 64.50.233.100 80]
エラー http://http.us.debian.org wheezy-updates/non-free amd64 Packages
  404  Not Found [IP: 64.50.233.100 80]
無視 http://http.us.debian.org wheezy-updates/contrib Translation-ja_JP
無視 http://http.us.debian.org wheezy-updates/contrib Translation-ja
無視 http://http.us.debian.org wheezy-updates/contrib Translation-en
無視 http://http.us.debian.org wheezy-updates/main Translation-ja_JP
無視 http://http.us.debian.org wheezy-updates/main Translation-ja
無視 http://http.us.debian.org wheezy-updates/main Translation-en
無視 http://http.us.debian.org wheezy-updates/non-free Translation-ja_JP
無視 http://http.us.debian.org wheezy-updates/non-free Translation-ja
無視 http://http.us.debian.org wheezy-updates/non-free Translation-en
エラー http://security.debian.org wheezy/updates/main amd64 Packages

エラー http://security.debian.org wheezy/updates/contrib amd64 Packages

エラー http://security.debian.org wheezy/updates/non-free amd64 Packages

エラー http://security.debian.org wheezy/updates/main amd64 Packages

エラー http://security.debian.org wheezy/updates/contrib amd64 Packages

エラー http://security.debian.org wheezy/updates/non-free amd64 Packages

エラー http://security.debian.org wheezy/updates/main amd64 Packages

エラー http://security.debian.org wheezy/updates/contrib amd64 Packages

エラー http://security.debian.org wheezy/updates/non-free amd64 Packages

無視 http://security.debian.org wheezy/updates/contrib Translation-ja_JP
無視 http://security.debian.org wheezy/updates/contrib Translation-ja
無視 http://security.debian.org wheezy/updates/contrib Translation-en
無視 http://security.debian.org wheezy/updates/main Translation-ja_JP
無視 http://security.debian.org wheezy/updates/main Translation-ja
無視 http://security.debian.org wheezy/updates/main Translation-en
無視 http://security.debian.org wheezy/updates/non-free Translation-ja_JP
無視 http://security.debian.org wheezy/updates/non-free Translation-ja
無視 http://security.debian.org wheezy/updates/non-free Translation-en
エラー http://security.debian.org wheezy/updates/main amd64 Packages
  404  Not Found [IP: 151.101.72.204 80]
エラー http://security.debian.org wheezy/updates/contrib amd64 Packages
  404  Not Found [IP: 151.101.72.204 80]
エラー http://security.debian.org wheezy/updates/non-free amd64 Packages
  404  Not Found [IP: 151.101.72.204 80]
W: http://http.us.debian.org/debian/dists/wheezy-updates/main/binary-amd64/Packages の取得に失敗しました  404  Not Found [IP: 64.50.233.100 80]

W: http://http.us.debian.org/debian/dists/wheezy-updates/contrib/binary-amd64/Packages の取得に失敗しました  404  Not Found [IP: 64.50.233.100 80]

W: http://http.us.debian.org/debian/dists/wheezy-updates/non-free/binary-amd64/Packages の取得に失敗しました  404  Not Found [IP: 64.50.233.100 80]

W: http://security.debian.org/dists/wheezy/updates/main/binary-amd64/Packages の取得に失敗しました  404  Not Found [IP: 151.101.72.204 80]

W: http://security.debian.org/dists/wheezy/updates/contrib/binary-amd64/Packages の取得に失敗しました  404  Not Found [IP: 151.101.72.204 80]

W: http://security.debian.org/dists/wheezy/updates/non-free/binary-amd64/Packages の取得に失敗しました  404  Not Found [IP: 151.101.72.204 80]

E: いくつかのインデックスファイルのダウンロードに失敗しました。これらは無視されるか、古いものが代わりに使われます。

この後、再度

sudo apt-get install curl

を行いましたが全く同じエラーが出てしまいました。
解決方法が分かる方いらっしゃったらご教示ください(Debianのバージョンが古いのですが、アップデートするのは難しいです)

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 2

checkベストアンサー

+1

古いサポート切れのOSは、ネットワークからのパッケージインストール、アップデートなどが出来ません。それがサポート切れと言うことです。
そのまま新しいバージョンのOSへの移行すら出来ないと思います。
新しいOSをインストールしましょう。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2019/05/26 20:34

    おっしゃる通り、新しいバージョンへのOSへの移行がそのままできません…。あきらめて新しいOSをインストールしてもらえるように管理者にもう一度お願いします...。

    キャンセル

+1

Debian7は2018年5月31日でサポートが終了したからでは?

サポートが終了したOS使用し続けるのはクラッカーから踏み台にされるのを防げません。他者に迷惑をかけるので至急、使用を止めるか、ネットワーク接続を止めてください。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2019/05/26 20:16

    サポートが終了したのは理解していて、管理者にアップグレードするようにお願いしています。
    現在の自分には権限がないので解決不能です。。。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 88.21%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る