質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

88.62%

Unity5.6.7f1にFireBaseSDKを導入するのは不可能でしょうか?

受付中

回答 0

投稿

  • 評価
  • クリップ 0
  • VIEW 560

yuya92

score 12

現在Unity5.6.7f1を使用して、運営しているタイトルにFireBaseSDKを導入したいと思っているのですが、エラーでビルドすることが出来なく困っております。

もし解決策をご存知の方がいらっしゃいましたら、ご教授お願い致します。

エラーその1

空のプロジェクトを作成し、Firebase公式サイトより必要なパッケージを導入し、ビルドを行うと下記のエラーが発生します。

CommandInvokationFailure: Unable to merge android manifests. See the Console for more details

CommandInvokationFailure: Unable to merge android manifests. See the Console for more details. 
C:\Program Files\Java\jdk1.8.0_171\bin\java.exe -Xmx2048M -Dcom.android.sdkmanager.toolsdir="C:/Users/ユーザー名/AppData/Local/Android/Sdk\tools" -Dfile.encoding=UTF8 -jar "C:\Program Files\Unity\5.6.7f1\Editor\Data\PlaybackEngines\AndroidPlayer/Tools\sdktools.jar" -

stderr[
Error: [Temp\StagingArea\AndroidManifest-main.xml:41, C:\プロジェクト名\Temp\StagingArea\android-libraries\com.google.android.gms.play-services-measurement-api-16.5.0\AndroidManifest.xml:10] Trying to merge incompatible /manifest/application/service[@name=com.google.firebase.components.ComponentDiscoveryService] element:
  <service
      @android:name="com.google.firebase.components.ComponentDiscoveryService">
          @android:name="com.google.firebase.components:com.google.firebase.analytics.connector.internal.AnalyticsConnectorRegistrar"
--    <meta-data
--        @android:name="com.google.firebase.components:com.google.firebase.iid.Registrar"
--        @android:value="com.google.firebase.components.ComponentRegistrar">
  <service
      @android:name="com.google.firebase.components.ComponentDiscoveryService">
          @android:name="com.google.firebase.components:com.google.firebase.analytics.connector.internal.AnalyticsConnectorRegistrar"
++</service>
++(end reached)
Error: [Temp\StagingArea\AndroidManifest-main.xml:41, C:\プロジェクト名\Temp\StagingArea\android-libraries\com.google.firebase.firebase-iid-18.0.0\AndroidManifest.xml:12] Trying to merge incompatible /manifest/application/service[@name=com.google.firebase.components.ComponentDiscoveryService] element:
  <service
      @android:name="com.google.firebase.components.ComponentDiscoveryService">
      <meta-data
--        @android:name="com.google.firebase.components:com.google.firebase.analytics.connector.internal.AnalyticsConnectorRegistrar"
  <service
      @android:name="com.google.firebase.components.ComponentDiscoveryService">
      <meta-data
++        @android:name="com.google.firebase.components:com.google.firebase.iid.Registrar"
]


どうやら調べたところ、このエラーはAndroidSDKを更新する必要があるとのことで、
【関連記事】
AndroidManifest merge fail. Please help! #192

AndroidSDKを25.2.5→26.1.1に更新すればうまくいくようでした。

エラーその2

先ほどの記事通り、AndroidSDKのバージョンを26.1.1にしたところ、現在の最新であるUnity2018.4.0f1では、ビルドが成功することは確認できました。

しかし、Unity5.6.7f1でビルドをしようとしたところ、今度は下記のエラーが発生してしまいました。

CommandInvokationFailure: Unable to list target platforms. Please make sure the android sdk path is correct. See the Console for more details. 


このエラーは逆に、AndroidSDKのバージョンをダウングレード(26.1.1→25.2.5)させないとダメのようでした。
【関連記事】
【Unity、Android】最新のAndroidStudio入れたらUnable to list target platforms.が出て困った
UnityでAndroidビルド時にエラーが発生します

解決方法はない…?

運用中のタイトルのバージョンを、すぐにUnity5.6.7f1→Unity2018.4.0f1にあげることは現実的に厳しいため、FirebaseSDKを導入することは不可能ということになりますでしょうか?

何か解決策等お持ちの方いらっしゃいましたら、宜しくお願い致します。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

まだ回答がついていません

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 88.62%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る