質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

88.06%

PHP mb_send_mail()のローカル環境でのメール送信について。

受付中

回答 3

投稿 編集

  • 評価
  • クリップ 2
  • VIEW 6,323

score 11

お世話になっております。

表題の通り、PHP mb_send_mail()のローカル環境でのメール送信についてお伺いしたいです。

現在、xampp ver7.3.4 を用いて、学習を行っているのですが、ローカル環境におけるメールの送信ができない状況にあります。

Gmailのサーバを用いて行おうとしているのですが、エラーログも出ず、問題なく送れているようなのですが、送信先のアドレスにメールが届かない状況にあります。

メール送信時にサーバと連携するため、多少のロード時間がかかるようですが、そのロード時間がなく、サーバと連携が取れていないのでは?と考えています。

しかし、対処法等が全く分からないため、皆様の知恵をお借りできればと思います。

ちなみにwindows10 ver1803です。

以下、行った設定の手順になります。
=================================================
1.xampp¥phpフォルダ内のphp.iniの内容変更
・SMTP=localhost
・smtp_port=25
・sendmail_path = "¥"C:¥xampp¥sendmail¥sendmail.exe¥" -t"
(sendmail.exeのある個所へのパスとなっています。)

2.xampp¥sendmailフォルダ内のsendmail.iniの内容変更
・smtp_server=smtp.gmail.com
・smtp_port=587
・auth_username=送信元@gmail.com (個人情報のため、伏せています)
・auth_password=送信元gmailアカウントのパス (個人情報のため、伏せています)
・force_sender=送信元@gmail.com (個人情報のため、伏せています)

3.gmail内の設定変更
・安全性の低いアプリのアクセス・・・有効化

4.メール送信の確認方法
・xampp¥htdocsフォルダ内にtest.phpの作成

【test.php】のコード

  <?php
      if(mb_send_mail("送信先@gmail.com", "test_sub", "test_body")){
          echo "送信成功";
      } else {
          echo "送信失敗";
      }
  ?>

5.ブラウザ上でlocalhost/test.phpを実行 → 送信成功と表記(送信先のアドレスでメール受信できず)
※この際にロード時間が全くないため、サーバに接続できていないのではないかと考えています。
=================================================
上記の作業を行いました。
xampp¥sendmailフォルダ内にerror.logは出ていません。

大変お手数ですが、ご教授願います。

なお、以下のサイトを参考しました。
=======================================
XAMPPのローカル環境からメールを送信できるように設定する方法【初心者向け】
XAMPP環境(ローカル環境)の sendmailからPHPメールを送信する設定方法
【PHP】ローカル環境からメールを送信する方法
XAMPP(Windows版)で、Gmail経由でローカル環境からメールを送信する
=======================================

追記です!
C:\xampp\apache\logs
上記のフォルダ内にエラーコードを発見しました。

[Thu May 23 16:49:18.018129 2019] [ssl:warn] [pid 12136:tid 592] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Thu May 23 16:49:18.054072 2019] [core:warn] [pid 12136:tid 592] AH00098: pid file C:/xampp/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
[Thu May 23 16:49:18.060056 2019] [ssl:warn] [pid 12136:tid 592] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
PHP Warning:  Module 'openssl' already loaded in Unknown on line 0
[Thu May 23 16:49:18.086945 2019] [mpm_winnt:notice] [pid 12136:tid 592] AH00455: Apache/2.4.39 (Win64) OpenSSL/1.1.1b PHP/7.3.4 configured -- resuming normal operations
[Thu May 23 16:49:18.086945 2019] [mpm_winnt:notice] [pid 12136:tid 592] AH00456: Apache Lounge VC15 Server built: Mar 28 2019 11:59:33
[Thu May 23 16:49:18.086945 2019] [core:notice] [pid 12136:tid 592] AH00094: Command line: 'c:\\xampp\\apache\\bin\\httpd.exe -d C:/xampp/apache'
[Thu May 23 16:49:18.094976 2019] [mpm_winnt:notice] [pid 12136:tid 592] AH00418: Parent: Created child process 12032
[Thu May 23 16:49:18.725239 2019] [ssl:warn] [pid 12032:tid 612] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Thu May 23 16:49:18.772112 2019] [ssl:warn] [pid 12032:tid 612] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
PHP Warning:  Module 'openssl' already loaded in Unknown on line 0
[Thu May 23 16:49:18.806021 2019] [mpm_winnt:notice] [pid 12032:tid 612] AH00354: Child: Starting 150 worker threads.
�t�@�C�����A�f�B���N�g�����A�܂��̓{�����[�� ���x���̍\�����Ԉ���Ă��܂��B

賢者の方々、ご確認していただいてもよろしいでしょうか。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正、ベストアンサー選択の依頼

  • m.ts10806

    2019/05/23 11:31

    質問は編集できますので質問本文にマークダウンのlink機能利用してリンクとしてご提示ください。
    またコードはcode機能を利用してください。
    https://teratail.com/help#about-markdown

    キャンセル

  • m.ts10806

    2019/05/23 11:45

    えっと。参考サイトも本文に追記お願いします。

    キャンセル

  • teruru.b

    2019/05/23 11:56

    失礼いたしました。
    よろしくお願いいたします。

    キャンセル

回答 3

+1

C:\xampp\sendmail\sendmail.iniにある

;debug_logfile=debug.log

のコメントアウトを外してログ出力できるようにして、
再度テストして、
debug.logの内容を質問文中に追記してください。

話はそれから。

--

debug.log が生成されないということは、
sendmail.exeが呼ばれて、もしくは動作できていないことになります。

このsendmailは正しくはfake sendmailというもので
Windows 8以上の環境で動かすときはWindows XP SP3互換モードで動かす必要があると書いてあります。
sendmail.exeでプロパティを開いて、互換モードで動かす設定を与えてから試してください。

うちWindows 7だけど、こういうことなのかも:
イメージ説明

--

Windows 10での成功事例、探しました:
Xampp windows10 PHP sendmail 設定 (gmailを使う) - Logicky BLOG
XAMPPのFake Sendmail を使用したPHPのSendmail 送信テストの方法

additional_headersにFromとReturn-Pathを与える、なんて記述もありますが、
そもそもdebug.logが呼ばれてないことがひっかかる・・・。

--
phpでopensslが使えるようになってない、から?
phpinfo()でopensslが有効になっているかどうか確認してみてほしい。
だとしたら
XAMPP for WindowsでSSLを有効にする - Qiita
にあるような手順でopensslが使えるように改善するのはどうだろう?

投稿

編集

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2019/05/23 14:10

    参考までに
    当方の環境はWin10 Proですが互換モード関連は触らなくても問題なく動きました。

    キャンセル

  • 2019/05/23 16:53

    お手数おかけしてしまい、申し訳ございません。
    動作の確認ありがとうございます。

    apacheのlog内にエラーコードと思われるものを見つけたのですが、確認していただけますでしょうか。
    たびたびすいません。。。

    キャンセル

  • 2019/05/23 17:30

    opensslの項目は、enabled(有効)と記載されていました。。。

    キャンセル

+1

pearのMail派なのでsend_mailは使ったことありませんでしたが
参考URLを元に構築して実験してみました。
問題なくメールの受信を確認できました。

一つ気になったのが

1.xampp¥phpフォルダ内のphp.iniの内容変更

この部分ですが、もしかしてSMTPとsmtp_portのコメントアウトまで外してませんか?
参考URLの一つ目はpathを通すためにsendmailのpathはコメントアウトを外せしか書いてませんが
2つ目のURLにご丁寧に

4行目の「;SMTP=localhost」、6行目の「;smtp_port=25」がコメントアウトされていることを確認し

と書いてあります。(私も同じようにコメントアウトしたままです)
書き方的にここも外しちゃっててmb_send_mailは呼べてて処理は通ってるから送信成功だけどmb_send_mail内で
設定の影響でメールを送信できてない(送信したつもりになってる)からログにも残らないんじゃないかと・・・

■php.ini内のSMTP、smtp_portのコメントアウトも外して実験してみました。

特に問題無く受信できていて、どうやら上記回答が原因ではないみたいです。
お力になれず申し訳ありません。
ただ、出力されるファイルは
error.logではなく
debug.logです 質問の追記に書いてあるファイル名ではないのでご注意。(回答にも書いていただいてますが)

投稿

編集

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2019/05/23 17:27

    exeが動いてないという観点から考えてみました。
    xamppフォルダの中に「mailoutput」ってフォルダがあると思うのですが
    もしかしてその中に今日日付(テストした日付)のファイルとか生成されてませんか?

    キャンセル

  • 2019/05/23 17:29

    空でした。。。

    キャンセル

  • 2019/05/23 17:56

    入れなおしたら動いたという事例もあるみたいです。
    最終手段ではありますが
    どうしてもとなったらやってみてください

    http://web-designer-mitainahito.com/xampp-sendmail/

    キャンセル

0

私も質問者様と全く同じ現象でずっと苦しんでましたが
ようやく解決しました。

結局のところ、php.ini内の
sendmail_path = "\"C:\xampp\sendmail\sendmail.exe\" -t"
の.exeの後のバックスラッシュが抜けてたパス間違い(脱字)が原因でした。

違ってたら大変申し訳ないのですが、質問者様のsendmail_pathコード内で誤字や脱字
は無いでしょうか?
例えば、\部分を半角バックスラッシュでなく環境依存の本当の半角の円マークを使ってたり、Cや:や"が半角でなく
全角だったり、どこかに全角のスペースが入ってたり・・等

ディレクトリの在り処が表記場所と根本的に違う場所にある事は流石にないと思われますが
全く同じような現象だったもので、sendmail_pathとの兼ね合いに原因があるように思われましたので
口を出してしまいましたm(_ _ )m

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 88.06%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る