質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.45%

  • Python 3.x

    10337questions

    Python 3はPythonプログラミング言語の最新バージョンであり、2008年12月3日にリリースされました。

python シュミレーション 環境設定で困っています

解決済

回答 3

投稿 編集

  • 評価
  • クリップ 1
  • VIEW 266

NR4200

score 1

前提・実現したいこと

pythonでシュミレーションをするためにpybulletをインストールして環境設定を行っています.
以下のコードを実行すると

===============================================
pythonが動作を停止しました
問題が発生したため,プログラムが正しく動作しなくなりました.プログラムは閉じられ,解決策がある場合はwindowsから通知されます
======================================--
とウィドウが表示されます

発生している問題・エラーメッセージ

pybullet build time: May 22 2019 08:37:07
starting thread 0
started testThreads thread 0 with threadHandle 000000000000021C
argc=2
argv[0] = --unused
argv[1] = --start_demo_name=Physics Server
ExampleBrowserThreadFunc started
Version = 1.1.0
Vendor = Microsoft Corporation
Renderer = GDI Generic
とコマンドプロンプトに表示されてから上述した「pythonが動作を停止しました」のウインドウが出ます

該当のソースコード

import pybullet as p
physicsClient = p.connect(p.GUI)

試したこと

画面に表示できない問題なので,PyQt5を追加でインストールしましたがエラー内容は変わりませんでした.
他にGUI関係のTkinterなども調べましたが,めぼしいものはありませんでした.

visualstudioをアンインストールしてもう一度インストールした.
visualstudio 2017をインストールしたものではちゃんと動くのですが
visualstudio 2019をインストールしたものでは動きません

===============================================
pythonが動作を停止しました
問題が発生したため,プログラムが正しく動作しなくなりました.プログラムは閉じられ,解決策がある場合はwindowsから通知されます
======================================--
が表示されてからデバックをクリックをクリックすると
イメージ説明
visual studioが起動し上記のような画像が出てきました

イメージ説明
図2

イメージ説明

図3

イメージ説明
図4
イメージ説明
図5
イメージ説明
図6

補足情報(FW/ツールのバージョンなど)

環境
windows10
anaconda3
python3.6.8
visualstudio2019

インストールリスト
Package              Version    
-------------------- ---------- 
absl-py              0.7.1
astor                0.8.0
baselines            0.1.5
certifi              2019.3.9
chardet              3.0.4
Click                7.0
cloudpickle          1.1.1
control              0.8.2
cycler               0.10.0
deap                 1.2.2
dill                 0.2.9
future               0.17.1
gast                 0.2.2
grpcio               1.20.1
gym                  0.12.1
h5py                 2.9.0
idna                 2.8
joblib               0.13.2
Keras                2.2.4
Keras-Applications   1.0.7
Keras-Preprocessing  1.0.9
kiwisolver           1.1.0
Markdown             3.1.1
matplotlib           3.1.0
mock                 3.0.5
mpi4py               3.0.1
numpy                1.16.2+mkl
Pillow               6.0.0
pip                  19.1.1
progressbar2         3.39.3
protobuf             3.7.1
pybullet             2.5.0
pyglet               1.3.2
pyparsing            2.4.0
PyQt5                5.12.2
PyQt5-sip            4.19.17
python-dateutil      2.8.0
python-utils         2.3.0
PyYAML               5.1
pyzmq                18.0.1
requests             2.22.0
scipy                1.3.0
setuptools           41.0.1
sip                  4.19.8
six                  1.12.0
slycot               0.3.3
tensorboard          1.13.1
tensorflow           1.13.1
tensorflow-estimator 1.13.0
termcolor            1.1.0
tqdm                 4.32.1
urllib3              1.25.2
Werkzeug             0.15.4
wheel                0.33.4
wincertstore         0.2
zmq                  0.0.0

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正、ベストアンサー選択の依頼

  • NR4200

    2019/06/03 14:38

    上のものがコマンドプロンプトに表示されるだけでエラー内容は表示されません

    キャンセル

  • NR4200

    2019/06/03 14:44

    実行すると図2が表示され,デバックをクリックすると最初の図のようにvisualstudioが起動します.

    キャンセル

  • NR4200

    2019/06/06 08:47

    anacondaのほうとpython.orgの両方から実行しましたが両方とも同じでした.

    キャンセル

回答 3

check解決した方法

0

グラボを入れ替えることによって動作しました.

回答してくださった皆さんありがとうございました.
特にYasuhiroNijiさんには何度も回答してくださり本当に助かりました.
この場をお借り致しまして,お礼申し上げます.

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

0

画像を見る限り、VisualStudio側の問題かと思います。VSのオプションからデバッギングを許可して下さい...みたいに書いてありますが、そちらはご確認いただけていますか?つまり、

Tools/Options/Debugging/Just-in-Time

上記の設定をenableにするとよいのではないかと思います。なお、私自身はVSCodeは一ミリも触ったことないので悪しからず...

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2019/06/03 12:37

    Just-in-Timeをenableにしましたがエラー内容は変わりません

    キャンセル

  • 2019/06/03 12:48

    visualstudioをもう一度インストールし直したら上記のようなものがでたので質問を修正しました.
    質問が分かりにくいとは思いますがよろしくお願いします.

    キャンセル

0

エラーメッセージの以下のことから、ディスプレイドライバーに Microsoft の GDI Generic 1.1.0 が使われていることがわかります。しかし、PyBullet は、OpenGL 2 又は OpenGL 3 が必要になりますが、GDI Generic では対応していません。

Version = 1.1.0
Vendor = Microsoft Corporation
Renderer = GDI Generic

使用している PC の GPU のメーカーから、ディスプレイドライバーをダウンロードしてインストールする必要があると思われます。INTEL CPU 内蔵のものを使っている場合は、以下のページを参考にしてください。
インテル® グラフィックス・ドライバー

投稿

編集

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2019/06/04 12:50

    anacondaをアンインストールしてPython.orgからpythonをインストールし直しましたが,何も変わりません.現状,YasuhiroNijiさんとの違いは分かっている範囲でvisual studioが2019か2017だけです.visual studioの問題でしょうか?
    python
    インストールパッケイジ
    control 0.8.2
    cycler 0.10.0
    kiwisolver 1.1.0
    matplotlib 3.1.0
    numpy 1.16.2+mkl
    pip 19.0.3
    pybullet 2.5.0
    pyparsing 2.4.0
    python-dateutil 2.8.0
    scipy 1.3.0
    setuptools 40.8.0
    six 1.12.0
    slycot 0.3.3

    キャンセル

  • 2019/06/04 20:33 編集

    python.orgのpython3.7.2は、MSC v.1916(Visual Studio 2017 version 15.9) でコンパイルされているのでコンパイラーは合わせておいた方がいいです。特にVisual Studio 2019 は公開されたばかりなので対応できていない可能性があります。

    質問の中で、「visualstudio 2017をインストールしたものではちゃんと動くのですが、visualstudio 2019をインストールしたものでは動きません 」と書いてあるのをみるとvisualstudio 2019がエラーの原因と考えるのが妥当なのではないでしょうか。

    キャンセル

  • 2019/06/04 23:40 編集

    Anaconda の方でも動作しました。ライブラリーの依存は、OpenGL 2 又は OpenGL 3 だけなので、あまり影響はないようです。

    参考までに、自分の場合の表示される内容を以下に書いておきます。

    pybullet build time: Jun 4 2019 22:56:00
    starting thread 0
    started testThreads thread 0 with threadHandle 00000000000002D8
    argc=2
    argv[0] = --unused
    argv[1] = --start_demo_name=Physics Server
    ExampleBrowserThreadFunc started
    Version = 4.5.0 - Build 25.20.100.6323
    Vendor = Intel
    Renderer = Intel(R) HD Graphics 630
    b3Printf: Selected demo: Physics Server
    starting thread 0
    started MotionThreads thread 0 with threadHandle 00000000000004B0
    MotionThreadFunc thread started

    キャンセル

  • 2019/06/06 08:44

    visual studio2019をアンインストールしてvisual studio2017をインストールしましたがvisualstudio2019をインストールしていた時と何も変わりません.

    キャンセル

  • 2019/06/06 12:18

    visualstudioの設定に何か問題があるのでしょうか?

    キャンセル

  • 2019/06/06 12:54 編集

    今気がついたのですが、PyBullet は、OpenGL 2 又は OpenGL 3 のドライバーが必要になります。ログを見ると、Microsoft Generic GDI 1.1 が使われているため、OpenGL 2 に対応していません。使用しているGPU のメーカーから、OpenGL 2 又は OpenGL 3 に対応したドライバーをダウンロードしてインストールする必要があるのではないでしょうか。自分の場合は、CPU内蔵を使っているので Intel になっています。

    キャンセル

  • 2019/06/07 09:21

    GPUを調べたらIntel(R) HD Graphics 3000なのでopenGL3.1らしいのですがMicrosoft Generic GDI 1.1から使うのを変えることは可能なのでしょうか?
    visualstudio2017を最初からインストールしているものでpybulletが動いたものでは何も変えていないので変え方がわかりません.
    調べてみても変更方法は見つからないのですが...

    キャンセル

  • 2019/06/07 09:32

    インテル® ドライバー & サポート・アシスタントをインストールするのが簡単です。
    https://www.intel.co.jp/content/www/jp/ja/support/products/80939/graphics-drivers.html

    キャンセル

  • 2019/06/07 10:07

    ながながと質問してすいません.
    インストールしたのですが全く変わりません.
    コマンドプロンプトに表示される内容も同じです.
    以下表示内容
    pybullet build time: May 21 2019 08:35:20
    starting thread 0
    started testThreads thread 0 with threadHandle 0000000000000250
    argc=2
    argv[0] = --unused
    argv[1] = --start_demo_name=Physics Server
    ExampleBrowserThreadFunc started
    Version = 1.1.0
    Vendor = Microsoft Corporation
    Renderer = GDI Generic

    キャンセル

  • 2019/06/07 11:17

    デバイスマネージャーを立ち上げて「ディスプレイ アダプター」がどうなっているか確認してみてください。もし、Intel(R) HD Graphics がインストールされていなければ、その方法をしらべればいいし、もし、GDI Generic と両方がインストールされていれば、GDI Generic の方をアンインストールすればいいと思います。

    キャンセル

  • 2019/06/07 12:25

    ディスプレイ アダプター(上図4)でIntel(R) HD Graphics 3000しか入っていないはずなのですが,実行しても何も変わりません

    キャンセル

  • 2019/06/07 13:54

    Intel(R) HD Graphics 3000 のプロパティを表示して、ドライバーのプロバイダーが Intel Corporation になっているか確認してみてください。

    キャンセル

  • 2019/06/10 08:20

    YasuhiroNijiさんへ
    返答が遅れてしまって申し訳ありません.
    プロパイダーを確認しました.
    図6に示すようにドライバーのプロバイダーがIntel Corporationになっています.

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.45%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

同じタグがついた質問を見る

  • Python 3.x

    10337questions

    Python 3はPythonプログラミング言語の最新バージョンであり、2008年12月3日にリリースされました。