remi-php56 の php のバージョンが 5.3.3 と表示されてしまう

解決済

回答 2

投稿

  • 評価
  • クリップ 0
  • VIEW 2,023

fitz

score 41

phpのv5.6.15をインストールしたいのですが、v5.3.3になってしまいます。。

$ rpm -U http://dl.fedoraproject.org/pub/epel/6/x86_64/epel-release-6-8.noarch.rpm
$ rpm -U http://rpms.famillecollet.com/enterprise/remi-release-6.rpm
$ yum list --enablerepo=remi-php56 | grep ^php\.x86_64
php.x86_64                                5.3.3-46.el6_6              updates

リポジトリの設定でバージョン変更したいのです。

環境は、CentOS release 6.7 (Final)です。
よろしくお願い致します。
  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 2

check解決した方法

0

すみません、自己解決しました。。
他のリポジトリが邪魔してたんですね。。

$ yum list --enablerepo=remi-php56 --disablerepo=base,updates | grep ^php\.x86_64
php.x86_64                                 5.6.15-1.el6.remi          remi-php56

投稿

編集

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2015/10/30 21:29

    プライオリティの設定がされていたんでしょう。

    キャンセル

  • 2015/10/30 21:39

    コメントありがとうございます。
    プライオリティが設定されていました。

    キャンセル

0

$ yum list --enablerepo=remi-php56 | grep ^php\.x86_64

$ yum list --enablerepo=remi-php56 | grep ^php56\.x86_64

でないと、検索されないと思います。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2015/10/30 21:09

    ご回答ありがとうございます。
    php56は見つかりませんでした。
    php56-phpはいるのですが、インストールすると、php56になるので、
    もっとスマートな方法がないものかと思い、質問させていただきました。
    $ yum list --enablerepo=remi | grep ^php56-php\.x86_64

    キャンセル

  • 2015/10/30 21:20

    いったい何をしたいのですか?

    php56 をインストールしたいのではないんですか?

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.22%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる