質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

88.80%

linuxサーバでのsshによるtensorflow GPU環境の構築

解決済

回答 1

投稿 編集

  • 評価
  • クリップ 2
  • VIEW 593

nouken

score 349

共用linux gpuサーバにおいてdeep learningをするために環境を構築中です。
手元のwindowsからsshで操作しています。

tensorflow-gpuのrequirementはこちらなのですが、linux環境のCUDAとcuDNNのバージョンは

(venv) [######### practice]$ nvcc --version
nvcc: NVIDIA (R) Cuda compiler driver
Copyright (c) 2005-2016 NVIDIA Corporation
Built on Tue_Jan_10_13:22:03_CST_2017
Cuda compilation tools, release 8.0, V8.0.61
(venv) [######### practice]$ find / -name libcudnn* 2>/dev/null
/opt/cuda/lib64/libcudnn.so.7
/opt/cuda/lib64/libcudnn.so.7.0.5
/opt/cuda/lib64/libcudnn_static.a
/opt/cuda/lib64/libcudnn.so


となっており、tensorflow-gpuのどのバージョンともマッチしません。

root権限がないので新しいバージョンのインストールが出来ません。

この場合どのようにして環境を構築していけばよいのかと悩んでおります。

手元のwindowsデスクトップでインストールし、linuxサーバの自分のhomeディレクトリ下に転送すればよいのかな、と思いましたが、ほかに良い手がありましたら伺いたいです。よろしくお願いいたします。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

checkベストアンサー

0

root権限がないので新しいバージョンのインストールが出来ません。
この場合どのようにして環境を構築していけばよいのかと悩んでおります。

ライブラリのバージョンが合わないだけなら、LD_LIBRARY_PATHなどを使って、/home以下に展開したライブラリを利用させることはできます。
http://tetsuyai.hatenablog.com/entry/20111201/1324792477

ただ、ハードウェア・ドライバのバージョンに関してはユーザの権限ではどうしようもないので、その場合は共用サーバのGPUは使えないと思います。(この辺は一般論としてですが)

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2019/05/20 20:10

    ハードウェア、ドライバの面では要件をクリアしてるので、バージョンだけが問題です。ご紹介あったような方法で試してみたいと思います。ありがとうございました。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 88.80%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る