質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.21%

CUDA cudnn インストール

受付中

回答 1

投稿

  • 評価
  • クリップ 0
  • VIEW 1,454

前提・実現したいこと

CUDAとcudnnをインストールして使いたいようにしたい。
chainerとcupyを使用したい。

はじめanacondaを使用して、tensorflowとkerasをが使えるようにしました。その段階でCUDAとcudnnが入っていました。
しかし、chainer環境をanacondaだと構築できないようなので、
https://docs.nvidia.com/deeplearning/sdk/cudnn-install/index.htmlにそって、手で入れることにしました。
その結果CUDA 10.1を入れたはずなのにnvcc -Vしたら 9が出てきます。(これはanacondaで入れたもののように思います)

anaconda環境から出ても、anacondaで入れたものが有効になるのでしょうか?
前のものをアンインストールして、新しいものにしたいと思うのですが、アンインストールできません。

またsudo apt-get install でCUDAを入れる方法、anacondaで入れる方法、nvidiaの手順、どれで入れるのが一番かんたんですか。
■■な機能を実装中に以下のエラーメッセージが発生しました。

発生している問題・エラーメッセージ

sudo apt autoremove
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
cuda-libraries-dev-10-1 : Depends: libcublas-dev (>= 10.2.0.168) but it is not installed
cuda-samples-10-1 : Depends: libcublas-dev (>= 10.2.0.168) but it is not installed
cuda-visual-tools-10-1 : Depends: libcublas-dev (>= 10.2.0.168) but it is not installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

該当のソースコード

補足情報(FW/ツールのバージョンなど

os Ubuntu

alps@Alps:~$ uname -r
4.18.0-20-generic

(base) alps@Alps:~$ cat /proc/driver/nvidia/version
NVRM version: NVIDIA UNIX x86_64 Kernel Module  430.14  Wed May  8 01:10:53 UTC 2019
GCC version:  gcc version 7.3.0 (Ubuntu 7.3.0-27ubuntu1~18.04) 

alps@Alps:~$ nvcc -V
nvcc: NVIDIA (R) Cuda compiler driver
Copyright (c) 2005-2017 NVIDIA Corporation
Built on Fri_Nov__3_21:07:56_CDT_2017
Cuda compilation tools, release 9.1, V9.1.85

alps@Alps:~$ sudo dpkg --audit
The following packages have been unpacked but not yet configured.
They must be configured using dpkg --configure or the configure
menu option in dselect for them to work:
cuda                 CUDA meta-package
cuda-10-1            CUDA 10.1 meta-package
cuda-documentation-10-1 CUDA documentation
cuda-libraries-dev-10-1 CUDA Libraries 10.1 development meta-package
cuda-samples-10-1    CUDA example applications
cuda-toolkit-10-1    CUDA Toolkit 10.1 meta-package
cuda-tools-10-1      CUDA Tools meta-package
cuda-visual-tools-10-1 CUDA visual tools

(base) alps@Alps:~$ sudo apt --fix-broken install
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
linux-headers-4.18.0-16 linux-headers-4.18.0-16-generic linux-image-4.18.0-16-generic linux-modules-4.18.0-16-generic
linux-modules-extra-4.18.0-16-generic
Use 'sudo apt autoremove' to remove them.
The following additional packages will be installed:
libcublas-dev
The following NEW packages will be installed:
libcublas-dev
0 upgraded, 1 newly installed, 0 to remove and 159 not upgraded.
8 not fully installed or removed.
Need to get 0 B/39.1 MB of archives.
After this operation, 112 MB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 file:/var/cuda-repo-10-1-local-10.1.168-418.67  libcublas-dev 10.2.0.168-1 [39.1 MB]
(Reading database ... 246256 files and directories currently installed.)
Preparing to unpack .../libcublas-dev_10.2.0.168-1_amd64.deb ...
Unpacking libcublas-dev (10.2.0.168-1) ...
dpkg: error processing archive /var/cuda-repo-10-1-local-10.1.168-418.67/./libcublas-dev_10.2.0.168-1_amd64.deb (--unpack):
trying to overwrite '/usr/lib/x86_64-linux-gnu/libcublas_static.a', which is also in package nvidia-cuda-dev 9.1.85-3ubuntu1
dpkg-deb: error: paste subprocess was killed by signal (Broken pipe)
Errors were encountered while processing:
/var/cuda-repo-10-1-local-10.1.168-418.67/./libcublas-dev_10.2.0.168-1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

0

解決方法ではないのですが、念の為。

tensorflow(-gpu)は、CUDAバージョンを選びますよね。なので、CUDAは最新版ではなく、10.0(tensorflow-gpu 1.13なら)がいいと思いますよ。

https://www.tensorflow.org/install/source#tested_build_configurations

Chainerがうまく動いたとしても、tensorflow-gpuが使えなくなると思います。

ちなみに、私は10.1を入れて同じような問題に遭遇したんですが、手で(≠apt remove)CUDA関連と思われるファイルを削除した後、10.0をインストールしました。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.21%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

同じタグがついた質問を見る