質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.02%

php-gdのインストールについて

解決済

回答 1

投稿

  • 評価
  • クリップ 1
  • VIEW 2,092

S.T

score 76

お世話になります。

phpで画像処理を行うのに、GDをインストールしようとしているのですがうまくインストールできないため質問させていただきました。

おおまかな流れとしましては、以下のサイトを参考に、php5.6をインストールしました。
http://qiita.com/pakiln/items/645e8a97cde46b59f9f8
その語、gdを入れようとしたのですがうまくいかず、他サイトでgd-lastから入れると良い。といった記事をみたので
試してみましたが、「Requires: libtiff.so.3()(64bit)」ということでエラーになっている状況です。
また、サーバーはaws EC2を利用していて、イメージはlinux64を使っています。

どうぞよろしくお願いしますm(_ _)m



# yum install --enablerepo=remi --enablerepo=remi-php56 php-gd
Loaded plugins: priorities, update-motd, upgrade-helper
Resolving Dependencies
--> Running transaction check
---> Package php-gd.x86_64 0:5.6.15-1.el6.remi will be installed
--> Processing Dependency: gd-last(x86-64) >= 2.1.1 for package: php-gd-5.6.15-1.el6.remi.x86_64
--> Processing Dependency: libgd.so.3()(64bit) for package: php-gd-5.6.15-1.el6.remi.x86_64
--> Running transaction check
---> Package gd-last.x86_64 0:2.1.1-2.el6.remi will be installed
--> Processing Dependency: libtiff.so.3()(64bit) for package: gd-last-2.1.1-2.el6.remi.x86_64
--> Finished Dependency Resolution
Error: Package: gd-last-2.1.1-2.el6.remi.x86_64 (remi)
           Requires: libtiff.so.3()(64bit)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
 
 
# yum install --enablerepo=remi --enablerepo=remi-php56 gd-last
Loaded plugins: priorities, update-motd, upgrade-helper
Resolving Dependencies
--> Running transaction check
---> Package gd-last.x86_64 0:2.1.1-2.el6.remi will be installed
--> Processing Dependency: libtiff.so.3()(64bit) for package: gd-last-2.1.1-2.el6.remi.x86_64
--> Finished Dependency Resolution
Error: Package: gd-last-2.1.1-2.el6.remi.x86_64 (remi)
           Requires: libtiff.so.3()(64bit)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

checkベストアンサー

+1

Error: Package: gd-last-2.1.1-2.el6.remi.x86_64 (remi)
          Requires: libtiff.so.3()(64bit)

gd-last-2.1.1-2.el6.remi.x86_64 を入れるためには、libtiff.so.3()(64bit) が必須です。

「libtiff.so.3 rpm」でパッケージ名を検索

libtiff.so.3 rpm

yum install libtiff




投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2015/10/30 14:49

    rpmでlibtiff.so.3をインストールしたら無事解決しました!
    的確なご回答ありがとうございますm(_ _)m

    キャンセル

  • 2016/06/06 21:03

    私も同じ状況で、php-gdがインストールできずに困っています。
    エラーも全く同じものが出ています。

    >rpmでlibtiff.so.3をインストールしたら無事解決しました!

    と言う事ですが、具体的にはどういうコマンドでインストール出来たのか教えて頂けませんか?

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.02%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

同じタグがついた質問を見る