質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

88.80%

XAMPPでphpMyAdminからローカルDBに接続したい

解決済

回答 1

投稿 編集

  • 評価
  • クリップ 2
  • VIEW 1,639

nagisinobi

score 11

前提・実現したいこと

XAMPPでphpMyAdminからローカルのDBに接続したいです。

ローカル環境でMySqlのDBを構築したく、XAMPPをインストールいたしました。
XAMPP自体の起動は問題なく、ApacheとMySqlの文字の背景も緑になっております。

https://www.adminweb.jp/xampp/mysql/index2.html
こちらのサイトを参考に、まずはrootユーザーのパスワードを設定しようと思いました。

mysqladmin -u root password

こちらのコマンドを叩くとエラーが返ってきます。

発生している問題・エラーメッセージ

mysqladmin: connect to server at 'localhost' failed
error: 'Authentication plugin 'caching_sha2_password' cannot be loaded: '


caching_sha2_passwordの認証だと入れないよ、的な意味だと解釈しました。
調べると、my.iniの[mysqld]の項目にデフォルトの認証プラグインを指定してあげれば良いという記事を見つけたので、

XAMPPのMySqlのConfigボタンからmy.iniを開き、[mysqld]の項目を編集しました。(1行目)

# The MySQL server
[mysqld]
default_authentication_plugin=mysql_native_password
port= 3308
socket = "C:/xampp/mysql/mysql.sock"
basedir = "C:/xampp/mysql" 
tmpdir = "C:/xampp/tmp" 
datadir = "C:/xampp/mysql/data"
pid_file = "mysql.pid"
# enable-named-pipe
key_buffer = 16M
max_allowed_packet = 1M
sort_buffer_size = 512K
net_buffer_length = 8K
read_buffer_size = 256K
read_rnd_buffer_size = 512K
myisam_sort_buffer_size = 8M
log_error = "mysql_error.log"


※default_authentication_plugin=mysql_native_password が追記したものになります。

それでもう一度、mysqladmin -u root password こちらのコマンドを叩いてみましたが、
エラーメッセージは変わりませんでした。

どういった切り口でこちらの問題を解消すればよいでしょうか。

試したこと

・編集後、MySqlの再起動(Stopを押してもう一度Start)
・XAMPPの再インストール

補足情報(FW/ツールのバージョンなど)

XAMPP 7.3.5
各種コマンドは
C:\xampp\mysql\binで行っております。

Apacheのポートを初期の80から8080に変えております。

Listen 8080

また、

mysql -u root -h 127.0.0.1 --port 3308


こちらのコマンドで、Mysqlに接続ができました。

SELECT user, host, plugin FROM mysql.user;
を叩くと結果は以下になりました。

MariaDB [(none)]> SELECT user, host, plugin FROM mysql.user;
+------+-----------+-----------------------+
| user | host      | plugin                |
+------+-----------+-----------------------+
| root | localhost | mysql_native_password |
| root | 127.0.0.1 | mysql_native_password |
| root | ::1       | mysql_native_password |
|      | localhost | mysql_native_password |
| pma  | localhost | mysql_native_password |
+------+-----------+-----------------------+

画面キャプチャです。
![イメージ説明](e97d103c5850aebaa2b35de2aade6f84.png)

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正、ベストアンサー選択の依頼

  • m.ts10806

    2019/05/17 20:49

    いえMySQLのポートです。デフォルト3307から変更されているので、MySQLへの接続時には全て設定したポートを指定する必要があります。

    キャンセル

  • nagisinobi

    2019/05/17 21:05

    Mysqlのポートは3308に変えておりましたので、
    http://localhost:3308/phpmyadmin/index.php
    にアクセスするというアドバイスだと理解しました。

    ただ、これだと今度はPhpMyAdminのログイン画面さえも表示されなくなりました。

    キャンセル

  • m.ts10806

    2019/05/18 05:16

    いやhttpにポートつけるとそれはApacheのポートですよ

    キャンセル

回答 1

checkベストアンサー

+1

ApacheもMySQLも何でもそうですが、何も指定しない場合にデフォルトで使用するポートが決まっていて、
そのポートを設定した場合、それぞれ再起動することと、その後、接続の際に設定したポートを利用して
接続する記述をする必要があります。
コメントで書きましたようにhttp://example.com:ポート番号とつけるとそれはApacheのポートを指定することになります。
MySQLはあくまでDBで、PHPなどから利用する場合はPHPコードの接続設定にポートを使用するように記述しなければなりません。
phpMyAdminもPHPで記述されたMySQLにアクセスしてデータを操作するためのツールなので、同様に対処する必要があります。

検索のキーワードとしては「phpMyAdmin ポート変更」とかですかね。

ただ、XAMPPで入れられたようなので、コントロールパネルからも設定は変更できます。
こちらのほうがもしかしたら確実かもしれません。

XAMPP Control Panel
→[Config]
→Configuration of Control Panel
→[Service and Port Settings]
→[MySQL]タブ

※ここでもし変更したポートがすでに入っていればやはりphpMyAdminのコードに追記する必要があるということになりますが

投稿

編集

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2019/05/18 14:30

    ご回答有り難うございます。
    頂いておりました設定類は全て、すでに変更済みでした。

    結局、phpMyAdminでは接続できないということで諦めることにいたしました。

    他にローカルMySQLに接続できるツールでMySQLWorkbenchがありますので、
    そちらの方で無事、XAMPPで立てたMySqlに接続できたので、そちらを使うことにします。

    エラー文的には文字コードの設定あたりがおかしいので、
    今度時間ができたら、utf8mb4とPHPの関連、
    ※Server sent charset (255)と言っているので。。

    my.iniの設定箇所、読み込みされているファイルはなにかといった切り口で調べてみようと思います。


    お付き合いいただきありがとうございました。

    キャンセル

  • 2019/05/18 18:53

    変更済みでも通ってるかどうかは確認してもらいたかったし、
    そもそもデフォルトのポートに戻した場合とかも確認してもらいたかったですけど。。。
    MacなのでMAMPにした場合はどうかとか、
    まあ、解決と判断されたことができたならそれで良いですね。
    解決されたようで何よりです

    キャンセル

  • 2019/05/22 12:19

    `Server sent charset (255) unknown to the client.` と言ってるので、MySQLとPHPのMySQL拡張がバージョンが違うことで、MySQLが喋ってる文字コードをPHPが知らないが故にエラーになっているような気がします。
    バージョンを合わせてやったり、古いバージョンでも認識できる文字コードで喋ってやれば解決するかもしれません。

    #質問者さんは既にその点はお気付きのようなので野暮でしたかね…

    キャンセル

  • 2019/05/22 12:21

    確かにその部分もありそうですね。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 88.80%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る