SpringBootで作成したJarファイルをVPS上で実行してアクセスしたい

解決済

回答 2

投稿

  • 評価
  • クリップ 0
  • VIEW 354

takahiro00

score 33

前提・実現したいこと

SpringBootで簡単なプログラム(HellorWorldがブラウザに表示される)を作成し、Jarファイルを作成して、
JarファイルをVPS上にアップして「http://IPアドレス:8080」でページにアクセスしてHelloWolrdを表示させたいのですが、
「http://IPアドレス:8080」にアクセスすると「このサイトにアクセスできません」とブラウザに表示されてアクセスできません。

VPSはさくらVPSを使用していて、
以下コマンドでjavaのインストール

sudo yum -y install java-1.8.0-openjdk java-1.8.0-openjdk-devel


以下コマンドでポート8080の解放をしています。

sudo firewall-cmd  --permanent --add-port=8080/tcp


サーバーの/home/userにjarファイルをアップして、以下コマンドでSpringBootを起動しています。

cd /home/user
java -jar hello-0.0.1-SNAPSHOT.jar


SpringBootは正常に起動しているのですが、ブラウザでアクセスができません。
(上記は全てrootユーザで実行しています。)
apache、tomcatはVPSにはインストールしていませんがそれが原因でしょうか...
jarファイルはローカルでは実行できることを確認しています。
ご教授お願いいたします。

補足情報(FW/ツールのバージョンなど)

サーバー:CentOS
SpringBoot 2.0

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正、ベストアンサー選択の依頼

  • asahina1979

    2019/05/16 22:45

    getenforce (ぼそっ)

    キャンセル

  • takahiro00

    2019/05/16 22:48

    コマンド打ってみたら「Disabled」でした。問題ないってことですよね?

    キャンセル

  • asahina1979

    2019/05/17 00:39 編集

    あとはちゃんと設定を確定させた?(firewallね)

    キャンセル

  • takahiro00

    2019/05/18 00:58

    できました!apacheをインストールしてfirewallの設定したらできました!ありがとうございます!

    キャンセル

回答 2

+1

CentOS であれば、sudo firewall-cmd  --permanent --add-port=8080/tcp と、 --permanent オプションを指定されているので、この段階では公開設定が反映されていません(オプションがなければ即時反映できます)。

sudo firewall-cmd --reload を実行し、接続できるかどうか試されてはいかがでしょう。

投稿

さくらインターネット コミュニティ、Developer Advocate
  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2019/05/18 00:11

    ご回答ありがとうございます。
    まだ公開するための設定が必要ということでしょうか。

    sudo firewall-cmd --reload
    上記コマンド打ったところ、successでした。
    接続はできるということですよね

    キャンセル

check解決した方法

0

apacheをインストールして、firewallの設定をしたら出来ました。
apacheインストール

yum install httpd


firewalにhttpの穴を開ける

firewall-cmd --add-service=http --zone=public --permanent¥


apache起動

systemctl restart firewalld

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.22%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる