質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

88.77%

Kotlin Firebase 依存関係のコンフリクト

受付中

回答 0

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 739

rikutennis

score 51

The library com.google.android.gms:play-services-basement is being requested by various other libraries at [[15.0.1,15.0.1]], but resolves to 16.1.0. Disable the plugin and check your dependencies tree using ./gradlew :app:dependencies.

というようなエラーが出ます。

implementation 'com.google.firebase:firebase-core:16.0.1'
implementation 'com.google.firebase:firebase-auth:16.2.1'
classpath 'com.google.gms:google-services:4.0.1'


の3つが関係していると考えていて解決方法を知りたいです。
参考にしたサイト:oogle Play servicesとFirebaseの依存コンフリクト解決 - Qiita

以下はターミナルで
./gradlew :app:dependencies と打ち込んだ結果です
何かのヒントになれば幸いです

+--- com.google.firebase:firebase-core:16.0.1
|    +--- com.google.firebase:firebase-analytics:16.0.1
|    |    +--- com.google.android.gms:play-services-basement:15.0.1 -> 16.1.0
|    |    |    \--- com.android.support:support-v4:26.1.0
|    |    |         +--- com.android.support:support-compat:26.1.0 -> 28.0.0 (*)
|    |    |         +--- com.android.support:support-media-compat:26.1.0
|    |    |         |    +--- com.android.support:support-annotations:26.1.0 -> 28.0.0
|    |    |         |    \--- com.android.support:support-compat:26.1.0 -> 28.0.0 (*)
|    |    |         +--- com.android.support:support-core-utils:26.1.0 -> 28.0.0 (*)
|    |    |         +--- com.android.support:support-core-ui:26.1.0 -> 28.0.0 (*)
|    |    |         \--- com.android.support:support-fragment:26.1.0 -> 28.0.0 (*)
|    |    +--- com.google.android.gms:play-services-measurement-base:[16.0.0] -> 16.0.0
|    |    +--- com.google.android.gms:play-services-stats:15.0.1
|    |    |    \--- com.google.android.gms:play-services-basement:[15.0.1] -> 16.1.0 (*)
|    |    +--- com.google.firebase:firebase-analytics-impl:[16.1.1] -> 16.1.1
|    |    |    +--- com.google.android.gms:play-services-ads-identifier:15.0.1
|    |    |    |    \--- com.google.android.gms:play-services-basement:[15.0.1,16.0.0) -> 16.1.0 (*)
|    |    |    +--- com.google.android.gms:play-services-basement:15.0.1 -> 16.1.0 (*)
|    |    |    +--- com.google.android.gms:play-services-measurement-base:[16.0.0] -> 16.0.0
|    |    |    +--- com.google.android.gms:play-services-stats:15.0.1 (*)
|    |    |    +--- com.google.android.gms:play-services-tasks:15.0.1 -> 16.0.1
|    |    |    |    \--- com.google.android.gms:play-services-basement:16.0.1 -> 16.1.0 (*)
|    |    |    +--- com.google.firebase:firebase-common:16.0.0 -> 16.0.3
|    |    |    |    +--- com.google.android.gms:play-services-basement:16.0.1 -> 16.1.0 (*)
|    |    |    |    \--- com.google.android.gms:play-services-tasks:16.0.1 (*)
|    |    |    \--- com.google.firebase:firebase-iid:16.0.0
|    |    |         +--- com.google.android.gms:play-services-basement:15.0.1 -> 16.1.0 (*)
|    |    |         +--- com.google.android.gms:play-services-stats:15.0.1 (*)
|    |    |         +--- com.google.android.gms:play-services-tasks:15.0.1 -> 16.0.1 (*)
|    |    |         +--- com.google.firebase:firebase-common:16.0.0 -> 16.0.3 (*)
|    |    |         \--- com.google.firebase:firebase-iid-interop:16.0.0
|    |    |              +--- com.google.android.gms:play-services-base:15.0.1 -> 16.0.1
|    |    |              |    +--- com.google.android.gms:play-services-basement:16.0.1 -> 16.1.0 (*)
|    |    |              |    \--- com.google.android.gms:play-services-tasks:16.0.1 (*)
|    |    |              \--- com.google.android.gms:play-services-basement:15.0.1 -> 16.1.0 (*)
|    |    \--- com.google.firebase:firebase-common:16.0.0 -> 16.0.3 (*)
|    \--- com.google.firebase:firebase-measurement-connector-impl:16.0.1
|         +--- com.google.android.gms:play-services-basement:15.0.1 -> 16.1.0 (*)
|         +--- com.google.android.gms:play-services-measurement-base:[16.0.0] -> 16.0.0
|         +--- com.google.firebase:firebase-analytics:[16.0.1] -> 16.0.1 (*)
|         +--- com.google.firebase:firebase-analytics-impl:[16.1.1] -> 16.1.1 (*)
|         +--- com.google.firebase:firebase-common:16.0.0 -> 16.0.3 (*)
|         \--- com.google.firebase:firebase-measurement-connector:16.0.0
|              \--- com.google.android.gms:play-services-basement:15.0.1 -> 16.1.0 (*)
+--- com.google.firebase:firebase-auth:16.2.1
|    +--- com.google.android.gms:play-services-base:16.0.1 (*)
|    +--- com.google.android.gms:play-services-basement:16.1.0 (*)
|    +--- com.google.android.gms:play-services-flags:16.0.1
|    |    +--- com.google.android.gms:play-services-base:16.0.1 (*)
|    |    \--- com.google.android.gms:play-services-basement:16.0.1 -> 16.1.0 (*)
|    +--- com.google.android.gms:play-services-tasks:16.0.1 (*)
|    +--- com.google.firebase:firebase-auth-interop:16.0.1
|    |    +--- com.google.android.gms:play-services-base:16.0.1 (*)
|    |    +--- com.google.android.gms:play-services-basement:16.0.1 -> 16.1.0 (*)
|    |    +--- com.google.android.gms:play-services-tasks:16.0.1 (*)
|    |    \--- com.google.firebase:firebase-common:16.0.3 (*)
|    \--- com.google.firebase:firebase-common:16.0.3 (*)

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正の依頼

  • Orlofsky

    2019/05/14 13:52

    URLは https://teratail.com/help#about-markdown の [リンク] に修正してください。

    キャンセル

まだ回答がついていません

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 88.77%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る