質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

88.77%

PHPでRatchetがインストールできない

解決済

回答 1

投稿

  • 評価
  • クリップ 0
  • VIEW 586

msssss

score 49

composerでratchetをインストールしようとして
cmdで
composer require cboden/ratchetを入力すると

You are running Composer with SSL/TLS protection disabled.

[Composer\Downloader\TransportException]
Your configuration does not allow connections to http://repo.packagist.org/
packages.json. See https://getcomposer.org/doc/06-config.md#secure-http for
details.

require [--dev] [--prefer-source] [--prefer-dist] [--no-progress] [--no-suggest]
[--no-update] [--no-scripts] [--update-no-dev] [--update-with-dependencies] [--
update-with-all-dependencies] [--ignore-platform-reqs] [--prefer-stable] [--pref
er-lowest] [--sort-packages] [-o|--optimize-autoloader] [-a|--classmap-authorita
tive] [--apcu-autoloader] [--] [<packages>]...

このようなエラーが出てうまくインストールできません
composer.jsonに
"config": {        "secure-http": false   },
を追加したのですが、これでもうまくいきません
インストールするにはどのようにすれば良いですか?

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

checkベストアンサー

0

を追加したのですが、これでもうまくいきません

うまくいかない状況が記述されていませんが、エラーメッセージが変わらないということであれば、composer.json の記述位置が間違っているか、ファイル名が正しく記述できていないかのいずれかです。

エラーが変化しているのであれば、記述して下さい。
マークダウンが適切でないので、シンタックスが適切なのか確認できませんが、,がおかしい気がします。

以下グローバルに設定する方法をリンクしておきます。
composer の 「secure-http false」(global 対応)

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2019/05/12 21:06

    You are running Composer with SSL/TLS protection disabled.
    Warning: Accessing repo.packagist.org over http which is an insecure protocol.
    Using version ^0.4.1 for cboden/ratchet
    ./composer.json has been created
    Loading composer repositories with package information
    Warning: Accessing repo.packagist.org over http which is an insecure protocol.
    Updating dependencies (including require-dev)
    Package operations: 16 installs, 0 updates, 0 removals
    - Installing symfony/routing (v4.2.8): Failed to download symfony/routing
    from dist: You must enable the openssl extension to download files via https
    Now trying to download from source
    - Installing symfony/routing (v4.2.8): Cloning f4e43bb0df

    Installation failed, deleting ./composer.json.


    [RuntimeException]
    Failed to clone https://github.com/symfony/routing.git, git was not found,
    check that it is installed and in your PATH env.

    'git' is not recognized as an internal or external command,
    operable program or batch file.

    にエラーが変更されました。
    この段階からどうすれば良いですか?

    キャンセル

  • 2019/05/12 21:15

    記述してあるエラーを読めば、次にすべきことはわかるかと。

    キャンセル

  • 2019/05/12 22:26

    gitをダウンロードしなければならないのですか?

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 88.77%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る