質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.13%

Unity2019.1.0f2 Androidビルド

受付中

回答 1

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 697

suika-pickle

score 7

前提・実現したいこと

UnityでAndroidのビルドをしたいです

発生している問題・エラーメッセージ

Required API Level 26.
というポップメッセージが出てきて、Use Highest Installedを選択すると
Requested minimum AndroidSDK Platform not Installed
というポップメッセージとともに以下のエラーが出てビルドが成功しません

エラーメッセージ


UnityException: Requested minimum Android SDK Platform not installed
Build set to use Minimum SDK of AndroidApiLevel26 but the latest installed SDK on the system is 0.

Please use the Android SDK Manager to install the minimum required SDK version.
UnityEngine.GUIUtility:ProcessEvent(Int32, IntPtr)
、、、、、、、、、、、、、、、、、、、、、、、、、、、、、、、、、、、、、、、
Build completed with a result of 'Failed'
UnityEngine.GUIUtility:ProcessEvent(Int32, IntPtr)
、、、、、、、、、、、、、、、、、、、、、、、、、、、、、、、、、、、、、、、
UnityEditor.BuildPlayerWindow+BuildMethodException: 2 errors

at UnityEditor.BuildPlayerWindow+DefaultBuildMethods.BuildPlayer (UnityEditor.BuildPlayerOptions options) [0x00242] in C:\buildslave\unity\build\Editor\Mono\BuildPlayerWindowBuildMethods.cs:194 

at UnityEditor.BuildPlayerWindow.CallBuildMethods (System.Boolean askForBuildLocation, UnityEditor.BuildOptions defaultBuildOptions) [0x0007f] in C:\buildslave\unity\build\Editor\Mono\BuildPlayerWindowBuildMethods.cs:97 
UnityEngine.GUIUtility:ProcessEvent(Int32, IntPtr)

試したこと

SDKフォルダの内部を古いデータと交換したり一度すべて削除してAndroidStudioからインストールし直したりしました。
フォルダのパスも変更してみましたが無駄でした。

補足情報(FW/ツールのバージョンなど)

minimum Api LvelはAndorid8.0'Oreo'(Api Level 26)です

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

0

どのUnityのバージョンを使われているのか分かりませんが、最新のバージョンでは、Unity Hubで本体をインストールする際に、AndroidのSDKをインストールするかどうかの選択肢が出てきたはず(うろおぼえですが)です。
なので、まずはそちらを試してみるといいかもしれません。

もし、これでもできなかった場合、あるいは旧バージョンでなければならない場合は、以下を確認してみてください。

  • AndroidStudioのSDK Managerを確認し、該当のバージョンのSDKがインストールされているかどうか
  • UnityのEdit→Preferences...→External Toolsで、AndroidのSDKなどのパスが正しいかどうか

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2019/05/12 15:14

    失礼しました、unityは2019.1.0f2です。
    HubのSDK/NDKは公式で提示されている位置にちゃんとあり、パスをこちらに切り替えことも試したのですが同じエラーが出ました。
    下記のアドバイスについても確認しましたが特にミスは見当たりませんでした……

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.13%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

同じタグがついた質問を見る