質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.51%

  • Ruby on Rails

    8872questions

    Ruby on Railsは、オープンソースのWebアプリケーションフレームワークです。「同じことを繰り返さない」というRailsの基本理念のもと、他のフレームワークより少ないコードで簡単に開発できるよう設計されています。

  • Linux

    4444questions

    Linuxは、Unixをベースにして開発されたオペレーティングシステムです。日本では「リナックス」と呼ばれています。 主にWebサーバやDNSサーバ、イントラネットなどのサーバ用OSとして利用されています。 上位500のスーパーコンピュータの90%以上はLinuxを使用しています。 携帯端末用のプラットフォームAndroidは、Linuxカーネル上に構築されています。

【Ruby on Rails】gem update --systemが出来ない

受付中

回答 0

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 72

gk_

score 0

初質問です。何か足りない点があればご教示ください。よろしくお願いします。

前提・実現したいこと

rails serverを立ち上げたいのですが、

The `rails' command exists in these Ruby versions:


が出てしまったため、

gem update --system


としたところ以下のエラーが出てしまいます。

発生している問題・エラーメッセージ

Traceback (most recent call last):
    4: from <internal:gem_prelude>:2:in `<internal:gem_prelude>'
    3: from <internal:gem_prelude>:2:in `require'
    2: from /Users/ユーザー名/.rbenv/versions/2.5.0-dev/lib/ruby/site_ruby/2.6.0/rubygems.rb:1395:in `<top (required)>'
    1: from /Users/ユーザー名/.rbenv/versions/2.5.0-dev/lib/ruby/site_ruby/2.6.0/rubygems/core_ext/kernel_require.rb:59:in `require'
/Users/ユーザー名/.rbenv/versions/2.5.0-dev/lib/ruby/site_ruby/2.6.0/rubygems/core_ext/kernel_require.rb:59:in `require': cannot load such file -- rubygems/core_ext/kernel_warn (LoadError)
  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正の依頼

  • otn

    2019/05/12 11:18

    > /2.5.0-dev/
    何故こんなバージョンが?

    キャンセル

  • gk_

    2019/05/12 11:43 編集

    コメントありがとうございます!
    これは過去に一度、railsの勉強をした時にインストールしたものかと思うのですが、バージョンが古いことでgem update --systemが出来ないということでしょうか?

    キャンセル

  • CHERRY

    2019/05/17 17:06

    まずは、安定版の 2.6.3 か 2.5.5 をインストールしてから、rails をインストールすることをおすすめします。

    キャンセル

  • otn

    2019/05/18 01:16

    古いというか、開発版(基本的には、Ruby自体やライブラリを開発している人が使うもの)なので、2.5.0-devをアンインストールして、-dev や RC のつかない2.5.xか2.6.xの最新版を使いましょう。

    キャンセル

まだ回答がついていません

同じタグがついた質問を見る

  • Ruby on Rails

    8872questions

    Ruby on Railsは、オープンソースのWebアプリケーションフレームワークです。「同じことを繰り返さない」というRailsの基本理念のもと、他のフレームワークより少ないコードで簡単に開発できるよう設計されています。

  • Linux

    4444questions

    Linuxは、Unixをベースにして開発されたオペレーティングシステムです。日本では「リナックス」と呼ばれています。 主にWebサーバやDNSサーバ、イントラネットなどのサーバ用OSとして利用されています。 上位500のスーパーコンピュータの90%以上はLinuxを使用しています。 携帯端末用のプラットフォームAndroidは、Linuxカーネル上に構築されています。