質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.51%

  • Linux

    4444questions

    Linuxは、Unixをベースにして開発されたオペレーティングシステムです。日本では「リナックス」と呼ばれています。 主にWebサーバやDNSサーバ、イントラネットなどのサーバ用OSとして利用されています。 上位500のスーパーコンピュータの90%以上はLinuxを使用しています。 携帯端末用のプラットフォームAndroidは、Linuxカーネル上に構築されています。

  • Ubuntu

    1810questions

    Ubuntuは、Debian GNU/Linuxを基盤としたフリーのオペレーティングシステムです。

  • Docker

    1049questions

    Dockerは、Docker社が開発したオープンソースのコンテナー管理ソフトウェアの1つです

  • GitLab

    158questions

    GitLabは Gitoliteをブラウザから管理できるようにする Rubyアプリケーションで、 GitHubのようなサービスをクローズドな環境に独自で構築できるように 公開されたものです。

  • Gitlab CE

    22questions

    GitLabのオープンソース版で、Community Editionのこと。 deb、rpmパッケージで提供されており、比較的簡単にインストールすることができます。

gitlab-runnnerによって作成されるDocker内でapt-getがconnection timed outになる。

解決済

回答 1

投稿

  • 評価
  • クリップ 0
  • VIEW 115

KIRIN3

score 1

プロキシ環境内でDockerを使用してgitlab-ce,gitlab-runnerを起動し、AndroidソースのpushをキーにCIを動かそうとしているのですが、
$ apt-get --quiet update --yes
が、connection timed out になってしまいます。

Running with gitlab-runner 11.10.0 (3001a600)
  on Android Docker Runner FZ2oQXZW
Using Docker executor with image openjdk:8-jdk ...
Using locally found image version due to if-not-present pull policy
Using docker image sha256:b8d3f94869bbbcf89afa5f3d4cb18b9e53dff94fb7200729796abc026600087f for openjdk:8-jdk ...
Running on runner-FZ2oQXZW-project-3-concurrent-0 via a8b5fb814960...
Reinitialized existing Git repository in /builds/FZ2oQXZW/0/gitlab/example/apptest001/.git/
Fetching changes...
Checking out c95afeec as master...

Skipping Git submodules setup
$ apt-get --quiet update --yes
Err:1 http://security.debian.org/debian-security stretch/updates InRelease
  Could not connect to prod.debian.map.fastly.net:80 (151.101.228.204), connection timed out Could not connect to security.debian.org:80 (133.242.99.74), connection timed out
Err:2 http://deb.debian.org/debian stretch InRelease
  Could not connect to prod.debian.map.fastly.net:80 (151.101.228.204), connection timed out Could not connect to deb.debian.org:80 (5.153.231.4), connection timed out [IP: 5.153.231.4 80]
Err:3 http://deb.debian.org/debian stretch-updates InRelease
  Unable to connect to deb.debian.org:http: [IP: 5.153.231.4 80]
Reading package lists...
W: Failed to fetch http://deb.debian.org/debian/dists/stretch/InRelease  Could not connect to prod.debian.map.fastly.net:80 (151.101.228.204), connection timed out Could not connect to deb.debian.org:80 (5.153.231.4), connection timed out [IP: 5.153.231.4 80]
W: Failed to fetch http://security.debian.org/debian-security/dists/stretch/updates/InRelease  Could not connect to prod.debian.map.fastly.net:80 (151.101.228.204), connection timed out Could not connect to security.debian.org:80 (133.242.99.74), connection timed out
W: Failed to fetch http://deb.debian.org/debian/dists/stretch-updates/InRelease  Unable to connect to deb.debian.org:http: [IP: 5.153.231.4 80]
W: Some index files failed to download. They have been ignored, or old ones used instead.
$ apt-get --quiet install --yes wget tar unzip lib32stdc++6 lib32z1
Reading package lists...
Building dependency tree...
Reading state information...
E: Unable to locate package lib32stdc++6
E: Couldn't find any package by regex 'lib32stdc++6'
E: Unable to locate package lib32z1
ERROR: Job failed: exit code 1

.gitlab-ci.ymlはAndroid用のテンプレートのままです

# This file is a template, and might need editing before it works on your project.
# Read more about this script on this blog post https://about.gitlab.com/2018/10/24/setting-up-gitlab-ci-for-android-projects/, by Jason Lenny
# If you are interested in using Android with FastLane for publishing take a look at the Android-Fastlane template.

image: openjdk:8-jdk

variables:
  ANDROID_COMPILE_SDK: "28"
  ANDROID_BUILD_TOOLS: "28.0.2"
  ANDROID_SDK_TOOLS:   "4333796"

before_script:
  - apt-get --quiet update --yes
  - apt-get --quiet install --yes wget tar unzip lib32stdc++6 lib32z1
  - wget --quiet --output-document=android-sdk.zip https://dl.google.com/android/repository/sdk-tools-linux-${ANDROID_SDK_TOOLS}.zip
  - unzip -d android-sdk-linux android-sdk.zip
  - echo y | android-sdk-linux/tools/bin/sdkmanager "platforms;android-${ANDROID_COMPILE_SDK}" >/dev/null
  - echo y | android-sdk-linux/tools/bin/sdkmanager "platform-tools" >/dev/null
  - echo y | android-sdk-linux/tools/bin/sdkmanager "build-tools;${ANDROID_BUILD_TOOLS}" >/dev/null
  - export ANDROID_HOME=$PWD/android-sdk-linux
  - export PATH=$PATH:$PWD/android-sdk-linux/platform-tools/
  - chmod +x ./gradlew
  # temporarily disable checking for EPIPE error and use yes to accept all licenses
  - set +o pipefail
  - yes | android-sdk-linux/tools/bin/sdkmanager --licenses
  - set -o pipefail

stages:
  - build
  - test

lintDebug:
  stage: build
  script:
    - ./gradlew -Pci --console=plain :app:lintDebug -PbuildDir=lint

assembleDebug:
  stage: build
  script:
    - ./gradlew assembleDebug
  artifacts:
    paths:
    - app/build/outputs/

debugTests:
  stage: test
  script:
    - ./gradlew -Pci --console=plain :app:testDebug


プロキシを疑い

mkdir /etc/systemd/system/docker.service.d
vi /etc/systemd/system/docker.service.d/http-proxy.conf

[Service]
Environment="HTTP_PROXY=http://XXXXX/" "HTTPS_PROXY=http://XXXXX/" "NO_PROXY=docker:2375,docker:2376"


systemctl daemon-reload
systemctl restart docker

vi /etc/docker/daemon.json

{
"dns": ["nameserver-ip-address"],
"dns-search": ["search-url"]
}

vi /etc/resolve.conf

{
"dns": ["nameserver-ip-address"],
"dns-search": ["search-url"]
}

vi /etc/default/docker

export http_proxy=http://XXXXX/
export https_proxy=http://XXXXX/
export HTTP_PROXY=http://XXXXX/
export HTTPS_PROXY=http://XXXXX/


vi ~/.docker/config.json

{
        "proxies":
        {
                "default":
                {
                        "httpProxy": "http://XXXXX/",
                        "httpsProxy": "http://XXXXX/",
                        "noProxy": "docker:2375,docker:2376"
                }
        }
}

とホストマシン内で試行錯誤しましたが、効果ありませんでした。
動的に作成される、openjdk:8-jdk内のDocker内では特に何もしていません。

宜しくお願い致します。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

checkベストアンサー

0

Dockerというよりは使っているイメージ(多分Debianベースですよね)の中で動いてるaptのエラーを見るべきかと思います。

https://www.digitalocean.com/community/questions/why-can-t-i-install-the-libstdc-6-i386-library-on-my-x64-ubuntu-droplet このへんを参考に解決できないでしょうか?

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2019/05/14 11:05

    情報、サイトどちらも参考になりました。
    一つ一つ手動で叩いて、aptのエラーを見て修正してを繰り返しています。
    その結果、調べるべき範囲が広くなりすぎたので、もう少し自分で調べていこうと思います。
    標準のサンプルだからと容易に動くものではなかったようですね。
    回答ありがとうございました。

    キャンセル

同じタグがついた質問を見る

  • Linux

    4444questions

    Linuxは、Unixをベースにして開発されたオペレーティングシステムです。日本では「リナックス」と呼ばれています。 主にWebサーバやDNSサーバ、イントラネットなどのサーバ用OSとして利用されています。 上位500のスーパーコンピュータの90%以上はLinuxを使用しています。 携帯端末用のプラットフォームAndroidは、Linuxカーネル上に構築されています。

  • Ubuntu

    1810questions

    Ubuntuは、Debian GNU/Linuxを基盤としたフリーのオペレーティングシステムです。

  • Docker

    1049questions

    Dockerは、Docker社が開発したオープンソースのコンテナー管理ソフトウェアの1つです

  • GitLab

    158questions

    GitLabは Gitoliteをブラウザから管理できるようにする Rubyアプリケーションで、 GitHubのようなサービスをクローズドな環境に独自で構築できるように 公開されたものです。

  • Gitlab CE

    22questions

    GitLabのオープンソース版で、Community Editionのこと。 deb、rpmパッケージで提供されており、比較的簡単にインストールすることができます。