質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

87.33%

MySQLエラーの解決方法を教えていただけないでしょうか?

解決済

回答 1

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 801

score 162

Capistrano3でRailsアプリをデプロイしている最中です。
開発中にはなにも問題がでなかったのですが、デプロイ実行中に「bundle exec rake db:migrate」を実行していますが

Mysql2::Error: Invalid default value for 'member_type': CREATE TABLE customers

というエラーが出てデプロイが止まってしまいます。
customersテーブルのmember_typeカラムのデフォルト値のところのエラーなのでしょうが、何が悪くてエラーとなってしまったのかわかりません。マイグレーションファイルの中身は以下のようになっています。

20170817225634_create_customers.rb

class CreateCustomers < ActiveRecord::Migration[5.1]
  def change
    create_table :customers do |t|
      t.string :email, null: false            # メールアドレス
      t.string :email_for_index, null: false  # 索引用メールアドレス
      t.string :family_name, null: false      # 姓
      t.string :given_name, null: false       # 名
      t.string :family_name_kana, null: false # 姓(カナ)
      t.string :given_name_kana, null: false  # 名(カナ)
      t.string :nickname, null: false         # ニックネーム
      t.string :gender                        # 性別
      t.date :birthday                        # 誕生日
      t.string :hashed_password               # パスワード
      t.string :sponsor1, null: false, default: "sss"  # 友人
      t.string :member_type, null: false, default: "一般"   # ここでエラー発生
      t.string :lock, null: false, default: "0"
      t.string :bonus_lock, null: false, default: "0"
      t.string :special_lock, null: false, default: "0"
      t.integer :new_register, null: false, default: 0

      t.timestamps
    end

    add_index :customers, :email_for_index, unique: true
    add_index :customers, :nickname, unique: true
    add_index :customers, [ :family_name_kana, :given_name_kana ]
    add_index :customers, :sponsor1
    add_index :customers, :member_type
    add_index :customers, :new_register
  end
end


開発中は何も問題はなかったのですが、何がいけないのでしょうか?
どなたかご教示お願いいたします。

追記(エンコードを調べてみました。)

仮想マシン側
+--------------------------+----------------------------+
| Variable_name            | Value                      |
+--------------------------+----------------------------+
| character_set_client     | utf8                       |
| character_set_connection | utf8                       |
| character_set_database   | latin1                     |
| character_set_filesystem | binary                     |
| character_set_results    | utf8                       |
| character_set_server     | latin1                     |
| character_set_system     | utf8                       |
| character_sets_dir       | /usr/share/mysql/charsets/ |
+--------------------------+----------------------------+
VPS側(変更前)
+--------------------------+----------------------------+
| Variable_name            | Value                      |
+--------------------------+----------------------------+
| character_set_client     | latin1                     |
| character_set_connection | latin1                     |
| character_set_database   | latin1                     |
| character_set_filesystem | binary                     |
| character_set_results    | latin1                     |
| character_set_server     | latin1                     |
| character_set_system     | utf8                       |
| character_sets_dir       | /usr/share/mysql/charsets/ |
+--------------------------+----------------------------+

変更後
+--------------------------+----------------------------+
| Variable_name            | Value                      |
+--------------------------+----------------------------+
| character_set_client     | latin1                     |
| character_set_connection | latin1                     |
| character_set_database   | utf8mb4                    |
| character_set_filesystem | binary                     |
| character_set_results    | latin1                     |
| character_set_server     | utf8mb4                    |
| character_set_system     | utf8                       |
| character_sets_dir       | /usr/share/mysql/charsets/ |
+--------------------------+----------------------------+

vim /etc/my.cnf.d/server.cnfを開いて[mysqld]の下にcharacter-set-server = utf8mb4を追記して

character_set_databaseとcharacter_set_serverは変更することができました。
しかしcharacter_set_clientとcharacter_set_connectionの変更ができていません。

vim /etc/my.cnf.d/server.cnfを開くと

#
# These groups are read by MariaDB server.
# Use it for options that only the server (but not clients) should see
#
# See the examples of server my.cnf files in /usr/share/mysql/
#

# this is read by the standalone daemon and embedded servers
[server]

# this is only for the mysqld standalone daemon
[mysqld]
character-set-server = utf8mb4

# this is only for embedded server
[embedded]

# This group is only read by MariaDB-5.5 servers.
# If you use the same .cnf file for MariaDB of different versions,
# use this group for options that older servers don't understand
[mysqld-5.5]

# These two groups are only read by MariaDB servers, not by MySQL.
# If you use the same .cnf file for MySQL and MariaDB,
# you can put MariaDB-only options here
[mariadb]

[mariadb-5.5]


と表示されます。
上のファイルのどこにエンコード変更の記述をすればcharacter_set_clientとcharacter_set_connectionの
エンコードを変更することができるのでしょうか?

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正、ベストアンサー選択の依頼

  • CHERRY

    2019/04/23 23:10

    一般を Normal のように英数字(ASCII)に変えたら状況は変わりますか?


    変わるのであれば、データベースのエンコードは何でしょうか?

    キャンセル

  • koume

    2019/04/24 01:21

    回答ありがとうございます。エンコードの変更ができていないのに気づきエンコードを変更しましたが、
    一部、変更する方法がわからなかったので、その部分を追記いたしました。
    お手数をおかけしますが、ご教示のほどよろしくお願いします。
    エンコードの変更完了後に試してみたいとおもいます。

    キャンセル

  • koume

    2019/04/24 21:39

    CHERRY様
    回答をいただいた件で、normal と打ち込んで実行すると大丈夫でした。
    エンコードは以下のようにしています。
    +--------------------------+----------------------------+
    | Variable_name | Value |
    +--------------------------+----------------------------+
    | character_set_client | utf8mb4 |
    | character_set_connection | utf8mb4 |
    | character_set_database | utf8mb4 |
    | character_set_filesystem | binary |
    | character_set_results | utf8mb4 |
    | character_set_server | utf8mb4 |
    | character_set_system | utf8 |
    | character_sets_dir | /usr/share/mysql/charsets/ |
    +--------------------------+----------------------------+
    このままだと、カラム値に日本語を受け付けないデータベースになってしまうので問題です。
    あと、そのほかにチェックするべきポイントはありますでしょうか?
    よろしくお願いします。

    キャンセル

回答 1

check解決した方法

0

vim /etc/my.cnf.d/server.cnf で開いて

[client]
default-character-set = utf8mb4

を追記して再起動をかけると
+--------------------------+----------------------------+
| Variable_name            | Value                      |
+--------------------------+----------------------------+
| character_set_client     | utf8mb4                    |
| character_set_connection | utf8mb4                    |
| character_set_database   | utf8mb4                    |
| character_set_filesystem | binary                     |
| character_set_results    | utf8mb4                    |
| character_set_server     | utf8mb4                    |
| character_set_system     | utf8                       |
| character_sets_dir       | /usr/share/mysql/charsets/ |
+--------------------------+----------------------------+

になりました。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 87.33%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る