質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

89.52%

rails slim エラー? undefined not callable

受付中

回答 2

投稿

  • 評価
  • クリップ 0
  • VIEW 434

naoki10

score 31

Rails エラーの理由が分かりません。

発生している問題・エラーメッセージ

webブラウザで開くと下記メッセージが表示されます。

ExecJS::ProgramError in Tasks#index
Showing C:/r_r/scaffold_app/app/views/layouts/application.html.slim where line #8 raised:

undefined not callable
Rails.root: C:/r_r/scaffold_app

Application Trace | Framework Trace | Full Trace
(execjs):1
app/views/layouts/application.html.slim:8:in `_app_views_layouts_application_html_slim__622682_88570600'
Request
Parameters:

None
Toggle session dump
Toggle env dump
Response
Headers:

None

該当のソースコード

doctype html
html
  head
    title
      | Taskleaf
    = csrf_meta_tags
    = csp_meta_tag
    = stylesheet_link_tag    'application', media: 'all', 'data-turbolinks-track': 'reload'
    = javascript_include_tag 'application', 'data-turbolinks-track': 'reload'
  body
    .app-title.navbar-expand-md.navbar-light.bg.light
    .navbar-brand Taskleaf
    .container
     = yield

試したこと

https://shiva-duke.hatenablog.com/entry/2018/10/19/003345 に記載されている
gemfile から duktape を消すを実施しました。
その他情報には調べてもたどりつけなかったです。

補足情報(FW/ツールのバージョンなど)

ruby 2.4.5p335 (2018-10-18 revision 65137) [x64-mingw32]
Rails 5.2.3

よろしくお願いいたします。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 2

0

bundle install を実行してみてください

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2019/04/22 22:01

    bundle install後 rails s をして再度読み込みましたが同じように表示されます。
    すみません。

    PS C:\r_r\scaffold_app> bundle install
    Using rake 12.3.2
    Using concurrent-ruby 1.1.5
    Using i18n 1.6.0
    Using minitest 5.11.3
    Using thread_safe 0.3.6
    Using tzinfo 1.2.5
    Using activesupport 5.2.3
    Using builder 3.2.3
    Using erubi 1.8.0
    Using mini_portile2 2.4.0
    Using nokogiri 1.10.2 (x64-mingw32)
    Using rails-dom-testing 2.0.3
    Using crass 1.0.4
    Using loofah 2.2.3
    Using rails-html-sanitizer 1.0.4
    Using actionview 5.2.3
    Using rack 2.0.7
    Using rack-test 1.1.0
    Using actionpack 5.2.3
    Using nio4r 2.3.1
    Using websocket-extensions 0.1.3
    Using websocket-driver 0.7.0
    Using actioncable 5.2.3
    Using globalid 0.4.2
    Using activejob 5.2.3
    Using mini_mime 1.0.1
    Using mail 2.7.1
    Using actionmailer 5.2.3
    Using activemodel 5.2.3
    Using arel 9.0.0
    Using activerecord 5.2.3
    Using mimemagic 0.3.3
    Using marcel 0.3.3
    Using activestorage 5.2.3
    Using public_suffix 3.0.3
    Using addressable 2.6.0
    Using io-like 0.3.0
    Using archive-zip 0.12.0
    Using execjs 2.7.0
    Using autoprefixer-rails 9.5.1
    Using bindex 0.7.0
    Using msgpack 1.2.10 (x64-mingw32)
    Using bootsnap 1.4.3
    Using popper_js 1.14.5
    Using method_source 0.9.2
    Using thor 0.20.3
    Using railties 5.2.3
    Using ffi 1.10.0 (x64-mingw32)
    Using sassc 2.0.1
    Using sprockets 3.7.2
    Using sprockets-rails 3.2.1
    Using tilt 2.0.9
    Using sassc-rails 2.1.0
    Using bootstrap 4.3.1
    Using bundler 2.0.1
    Using byebug 11.0.1
    Using regexp_parser 1.4.0
    Using xpath 3.2.0
    Using capybara 3.17.0
    Using childprocess 1.0.1
    Using chromedriver-helper 2.1.1
    Using coffee-script-source 1.12.2
    Using coffee-script 2.4.1
    Using coffee-rails 4.2.2
    Using duktape 2.0.1.0
    Using hpricot 0.8.6
    Using html2slim 0.2.0
    Using multi_json 1.13.1
    Using jbuilder 2.8.0
    Using puma 3.12.1
    Using rails 5.2.3
    Using rails-i18n 5.1.3
    Using rb-fsevent 0.10.3
    Using rb-inotify 0.10.0
    Using rubyzip 1.2.2
    Using sass-listen 4.0.0
    Using sass 3.7.4
    Using sass-rails 5.0.7
    Using selenium-webdriver 3.141.5926
    Using temple 0.8.1
    Using slim 4.0.1
    Using slim-rails 3.2.0
    Using sqlite3 1.3.13 (x64-mingw32)
    Using turbolinks-source 5.2.0
    Using turbolinks 5.2.0
    Using tzinfo-data 1.2019.1
    Using uglifier 4.1.20
    Using web-console 3.7.0
    Bundle complete! 20 Gemfile dependencies, 88 gems now installed.
    Use `bundle info [gemname]` to see where a bundled gem is installed.

    キャンセル

0

gemfileのexecjsをtherubyracerに書き換えてbundle install後に実行するとどうでしょうか?

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 89.52%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる